LINUX.ORG.RU

Nat Network на Virtualbox

 , ,


0

2

Доброго времени суток форумчане. Столкнулся с проблемой настройки NAT сети в virtualbox. Нужно создать окружение в котором все виртуальные машины будут находиться в подсети и доступны друг другу только на этом уровне. Настройки NAT сети стоят по умолчанию. Внутренние IP адреса машин 10.0.х.15 но интернета машина не видит. Как мне добиться желаемого?

все виртуальные машины будут находиться в подсети

В какой подсети? Ты понимаешь отличие понятие сеть и подсеть?

Внутренние IP адреса машин 10.0.х.15 но интернета машина не видит.

Эти IP адреса машина сама получила вместе с параметром шлюза и DNS сервера или ты прописал их руками?

Шлюз за NAT пингуется? DNS от google, 8.8.8.8?

Какое подключение к сети Internet (провайдера) на хост системе? Случаем нет VPN, ppp?

kostik87 ★★★★★ ()

тебе нужно, чтобы за 10.0.х.15 отвечал роутер, через который, в эту сеть, будет просачиваться интернет.
самый простой способ — это взять физическую железку, которую все так и называют «роутер» и создать там подсеть для 10.0.х.15.
можно создать всякую мудрёную маршрутизацию интернета в 10.0.х.15 прямо на компе где запущенны виртуалки.
ещё можно одну из виртуалок в 10.0.х.15 сделать роутером\шлюзом и выдать ей интернетов, чтобы просачивалось к другим.

system-root ★★★★★ ()
Ответ на: комментарий от system-root

В VirtualBox, так же как и в Vmware есть свои виртуальные адаптеры и способы коммутации этих сетей к сети Host системы: Bridge, NAT и внутренняя сеть.

Ничего дополнительно ставить не нужно.

kostik87 ★★★★★ ()

Надо что-то настроить в соответсвии с настройками имеющегося выхода в интернет.

fornlr ★★★★★ ()
Ответ на: комментарий от kostik87

Я в сетях нуб если чо.) Подключение к сети по pppoe. Руками я ничего не настраивал. В дефолтных настройках Netwok CIDR прописано 10.0.2.0/24

Hokugava ()

Подумайте на тему 192.168.56.1 сделать шлюзом для остальных, в той же 192.168.56.0/24 что ли.

Infra_HDC ★★★★★ ()
Ответ на: комментарий от Hokugava

Подключение к сети по pppoe

Ну вот в этом и проблема, скорее всего.

Пакеты из NAT сети не «пролазят» в pppoe канал, т.к. в pppoe размер кадра (MTU) где-то 1400, а в обычной сети 1500.

Так что надо как-то указать, что размер MTU 1400 на сетевом адаптере в виртуальной системе.

kostik87 ★★★★★ ()
Ответ на: комментарий от Hokugava

Ты можешь это сделать либо в настройках операционной системы запущенной в виртуальной машине, т.е. Linux.

Либо поправить параметры виртуальной машины, попробуй вот это: https://www.virtualbox.org/manual/ch09.html#nat-adv-settings

Либо вот ещё есть: https://forums.virtualbox.org/viewtopic.php?f=7&t=61589#p287271

Но 100% будет работать, если ты изменишь настройки адаптера в загруженной операционной системе.

Попробуй для теста что-то вроде:

ifconfig интерфейс mtu 1400
ip link set dev интерфейс mtu 1400
но это только для теста.

Возможно, mtu придётся выставить ниже.

Если у тебя там Windows, то mtu настраивается в свойствах сетевого адаптера Windows.

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)
Ответ на: комментарий от kostik87

Получается из-за этой особенности протокола нужно будет в каждой новой виртуальной машине прописывать настройки адаптера?

Hokugava ()
Ответ на: комментарий от Hokugava

Да. Почитай как в конкретном Linux указывается настройка MTU для адаптера.

Если бы нат настраивался стандартными средствами Linux, т.е. iptables, то там можно было бы настроить согласование MTU.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

Понял. Отпишусь, как получу положительный результат. Еще раз спасыб

Hokugava ()
Ответ на: комментарий от Hokugava

Шлюз пингуется?

Мту ниже пробовал выставлять?

Попробую вместо кали любой другой нормальный дистрибутив.

Ну и просто шлюз пингуется?

kostik87 ★★★★★ ()

Нужно создать окружение в котором все виртуальные машины будут находиться в подсети и доступны друг другу только на этом уровне.

Там же есть тип подключения «Виртуальный адаптер хоста». Указываешь в настройках VirtualBox для него адрес и маску, включаешь там же DHCP с указанием диапазона адресов и указываешь этот виртуальный адаптер во всех нужных виртуалках.

Файл > Настройки > Сеть > Вкладка «Виртуальные сети хоста»

VB при запуске будет поднимать DHCP для выдачи адресов виртуалках. Там по дефолту вроде 192.168.56.0/24 сеть.

Radjah ★★★★★ ()
Ответ на: комментарий от Hokugava
9.11.3. Tuning TCP/IP buffers for NAT
The VirtualBox NAT stack performance is often determined by its interaction with the host's TCP/IP stack and the size of several buffers (SO_RCVBUF and SO_SNDBUF). For certain setups users might want to adjust the buffer size for a better performance. This can by achieved using the following commands (values are in kilobytes and can range from 8 to 1024):

VBoxManage modifyvm «VM name» --natsettings1 16000,128,128,0,0
This example illustrates tuning the NAT settings. The first parameter is the MTU, then the size of the socket's send buffer and the size of the socket's receive buffer, the initial size of the TCP send window, and lastly the initial size of the TCP receive window. Note that specifying zero means fallback to the default value.

Each of these buffers has a default size of 64KB and default MTU is 1500.

Вот это пробовал https://www.virtualbox.org/manual/ch09.html#nat-adv-settings делать? Только MTU в команде укажи правильный.

Т.е. нужно выполнить что-то вроде:

VBoxManage modifyvm "linux" --natsettings1 1400,128,128,0,0
И в файл vbox должна появиться секция:
      <Network>
        <Adapter slot="0" enabled="true" MACAddress="************" type="*******">
          <NAT mtu="1400" sockrcv="128" socksnd="128"/>
        </Adapter>
      </Network>
VBoxManage может не быть в переменной PATH.

kostik87 ★★★★★ ()
Ответ на: комментарий от Radjah

Вообще для данной задачи это «Сеть Nat» (не путать с «Nat»).

anonymous ()
Ответ на: комментарий от kostik87

Шлюз пингуется. Стал пинговаться после modifyvm. При запущенном VB команда не срабатывает. Пробовал выставлять MTU ниже. Не помогает.

Hokugava ()
Ответ на: комментарий от Hokugava

В хостовой системе будет сетевой интерфейс с адресом 192.168.56.1 или какой задашь в настройках. В интернеты выход уже надо будет руками настраивать. Форвардинг, прокси, на что фантазии хватит.

Radjah ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.