LINUX.ORG.RU

Обновление hwe в убунту - удаление нужных пакетов.

 


0

1

Доброго времени суток. Нужно обновить hwe, которое по факту решает ряд проблем. Но при обновлении часть пакетов удаляется. Как бы сделать так, чтобы эти пакеты не конфликтовали?

По факту мне нужно: bumblebee bumblebee-nvidia. У меня i7-3730qm и nvidia geforce 730m.

https://pastebin.com/f5R3qd8W

Про hwe читать тут: https://wiki.ubuntu.com/Kernel/LTSEnablementStack

p.s. Решение: https://github.com/Bumblebee-Project/Bumblebee/issues/857

★★

Про hwe читать тут

осталось прочитать man apt-mark

novitchok ★★★★★ ()
Ответ на: комментарий от BitSum

Apt-mark тут ничем не поможет. Убунта хочет стереть пакеты, для которых, после предстоящего обновления, не будут удовлетворятся зависмости (могу ошибаться). Как минимум, к списку устанавливаемого нужно добавить xserver-xorg-video-all-hwe-16.04 (apt, между прочим, предлагает тебе его установить в секции recommends!), тогда bumblebee, скорее всего не будет удаляться. Вообще, лучше устанавливай с флагом --install-recommends, мало ли, чего еще не установится.

Насчет остального хз, есть вероятность какому-то пакету требуется именно старая версия иксов/дров/ядра и с новым он работать не захочет.

anonymous ()
Ответ на: комментарий от anonymous

Как минимум, к списку устанавливаемого нужно добавить xserver-xorg-video-all-hwe-16.04 (apt, между прочим, предлагает тебе его установить в секции recommends!

В том то и дело. Что даже имея то, что я хотел установить - по минимуму, мне предлагают удалить бамболби.

BitSum ★★ ()

Для решения сложных ситуаций с зависимостями есть очень удобная штука - aptitude.

erfea ★★★★★ ()
Ответ на: комментарий от BitSum

Вот сейчас я тебя не понимаю. Ты хочешь xserver-xorg-hwe, но при этом оставить старый xserver-xorg-video-*? Так не получится.

Или что, даже при добавлении xserver-xorg-video-all-hwe-16.04 apt хочет удалить bumblbee? В таком случае погугли bumblbee hwe - может на такой случай нужно какой-то ppa подключать.

anonymous ()
Ответ на: комментарий от anonymous

Вот сейчас я тебя не понимаю. Ты хочешь xserver-xorg-hwe, но при этом оставить старый xserver-xorg-video-*? Так не получится.

Я не хочу старый оставлять. Мне нужен бамболби, который удаляется при использлвании: apt-get install --install-recommends linux-generic-hwe-16.04 xserver-xorg-hwe-16.04

Это и есть моя проблема - во время обновлении ядра и иксов удаляется бамболби.

BitSum ★★ ()
Ответ на: комментарий от anonymous

Или что, даже при добавлении xserver-xorg-video-all-hwe-16.04 apt хочет удалить bumblbee? В таком случае погугли bumblbee hwe - может на такой случай нужно какой-то ppa подключать.

Спасибо, ответ дам в ближайшие полтора часа.

BitSum ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.