LINUX.ORG.RU

Проблема с зайпуском perl скриптов

 , ,


0

1

Делал все по этой статье https://habrahabr.ru/post/264617/ . Все шло более менее нормально. Вместо php5 и всего остального , поставил LAMP как здесь сказано сдесь http://help.ubuntu.ru/wiki/lamp_%D0%BD%D0%B0_ubuntu_server_16.04. При перезагрузке апача была ошибка :

-- Начат процесс запуска юнита apache2.service.
ноя 28 13:48:45 rkBlack apache2[2729]:  * Starting Apache httpd web server apache2
ноя 28 13:48:45 rkBlack apache2[2729]:  *
ноя 28 13:48:45 rkBlack apache2[2729]:  * The apache2 configtest failed.
ноя 28 13:48:45 rkBlack apache2[2729]: Output of config test was:
ноя 28 13:48:45 rkBlack apache2[2729]: apache2: Syntax error on line 219 of /etc/apache2/apache2.conf: Syntax error on line 39 of /etc/apache2/sites-enabled/000-default.conf: Expected </Directory> but saw </VirtualHost>
ноя 28 13:48:45 rkBlack apache2[2729]: Action 'configtest' failed.
ноя 28 13:48:45 rkBlack apache2[2729]: The Apache error log may have more information.
ноя 28 13:48:45 rkBlack systemd[1]: apache2.service: Control process exited, code=exited status=1
ноя 28 13:48:45 rkBlack systemd[1]: Failed to start LSB: Apache2 web server.

В фаил добавил /etc/apache2/sites-enabled/000-default.conf

</Directory>

В статье сказано :

И ещё нюанс: надо объяснить апачу что в дирректории /var/www/html/perl/ лежат скрипты и он может их исполнять. Для этого добавляем в файл /etc/apache2/sites-available/000-default.conf после строки DocumentRoot вот такой блок: <Directory «/var/www/html/perl»> AllowOverride All Options +ExecCGI Require all granted

У меня получилось :

  
      DocumentRoot /var/www/html

        <Directory "/var/www/html/perl">

        AllowOverride All

        Options +ExecCGI

        Require all granted
        </Directory>

После этого апач2 перезагрузился без проблем.

Далее сказано:

Теперь пробуем открыть в браузере адреса helpdesk/perl/index.cgi и helpdesk/php/index.php.

По адресу index.php заходит нормально.

А по адресу helpdesk/perl/index.cgi . Выводится просто текст

#!/usr/bin/perl print «Content-type: text/html\n\n»; print «<html>\n<body>\n»; print «<div style=\„width: 100%; font-size: 40px; font-weight: bold; text-align: center;\“>\n»; print «CGI Test Page»; print «\n</div>\n»; print «</body>\n</html>\n»;

Но если ввести адрес 192.168.1.191/perl/index.cgi . Получается скрипт отрабатывает, и я вижу следующие : CGI Test Page . Большими жирными буквами.

В гугле я зашел в тупик.

Вот тут https://unixforum.org/index.php?showtopic=94821 Что то похожее но я не знаю что за фаил .htaccess .

Вот тут http://forum.ubuntu.ru/index.php?topic=218426.0 я не понял что за фаил, и он не сказал что в конфигах подправил .

молодец, держи нас в курсе событий.

Anoxemian ★★★★★ ()
Ответ на: комментарий от Anoxemian

молодец, держи нас в курсе событий.

Вот просто интересно, о чем ты? Текст тс составил вполне адекватно, ты не в силах загрузить столько буков для обработки в мозг?
Или не в состоянии попросить доп инфы потому-что не шаришь в вопросе? Неужели отупение контингента лора добралось до 5зв?

LinuxDebian ★★★★ ()

А каким образом связаны «192.168.1.191» и «helpdesk»?

Если по адресу все ок, а по хостнейму нет - возможно настроен VirtualHost, и соответственно конфиг из «<Directory »/var/www/html/perl">", который есть в ОП нужно перенести в этот самый конфиг виртуалхоста

Kronick ()
Ответ на: комментарий от LinuxDebian

Текст тс составил вполне адекватно, ты не в силах загрузить столько буков для обработки в мозг?

Большинство проблем можно описать сжато - только самую соль. А вчитываться в ТС'овскую простыню, да к тому же еще по каким-то ссылкам ходить и там еще вчитываться... Нахрен кому это нужно?

Т.е. вместо того, чтобы четко сформулировать проблему и задань вопрос, ТС как бы предлагает нам заняться, так сказать, ресерчем его проблемы. А это уже совсем другая история, мазафака!

KernelPanic ()
Ответ на: комментарий от ilux

Спасибо!

Добавил строчку, заработало.

Спасибо.

Подправил 000-default.conf

<Directory «/var/www/html/perl»> AddHandler cgi-script .cgi AllowOverride All

Options +ExecCGI

Require all granted </Directory>

timhawx ()
Ответ на: комментарий от Kronick

Извините просто скопировал со статьи, у меня имя компьютера rkblack . Там должно было быть rkblack/perl/index.cgi и rkblack/php/index.php .

Я сделал как написал выше ilux, вроде заработало.

timhawx ()
Ответ на: комментарий от KernelPanic

Я расписал так изходя из своего опыта общения на форумах и с тех поддержкой. Яб мог написать что то типа «не работают перл скрипты», тут бы было куча ссылок как надо сделать, и куча вопросов «как настроил» «скинь логи» и т.д. Поэтому расписал максимально как я делал и для чего делал.

timhawx ()
Ответ на: комментарий от LinuxDebian

Очевидно, отупление настолько глубоко, что 3зв не видят, что некий школьник хватает syntax error в конфиге апача, о чем написаны тысячи статей и есть официальная дока. Загрузи в голову не только буквы но и знания, это полезная штука, правда в школе к этому относятся спустя рукава.

Anoxemian ★★★★★ ()
Ответ на: комментарий от Anoxemian

Я даже и не пытался, я апачем не пользуюсь. Просто меня твой типаж раздражает.

3зв

что это за новая херня? Задолбали своими молодежными сленгами.

LinuxDebian ★★★★ ()
Последнее исправление: LinuxDebian (всего исправлений: 1)
Ответ на: комментарий от Anoxemian

хватает syntax error в конфиге апача

Но он исправляет её прямо тут же в своём посте. Видимо, ты столько загрузил
полезных штук в свою голову, что для внимательности и вежливости места не осталось.

bass ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.