LINUX.ORG.RU

Аномально старые пакеты в ubuntu

 , ,


0

1

Здравствуйте

Копаюсь в пакетах убунты. Большинство более-менее новые. Но некоторые прям совсем древние попадаются. Например версия bareos от 2015 года. Qemu 1.2 (!!!).

Почему так? Что за пакеты-аномалии? И можно ли как-то безболезненно поставить новые версии?

★★★★★

Но некоторые прям совсем древние попадаются.

Вангую отсутствие мейнтейнера в убунте/дебиане, вероятно, в связи с утратой надобности/интереса. Возможно какие-нибудь неразрешимые баги не дают обновить.

И можно ли как-то безболезненно поставить новые версии?

Можно попробовать найти ppa, либо собрать самому.

Qemu 1.2

Это где такое? Вероятно ты перепуал 1:2.10 c 1.2.10. Не знаю, что обозначает цифра до двоеточия, но версия пакета точно идет после.

anonymous ()
Ответ на: комментарий от anonymous

Не знаю, что обозначает цифра до двоеточия, но версия пакета точно идет после

Оу. Спасибо, бро. 5 утра, красные глаза.. Проглядел ) Уже было собрался сносить бубунту из-за древнючей qemu

Вангую отсутствие мейнтейнера в убунте/дебиане

А вот тут сомнительно. Что bareos, что bacula - обе версии древние. Хотя проекты довольно-таки востревобанные.

makoven ★★★★★ ()
Ответ на: комментарий от makoven

На https://packages.ubuntu.com/ можешь найти больше инфы. Емнип, у дебиана тоже был какой-то сайт, там подробно писали что к чему, вплоть до того, почему не обновляется, если новая версяи давно вышла.

Наприер, вбив bareos и передя по ссылке https://launchpad.net/ubuntu/ source/bareos обнаружишь, что пакет собираются обновить к 18.04. Можешь попробовать стянуть оттуда исходники, и собрать на своей версии убунты.

bareos ... проекты довольно-таки востревобанные.

Судя по всего пяти багрепортам на https://bugs.launchpad.net/ubuntu/ source/bareos - востребованность минимальная. Если какой-то нужный тебе пакет давно не обновляется - попробуй написать баг репорт по поводу, если повезет, может и обновят.

anonymous ()

#ЗатоШтабильно

anonymous ()

И можно ли как-то безболезненно поставить новые версии?

sudo add-apt-repository ppa:jacob/virtualisation

qemu 1:2.10.1+dfsg-0~17.10~ppa0

Или ещё в каком-то PPA поискать. Я не пользуюсь, посмотрел первый нагугленный.

KRoN73 ★★★★★ ()

можно! возьму, собери и подай заявку на добавление в апстрим, не мужик чтоли!?!

darkenshvein ★★★★★ ()

Дело в том, что Canonical разрабатывает и поддерживает лишь ту часть пакетов, что находится в секции main. В то же время большая часть пакетов лежит в universe и поддерживается сильно по-разному: от более-менее до из рук вон плохо. Об исправлении уязвимостей даже не заикаюсь.

Хотя и в main есть пакеты, которые уже стадию окаменелости прошли: debian-installer, например.

Вот и приходится порой по помойкам всяческих Васянов (читай PPA) шарить.

anonymous ()
Ответ на: комментарий от Sunderland93

Приоритет пакета

А ещё 5 звёзд...

Число до двоеточия это эпоха. Нужна при, например, смене схемы нумерации версий, чтобы новая версия гарантированно была воспринята как большая, чем предыдущая.

anonymous ()
Ответ на: комментарий от anonymous

Ну, спасибо за объяснение. Я считал что это приоритет

Sunderland93 ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.