LINUX.ORG.RU

Re: vim, как заставить стрелки работать?

Проверь настройки терминала на посылку кодов стрелок.

gh0stwizard ★★★★★ ()
Ответ на: Re: vim, как заставить стрелки работать? от Teak

Re: vim, как заставить стрелки работать?

>P.S. Фрюха?

Я такое в слаке видел, правда и в vi, и в vim, если меня память не подводит, вылечилось подсовыванием vim'у конфига vimrc_example.vim из его же состава.

mr ★★ ()
Ответ на: Re: vim, как заставить стрелки работать? от gh0stwizard

Re: vim, как заставить стрелки работать?

> Проверь настройки терминала на посылку кодов стрелок.

В терминале эта проблема не наблюдается.. лишь в иксовых эмуляторах (xterm,konsole).. порылся в настройках консоле, ничего подобного не могу найти....

> :set nocompatible

А как нибудь без этого?

> P.S. Фрюха?

Слака..

anonymous ()

Re: vim, как заставить стрелки работать?

> Я такое в слаке видел, правда и в vi, и в vim, если меня память не подводит, вылечилось подсовыванием vim'у конфига vimrc_example.vim из его же состава.

На сколько я понял, в этом конфиге есть опция ":set nocompatible".. тоесть vim превращается в простой vi?.. если так, то есть ли другие способы обхода проблемы?

anonymous ()
Ответ на: Re: vim, как заставить стрелки работать? от anonymous

Re: vim, как заставить стрелки работать?

>На сколько я понял, в этом конфиге есть опция ":set nocompatible".. тоесть vim превращается в простой vi?.. если так, то есть ли другие способы обхода проблемы?

По-моему наоборот отдаляется от vi.

mr ★★ ()

Re: vim, как заставить стрелки работать?

> По-моему наоборот отдаляется от vi.

Ну, после введения этой команды, vim становится идентичным моему elvis'у в слаке (а он, вроде как, считается клоном именно vi, даже символическая ссылка на него идет в коробке под названием vi)...

anonymous ()
Ответ на: Re: vim, как заставить стрелки работать? от anonymous

Re: vim, как заставить стрелки работать?

Нет, nocompatible рекомендованная опция. Она стоит почти у всех.

"If you start Vim now, the 'compatible' option should be off. You can check it with this command: >

:set compatible?

If it responds with "nocompatible" you are doing well. If the response is "compatible" you are in trouble."

Iocr ()
Ответ на: Re: vim, как заставить стрелки работать? от anonymous

Re: vim, как заставить стрелки работать?

> А как нибудь без этого?

А зачем без этого? В .vimrc пропиши. Просто в Слаквари по идеологическим соображениям vim идёт ненастроенным. Но насколько я помню даже и там есть нормальный vimrc, надо его просто использовать.

Teak ★★★★★ ()
Ответ на: Re: vim, как заставить стрелки работать? от Iocr

Re: vim, как заставить стрелки работать?

> Нет, nocompatible рекомендованная опция. Она стоит почти у всех.

Ну, да будет так тогда, спасибо.

> А зачем без этого? В .vimrc пропиши. Просто в Слаквари по идеологическим соображениям vim идёт ненастроенным. Но насколько я помню даже и там есть нормальный vimrc, надо его просто использовать.

Да просто с ней меняется все поведение вима, что выглядит не правильно, когда имеется конкретная проблема.

anonymous ()
Ответ на: Re: vim, как заставить стрелки работать? от anonymous

Re: vim, как заставить стрелки работать?

Ну, вообще-то, терминал конечно надо настраивать. Но set nocompatible проще :) И никаких проблем не создаёт.

Teak ★★★★★ ()

Re: vim, как заставить стрелки работать?

гыгы :)

попробуй echo "set syntax on" >> ~/.vimrc и перезапусти vim

ему в общем нужен конфиг. без этого никак. или sample скопируй из /usr/**, и будет тебе счастье :)

unicsoid ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.