LINUX.ORG.RU

Проблема с locale в KDE 1.1


0

0

Наблюдается напонятная проблема в KDE 1.1: все сделано в соответствии с инструкциями (по адресу http://www.iplabs.ru/Linux/Article/index.html), но в приложениях KDE (как то Advanced Editor и иже с ними) отображаются русские буквы в совершенно непонятной кодировке: вместо буквы [й] отображается [ы], [ц]->[Ф], [у]->[Ц] и т.д. А вот в Netscape все отлично ! Такое ощущение, что KDE дважды перекодирует вводимые символы или перекодирует их в какую-то другую кодировку. Борюсь с проблемой уже день, но, увы, пока безрезультатно. Ставил программу kkb 0.2 - результат нулевой (при использовании "хакерских" кодировок вообще ничего не печатает по русски):-((. Очень прошу Вас помочь - ткнуть в man или в URL, или еще как на Ваше усмотрение. У меня стоит RedHat 5.2 на i386: Xfree86 v. 3.3.3 и необходимые updates для KDE. Конфигурация машины: Pentium II 400Mhz, 128Mb RAM, ATI RagePro 8Mb (Xpert&Work), Adaptec 2940U SCSI adapter, 4Gb SCSI HDD Western Digital. Под обычным twm менеджер

anonymous

Re: Проблема с locale в KDE 1.1

Это ошибка в XFree 3.3.3. Поставьте 3.3.3.1 и все будет хорошо.

anonymous ()

Re: Проблема с locale в KDE 1.1

anonymous ()

Re: Проблема с locale в KDE 1.1

"Хакерские" раскладки kkb нужны для ввода русских букв в тех и только приложениях, которые знают лишь Latin1: StarOffice, Applix, старый rxvt, nxterm, LyX. В "правильных" приложениях русские буквы вводятся обычными раскладками. В Вашем случае KDE просто отбражает символы 8859-5, - это ошибка XFree 3.3.3, исправляемая переходом на 3.3.3.1 (или назад на 3.3.2.3, если она под рукой). Можно установить только libX11.so.6.1 из 3.3.3.1 -все будет работать.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.