LINUX.ORG.RU

Gentoo не собирается nvidia-drivers

 , , ,


0

1

Понимаю, что вопрос платиновый, но всёже.
Собрал пока nouveau, чтобы создать тему

sh-4.4# emerge --ask nvidia-drivers

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] x11-drivers/nvidia-drivers-304.135 

Would you like to merge these packages? [Yes/No] y

>>> Verifying ebuild manifests
>>> Running pre-merge checks for x11-drivers/nvidia-drivers-304.135
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/4.11.1-gentoo/build
 * Found sources for kernel version:
 *     4.11.1-gentoo
 * Gentoo supports kernels which are supported by NVIDIA
 * which are limited to the following kernels:
 * <sys-kernel/gentoo-sources-4.10
 * <sys-kernel/vanilla-sources-4.10
 * 
 * You are free to utilize eapply_user to provide whatever
 * support you feel is appropriate, but will not receive
 * support as a result of those changes.
 * 
 * Do not file a bug report about this.
 * 
 * Checking for suitable kernel configuration options...                         [ ok ]

>>> Emerging (1 of 1) x11-drivers/nvidia-drivers-304.135::gentoo
 * NVIDIA-Linux-x86_64-304.135.run SHA256 SHA512 WHIRLPOOL size ;-) ...          [ ok ]
 * nvidia-settings-304.135.tar.bz2 SHA256 SHA512 WHIRLPOOL size ;-) ...          [ ok ]
 * Determining the location of the kernel source code
Бла-бла-бла
>>> Source configured.
>>> Compiling source in /var/tmp/portage/x11-drivers/nvidia-drivers-304.135/work ...
 * Preparing nvidia module
make -j1 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- 'LDFLAGS=-m elf_x86_64' ARCH=x86_64 IGNORE_CC_MISMATCH=yes V=1 SYSSRC=/usr/src/linux SYSOUT=/lib/modules/4.11.1-gentoo/build CC=x86_64-pc-linux-gnu-gcc clean module 
NVIDIA: calling KBUILD...
make -C /lib/modules/4.11.1-gentoo/build KBUILD_SRC=/usr/src/linux-4.11.1-gentoo \
-f /usr/src/linux-4.11.1-gentoo/Makefile modules
test -e include/generated/autoconf.h -a -e include/config/auto.conf || (               \
[b] echo >&2;                                                       \
echo >&2 "  ERROR: Kernel configuration is invalid.";           \
echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\
echo >&2 "         Run 'make oldconfig && make prepare' on kernel src to fix it.";     \
echo >&2 ;                                                      \
/bin/false)[/b] 
mkdir -p /var/tmp/portage/x11-drivers/nvidia-drivers-304.135/work/kernel/.tmp_versions ; rm -f /var/tmp/portage/x11-drivers/nvidia-drivers-304.135/work/kernel/.tmp_versions/*
make -f /usr/src/linux-4.11.1-gentoo/scripts/Makefile.build obj=/var/tmp/portage/x11-drivers/nvidia-drivers-304.135/work/kernel
бла-бла-бла

Дальше собирается, но не работает. С 4.9 тоже.

cd /usr/src/linux
make oldconfig && make prepare
делал
sh-4.4# eselect kernel list
Available kernel symlink targets:
  [1]   linux-4.9.16-gentoo
  [2]   linux-4.11.1-gentoo *
Что я делаю не так?

* Gentoo supports kernels which are supported by NVIDIA
* which are limited to the following kernels:
* <sys-kernel/gentoo-sources-4.10
* <sys-kernel/vanilla-sources-4.10

hizel ★★★★★ ()

Так у тебя выбрано 4.11. тебе нужно поставить 4.9, потом сделать eselect kernel list, посмотреть его номер сделай eselect kernel set номер, потом ещё раз eselect kernel list, чтобы убедиться, что звёздочкой теперь помечено 4.9. Можно ещё, на будущее, снять в системе для пакета ядра флаг, аытоматически создающий симлинк на новое ядро.

Там ж всё написано в сообщении об ошибке.

grem ★★★★★ ()
Ответ на: комментарий от meg62941

В переводе это звучит так, nvidia будет стабильно собиратся толь с ядрами gentoo-source и vanila-source - причем со стабильными их версиями (те что зеленые), во всех остальных случаях как повезет.

Silerus ★★ ()
Ответ на: комментарий от meg62941

<sys-kernel/gentoo-sources-4.10

Но английский лучше подтянуть, так как новости из списка eselect news list, и не только их, придётся читать на нём, а там часто важные бывают о действиях при обновлении ряда системных пакетов.

grem ★★★★★ ()
Последнее исправление: grem (всего исправлений: 1)
Ответ на: комментарий от grem

тебе нужно поставить 4.9

Можно и 4.10. У меня на 4.10 они нормально работают. Главное чтобы не 4.11, потому что для этой версии дров еще нет.

Rinaldus ★★★★★ ()
Ответ на: комментарий от grem

тебе нужно поставить 4.9

Оно изначально было. С ним тоже не заработало. eselect kernel set делал Сейчас попробую 4.10 собрать

meg62941 ()
[ebuild   R    ] x11-drivers/nvidia-drivers-304.135

Говном мамонта обмазываешься, сэр. Попробуй поставить старое стабильное ядро или найти патчи к этим драйверам.

Liferer ()
Ответ на: комментарий от Liferer

Говном мамонта обмазываешься, сэр

Могу обмазаться 340

Попробуй поставить старое стабильное ядро

3.4.9999?

meg62941 ()
Ответ на: комментарий от meg62941

Подожди, а что с

echo >&2 "         include/generated/autoconf.h or include/config/auto.conf are missing.";\

Стоит проверить эту парочку файлов на странности. Должны лежать в директории с исходниками ядра. Если все ок, открыть сценарий сборки и посмотреть, при каких условиях выводится это сообщение.

Liferer ()
Ответ на: комментарий от anonymous

А нет есть проблема

$ eselect opengl list
Available OpenGL implementations:
  [1]   nvidia
  [2]   xorg-x11 *
$ eselect opengl set 1
!!! Error: The nvidia OpenGL implementation doesn't seem to provide
!!! Error: libGL.so file. This might be an effect of breakage introduced
!!! Error: by a prioprietary driver installer. Please re-merge the package
!!! Error: providing your OpenGL implementation.
!!! Error: Selected OpenGL implementation incomplete.
exiting

meg62941 ()
Ответ на: комментарий от Liferer

А нет есть проблема

$ eselect opengl list
Available OpenGL implementations:
  [1]   nvidia
  [2]   xorg-x11 *
$ eselect opengl set 1
!!! Error: The nvidia OpenGL implementation doesn't seem to provide
!!! Error: libGL.so file. This might be an effect of breakage introduced
!!! Error: by a prioprietary driver installer. Please re-merge the package
!!! Error: providing your OpenGL implementation.
!!! Error: Selected OpenGL implementation incomplete.
exiting

meg62941 ()
Ответ на: комментарий от imul

А нет есть проблема

$ eselect opengl list
Available OpenGL implementations:
  [1]   nvidia
  [2]   xorg-x11 *
$ eselect opengl set 1
!!! Error: The nvidia OpenGL implementation doesn't seem to provide
!!! Error: libGL.so file. This might be an effect of breakage introduced
!!! Error: by a prioprietary driver installer. Please re-merge the package
!!! Error: providing your OpenGL implementation.
!!! Error: Selected OpenGL implementation incomplete.
exiting

meg62941 ()
Ответ на: комментарий от imul
 $ qlist x11-drivers/nvidia-drivers
/usr/bin/nvidia-bug-report.sh
/usr/bin/nvidia-settings
/usr/lib64/libvdpau_nvidia.so.1
/usr/lib64/libnvidia-compiler.so.1
/usr/lib64/libnvcuvid.so.304.135
/usr/lib64/libXvMCNVIDIA.so.1
/usr/lib64/libXvMCNVIDIA.so
/usr/lib64/libnvidia-opencl.so.1
/usr/lib64/libnvidia-cfg.so.304.135
/usr/lib64/libnvidia-opencl.so
/usr/lib64/libnvidia-cfg.so
/usr/lib64/libnvidia-ml.so.304.135
/usr/lib64/libnvidia-glcore.so
/usr/lib64/xorg/modules/drivers/nvidia_drv.so
/usr/lib64/libvdpau_nvidia.so
/usr/lib64/libnvidia-ml.so
/usr/lib64/libnvcuvid.so.1
/usr/lib64/libnvcuvid.so
/usr/lib64/libXvMCNVIDIA_dynamic.so.1
/usr/lib64/libnvidia-compiler.so.304.135
/usr/lib64/libcuda.so
/usr/lib64/libnvidia-glcore.so.304.135
/usr/lib64/libnvidia-ml.so.1
/usr/lib64/libcuda.so.1
/usr/lib64/libnvidia-glcore.so.1
/usr/lib64/libcuda.so.304.135
/usr/lib64/libnvidia-opencl.so.304.135
/usr/lib64/libXvMCNVIDIA.a
/usr/lib64/opengl/nvidia/extensions/libglx.so.304.135
/usr/lib64/opengl/nvidia/lib/libGL.so.304.135
/usr/lib64/opengl/nvidia/lib/libnvidia-tls.so.304.135
/usr/lib64/opengl/nvidia/lib/libnvidia-tls.so.1
/usr/lib64/libnvidia-cfg.so.1
/usr/lib64/libnvidia-compiler.so
/usr/lib64/OpenCL/vendors/nvidia/libOpenCL.so
/usr/lib64/OpenCL/vendors/nvidia/libOpenCL.so.1.0.0
/usr/lib64/OpenCL/vendors/nvidia/libOpenCL.so.1
/usr/lib64/libvdpau_nvidia.so.304.135
/usr/lib64/libXvMCNVIDIA.so.304.135
/usr/share/pixmaps/nvidia-settings.png
/usr/share/applications/nvidia-settings.desktop
/usr/share/man/man1/nvidia-cuda-proxy-control.1.bz2
/usr/share/man/man1/nvidia-xconfig.1.bz2
/usr/share/man/man1/nvidia-smi.1.bz2
/usr/share/man/man1/nvidia-settings.1.bz2
/usr/share/doc/nvidia-drivers-304.135/README.gentoo.bz2
/usr/share/doc/nvidia-drivers-304.135/NVIDIA_Changelog.bz2
/usr/share/doc/nvidia-drivers-304.135/README.bz2
/usr/share/doc/nvidia-drivers-304.135/html/displaydevicenames.html
/usr/share/doc/nvidia-drivers-304.135/html/supportedchips.html
/usr/share/doc/nvidia-drivers-304.135/html/nvidia-ml.html
/usr/share/doc/nvidia-drivers-304.135/html/flippingubb.html
/usr/share/doc/nvidia-drivers-304.135/html/configuringagp.html
/usr/share/doc/nvidia-drivers-304.135/html/introduction.html
/usr/share/doc/nvidia-drivers-304.135/html/commonproblems.html
/usr/share/doc/nvidia-drivers-304.135/html/nvidia-smi.html
/usr/share/doc/nvidia-drivers-304.135/html/appendices.html
/usr/share/doc/nvidia-drivers-304.135/html/i2c.html
/usr/share/doc/nvidia-drivers-304.135/html/minimumrequirements.html
/usr/share/doc/nvidia-drivers-304.135/html/faq.html
/usr/share/doc/nvidia-drivers-304.135/html/optimus.html
/usr/share/doc/nvidia-drivers-304.135/html/addressingcapabilities.html
/usr/share/doc/nvidia-drivers-304.135/html/xcompositeextension.html
/usr/share/doc/nvidia-drivers-304.135/html/acknowledgements.html
/usr/share/doc/nvidia-drivers-304.135/html/editxconfig.html
/usr/share/doc/nvidia-drivers-304.135/html/sdi.html
/usr/share/doc/nvidia-drivers-304.135/html/newusertips.html
/usr/share/doc/nvidia-drivers-304.135/html/nvidia-debugdump.html
/usr/share/doc/nvidia-drivers-304.135/html/configtvout.html
/usr/share/doc/nvidia-drivers-304.135/html/installedcomponents.html
/usr/share/doc/nvidia-drivers-304.135/html/sli.html
/usr/share/doc/nvidia-drivers-304.135/html/xrandrextension.html
/usr/share/doc/nvidia-drivers-304.135/html/openglenvvariables.html
/usr/share/doc/nvidia-drivers-304.135/html/vdpausupport.html
/usr/share/doc/nvidia-drivers-304.135/html/selectdriver.html
/usr/share/doc/nvidia-drivers-304.135/html/audiosupport.html
/usr/share/doc/nvidia-drivers-304.135/html/nvidiasettings.html
/usr/share/doc/nvidia-drivers-304.135/html/xvmcsupport.html
/usr/share/doc/nvidia-drivers-304.135/html/configlaptop.html
/usr/share/doc/nvidia-drivers-304.135/html/index.html
/usr/share/doc/nvidia-drivers-304.135/html/dma_issues.html
/usr/share/doc/nvidia-drivers-304.135/html/configmultxscreens.html
/usr/share/doc/nvidia-drivers-304.135/html/knownissues.html
/usr/share/doc/nvidia-drivers-304.135/html/glxsupport.html
/usr/share/doc/nvidia-drivers-304.135/html/procinterface.html
/usr/share/doc/nvidia-drivers-304.135/html/configtwinview.html
/usr/share/doc/nvidia-drivers-304.135/html/addtlresources.html
/usr/share/doc/nvidia-drivers-304.135/html/depth30.html
/usr/share/doc/nvidia-drivers-304.135/html/installdriver.html
/usr/share/doc/nvidia-drivers-304.135/html/installationandconfiguration.html
/usr/share/doc/nvidia-drivers-304.135/html/programmingmodes.html
/usr/share/doc/nvidia-drivers-304.135/html/framelock.html
/usr/share/doc/nvidia-drivers-304.135/html/dpi.html
/usr/share/doc/nvidia-drivers-304.135/html/powermanagement.html
/usr/share/doc/nvidia-drivers-304.135/html/xineramaglx.html
/usr/share/doc/nvidia-drivers-304.135/html/xconfigoptions.html
/etc/X11/xinit/xinitrc.d/95-nvidia-settings
/etc/modprobe.d/nvidia.conf
/etc/init.d/nvidia-smi
/etc/OpenCL/vendors/nvidia.icd
/opt/bin/nvidia-smi
/opt/bin/nvidia-cuda-proxy-server
/opt/bin/nvidia-cuda-proxy-control
/opt/bin/nvidia-xconfig
/opt/bin/nvidia-debugdump
/lib/modules/4.9.16-gentoo/video/nvidia.ko
/lib/udev/nvidia-udev.sh
/lib/udev/rules.d/99-nvidia.rules
/usr/lib64/opengl/nvidia/lib/libGL.so.1
/usr/lib64/opengl/nvidia/lib/libnvidia-tls.so
/usr/lib64/opengl/nvidia/extensions/libglx.so.1
/usr/lib64/opengl/nvidia/extensions/libglx.so
/usr/lib64/opengl/nvidia/lib/libGL.so
meg62941 ()
Ответ на: комментарий от meg62941

Как-то мало файлов. У меня в пакет набивается больше раза в полтора, даже если вычеркнуть debug и lib32.

Не понял как патчить пакет

https://gogs.lumi.pw/mike/portage/src/master/x11-drivers/nvidia-drivers
Сделал ebuild. Собирается. Проверить не на чем, видеокарта intel.
Накладываемый патч в каталоге files https://gogs.lumi.pw/mike/portage/src/master/x11-drivers/nvidia-drivers/files...
Если кто соберёт, скажите потом, работает, или нет.

imul ★★★★★ ()
Ответ на: комментарий от imul

Уже решил проблему. Сделал emerge nvidia-drivers и в другом терминале очень быстро перешёл в /var/tmp/portage/бла/бла/бла-nvidia/work
Быстро скачал wget-ом патч и наложил. Теперь всё включилось

meg62941 ()
Ответ на: комментарий от meg62941

На будущее — если не хочешь играть в такую гонку на опережение, жми Ctrl + Z в терминале на нужной стадии, продолжать % fg.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.