LINUX.ORG.RU

установка supervisor (crash)

 , ,


1

1

На арче решил поставить supervisor:

[foozzi@foozzi crowdtrip]$ sudo pacman -S supervisor
разрешение зависимостей...
проверка конфликтов...

Пакеты (7) python2-appdirs-1.4.0-5  python2-meld3-1.0.2-1  python2-packaging-16.8-2  python2-pyparsing-2.1.10-2  python2-setuptools-1:34.2.0-1
           python2-six-1.10.0-3  supervisor-3.3.1-1

Будет установлено:  6,36 MiB

:: Приступить к установке? [Y/n] 
(7/7) проверка ключей                                                                            [#########################################################] 100%
(7/7) проверяется целостность пакета                                                             [#########################################################] 100%
(7/7) загрузка файлов пакетов                                                                    [#########################################################] 100%
(7/7) проверка конфликтов файлов                                                                 [#########################################################] 100%
ошибка: не удалось завершить транзакцию (конфликтующие файлы)
python2-six: '/usr/lib/python2.7/site-packages/six.py' существует в файловой системе
python2-six: '/usr/lib/python2.7/site-packages/six.pyc' существует в файловой системе
python2-appdirs: '/usr/lib/python2.7/site-packages/appdirs.py' существует в файловой системе
python2-appdirs: '/usr/lib/python2.7/site-packages/appdirs.pyc' существует в файловой системе
python2-setuptools: '/usr/bin/easy_install-2.7' существует в файловой системе
Обнаружены ошибки, пакеты не обновлены.
что то я не понимаю, как и зачем это происходит...

★★★

А не надо было пакеты через pip под root ставить. Сделай sudo pacman -S supervisor --force и все поставится

anonymous ()

runit </thread>

P.S. Обдолбаются своим питоном, а потом ябутся в жопы.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.