LINUX.ORG.RU

Репозиторий experimental не полноценная ветка, по этому включаешь сразу и unstable.

$ sudo echo "deb http://httpredir.debian.org/debian experimental main contrib non-free" >> /etc/apt/sources.list
$ sudo echo "deb-src http://httpredir.debian.org/debian experimental main contrib non-free" >> /etc/apt/sources.list
$ sudo echo "deb http://httpredir.debian.org/debian unstable main contrib non-free" >> /etc/apt/sources.list
$ sudo echo "deb-src http://httpredir.debian.org/debian unstable main contrib non-free" >> /etc/apt/sources.list
$ sudo echo "APT::Default-Release \"stretch\"" >> /etc/apt/apt.conf
$ sudo apt-src update
$ sudo apt-src -t experimental install mesa

Вот, так ты установишь пакет исходного кода mesa. Что дальше делать знаешь?

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 4)
Ответ на: комментарий от anonymous

Он дал линк на src. Сами всегда ругаетесь, что на лоре не отвечают на вопрос, а вдаются в пространные рассуждения о том что по правде нужно ТС-у.

mandala ★★★★ ()
Ответ на: комментарий от devorg

А что ты не говоришь что остальное не отработало? Терпеть не могу sudo... подожди 5 минут

mandala ★★★★ ()
Ответ на: комментарий от devorg
$ sudo su
# echo "deb http://httpredir.debian.org/debian experimental main contrib non-free" >> /etc/apt/sources.list
# echo "deb-src http://httpredir.debian.org/debian experimental main contrib non-free" >> /etc/apt/sources.list
# echo "deb http://httpredir.debian.org/debian unstable main contrib non-free" >> /etc/apt/sources.list
# echo "deb-src http://httpredir.debian.org/debian unstable main contrib non-free" >> /etc/apt/sources.list
# echo "APT::Default-Release \"stretch\";" >> /etc/apt/apt.conf
# apt-src update
# exit
$ mkdir mesa_source
$ cd ~/mesa_source
$ apt -t experimental source mesa



А тебе точно нужно самому собирать месу из этого репозитория? Какова цель?

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 1)
Ответ на: комментарий от mandala

Хорошо, это вроде сработало. А дальше как скомпиллить?

apt -t experimental source mesa
Reading package lists... Done
Selected version '17.0.0~rc3-1' (experimental) for mesa
NOTICE: 'mesa' packaging is maintained in the 'Git' version control system at:
https://anonscm.debian.org/git/pkg-xorg/lib/mesa.git
Please use:
git clone https://anonscm.debian.org/git/pkg-xorg/lib/mesa.git
to retrieve the latest (possibly unreleased) updates to the package.
Need to get 16.0 MB of source archives.
Get:1 http://debian.mirror.vu.lt/debian experimental/main mesa 17.0.0~rc3-1 (dsc) [4,332 B]
Get:2 http://debian.mirror.vu.lt/debian experimental/main mesa 17.0.0~rc3-1 (tar) [15.9 MB]
Get:3 http://ftp.aso.ee/debian experimental/main mesa 17.0.0~rc3-1 (diff) [85.3 kB]
Fetched 16.0 MB in 9s (1,716 kB/s)                                                                       
dpkg-source: info: extracting mesa in mesa-17.0.0~rc3
dpkg-source: info: unpacking mesa_17.0.0~rc3.orig.tar.gz
dpkg-source: info: applying mesa_17.0.0~rc3-1.diff.gz
dpkg-source: info: upstream files that have been modified: 
 mesa-17.0.0~rc3/src/intel/vulkan/Makefile.am
W: Download is performed unsandboxed as root as file 'mesa_17.0.0~rc3-1.dsc' couldn't be accessed by user '_apt'. - pkgAcquire::Run (13: Permission denied)

зы: Цель — OpenGL 4.5 для встроенной видюхи Haswell (hd-4600).

devorg ★★ ()
Ответ на: комментарий от mandala

Только я не пойму, а нельзя просто установить, без всякой компиляции и прочего? Ведь таким же макаром я могу скачать Mesa Git, и скомпиллировать и инсталлировать его?

devorg ★★ ()
Ответ на: комментарий от devorg

Угу, я и спросил. Но может тебе там патчи нужно наложить.
Там я поздно поправил команду скачивания исходников, они теперь валяются в хомяке и с правами доступа только для рута. А это не гуд. Удали их с правами рута.
Тебе проще будет обновиться на sid, указав предпочтительный источник experimental, т.к. при смешивании веток один фиг больше половины системы обновится, но что-нибудь 146% сломается.
Все дальнейшие действия превратят твой дебиан в лютый анстейбл:
Поменять назначение в /etc/apt/apt.conf

APT::Default-Release "experimental";

Дальше выполнить обновление списока пакетов и обновить дистр:
# apt update
# apt full-upgrade

Но я бы так не делал на «боевой» системе, а установил бы рядышком тестовый и там посмотрел что вообще и как работает, ведь experimental это даже не sid — это место где лежат «недоделанные» пакеты.
Список репозиториев должен выглядеть так
/etc/apt/sources.list
deb http://httpredir.debian.org/debian/ sid main contrib non-free
deb-src http://httpredir.debian.org/debian/ sid main contrib non-free
deb http://httpredir.debian.org/debian experimental main contrib non-free
deb-src http://httpredir.debian.org/debian experimental main contrib non-free

Устанавливать можно или с недельного среза тестинга или со стабильного, в принципе особой разницы нет для тестового полигона.

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 1)

Скачай файлы mesa_17*.dsc, mesa_17*orig.tar.gz, mesa_17*diff.gz.

Выполни dpkg-source -x mesa_17*.dsc Перейди в каталог mesa_17* и выполни dpkg-buildpackage -b -rfakeroot

Недостающие зависимости можешь поставить ручками. Если всё пройдёт хорошо, в каталоге выше получишь собранные пакеты. Поставишь их командой dpkg -i mesa*.deb

anonymous ()
Ответ на: комментарий от devorg

Он намекает на то что «ламеру» нечего делать на дебиане, но отправить на винду он постеснялся. Сам он видимо родился сразу «гуру» и в колыбели ядро патчил.

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 1)
Ответ на: комментарий от anonymous

А почему нельзя просто установить командой что-то типа

apt -t experimental install libgl1-mesa ... итд
? Я пробовал, но выдаёт ошибки типа
The following packages have unmet dependencies:
 libkf5notifications5 : Depends: phonon4qt5 but it is not going to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

При чём половина пакетов установилась, например glxinfo уже выдаёт 17 версию mesa, но OpenGL до сих пор 3, хотя и пишет что максимальная версия 4.5.

glxinfo | grep "OpenGL"
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Haswell Desktop 
OpenGL core profile version string: 4.5 (Core Profile) Mesa 17.0.0-rc3
OpenGL core profile shading language version string: 4.50
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 17.0.0-rc3
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.1 Mesa 17.0.0-rc3
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.10
OpenGL ES profile extensions:
devorg ★★ ()
Ответ на: комментарий от devorg
Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.

Хз, у меня симуляция установки по пакетам из https://packages.debian.org/source/experimental/mesa прошла успешно

apt-get -s install libegl1-mesa libegl1-mesa-dev libgbm-dev libgbm1 libgl1-mesa-dev libgl1-mesa-dri libgl1-mesa-glx libglapi-mesa libgles2-mesa libgles2-mesa-dev libosmesa6 libosmesa6-dev libwayland-egl1-mesa libxatracker-dev libxatracker2 mesa-common-dev mesa-opencl-icd mesa-va-drivers mesa-vdpau-drivers mesa-vulkan-drivers
но именно на самом пакете libkf5notifications5 ошибка. Откуда он притягивается? Подожди пока эта Mesa 17 попадёт в sid.

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 3)
Ответ на: комментарий от devorg

Тем, что, возможно, не придётся превращать дистрибутив в смесь stable/sid/experemental. Если повезёт, то новая меса соберётся с зависимостями, уже присутствующими в стейбле. И будет у тебя в системе только «неродная» меса. А при установке готового бинарника из sid/experemental практически наверняка дополнительно приедет ещё куча пакетов. Сейчас, пока базы их близки, пакетов может быть немного, но, со временем, при такой операции из-за одного бинарника тебе может приехать весь сид.

anonymous ()
Ответ на: комментарий от anonymous

Если повезёт, то новая меса соберётся с зависимостями, уже присутствующими в стейбле.

Только что проверял — Mesa 17.0.0 rc3 ставится на тестинг без лишних зависимостей, пересобирать не надо. Не знаю, чего ТС мозги насилует.

anonymous ()
Ответ на: комментарий от devorg

При чём половина пакетов установилась, например glxinfo уже выдаёт 17 версию mesa, но OpenGL до сих пор 3, хотя и пишет что максимальная версия 4.5.

Всё правильно, так и должно быть. 3.0 это версия compat profile, которая никогда не повысится дальше.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.