LINUX.ORG.RU

OpenWRT не пингует свой интерфейс

 , , ,


0

2

Здравствуйте.

Имеется WiFi роутер D-Link DIR-615 на OpenWRT.

Если честно, в нем я пока новичек.

На данный момент настроено 3 порта.

WAN - 192.168.3.1 LAN - 192.168.2.1 WLAN - 192.168.6.1

Причем роутер пингует подсеть 192.168.3.0 и интернет, который имеется за ним, так же и подсеть - 192.168.2.0. Но отказывается пинговать свой IP на WLAN на 192.168.6.1.

Помогите, что я делаю не так? Спасибо.

Ответ на: комментарий от Dark_SavanT
config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.2.1'
        option dns '8.8.8.8'

config interface 'wan'
        option _orig_ifname 'eth1'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '192.168.1.9'
        option netmask '255.255.255.0'
        option gateway '192.168.1.6'
        option ifname 'eth1'
        option dns '192.168.1.4'
        option type 'bridge'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0 1 2 3 4'
        option vid '1'

config interface 'WLAN'
        option proto 'static'
        option ipaddr '192.168.3.1'
        option dns '8.8.8.8'
        option gateway '192.168.3.1'
        option _orig_ifname 'wlan0'
        option _orig_bridge 'false'
        option type 'bridge'
        option netmask '255.255.255.0'
        option stp '1'

config route
        option interface 'lan'
        option target '0.0.0.0'
        option netmask '255.255.0.0'
        option gateway '192.168.2.1'
Krishnoved ()
Ответ на: комментарий от Crewger
config interface 'WLAN'
        option proto 'static'
        option ipaddr '192.168.6.1'
        option dns '8.8.8.8'
        option gateway '192.168.6.1'
        option _orig_ifname 'wlan0'
        option _orig_bridge 'false'
        option type 'bridge'
        option netmask '255.255.255.0'
        option stp '1'

Привел в единый вид. Написал первоначально лишь в схематике.

Krishnoved ()
Ответ на: комментарий от Crewger

Привел таблицу в соответствие.

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.2.1'
        option dns '8.8.8.8'

config interface 'wan'
        option _orig_ifname 'eth1'
        option _orig_bridge 'false'
        option proto 'static'
        option ipaddr '192.168.3.1'
        option netmask '255.255.255.0'
        option gateway '192.168.3.1'
        option ifname 'eth1'
        option dns '192.168.1.4'
        option type 'bridge'

config switch
        option name 'eth0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'eth0'
        option vlan '1'
        option ports '0 1 2 3 4'
        option vid '1'

config interface 'WLAN'
        option proto 'static'
        option ipaddr '192.168.6.1'
        option dns '8.8.8.8'
        option gateway '192.168.6.1'
        option _orig_ifname 'wlan0'
        option _orig_bridge 'false'
        option type 'bridge'
        option netmask '255.255.255.0'
        option stp '1'

config route
        option interface 'lan'
        option target '0.0.0.0'
        option netmask '255.255.0.0'
        option gateway '192.168.2.1'

Krishnoved ()
Ответ на: комментарий от Krishnoved

Всем спасибо.

Проблему решил. Оказывается намудрил с зонами на интерфейсах.

Krishnoved ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.