LINUX.ORG.RU

Ядро сообщает об утечке

 , , , ,


0

1

Древний комп Athlon64 с Убунтой 16.04, картой NVIDIA GeForce 6200 и nouveau в качестве драйвера к ней. В некоторый (довольно произвольный) момент времени ядро выдаёт:

kernel: [157059.271864] [TTM] Erroneous page count. Leaking pages.

После чего (по-видимому) система намертво виснет (без каких-либо доп. сообщений), «магические» кнопочки не работают, только жёсткий reset. Очень похоже на то, что виснет из-за Nouveau, поскольку с блобом не замечал такого поведения (но зато с блобом не работает как следует OpenGL, а оно нужно). Что можно сделать?

P.S. Ответ «выкинь это старьё» я знаю, и он меня не устраивает.

★★★★★

netconsole + reportbug

anonymous ()
Ответ на: комментарий от rezedent12

старая видеокарта поддерживается только старым блобом, который фигово работает с новыми иксами. Как-то так...

Sahas ★★★★★ ()

Ставь закрытый драйвер 304.* ветки.

anonymous ()
Ответ на: комментарий от Sahas

только старым блобом, который фигово работает с новыми иксами.

Собери старые иксы тогда.

rezedent12 ☆☆☆ ()
Ответ на: комментарий от anonymous

У «старого блоба» дата выпуска 14.12.2016. Как такое объяснишь?

Да скорее всего он просто не полностью блоб поставил. Наверно библиотеки не установил.

rezedent12 ☆☆☆ ()
Ответ на: комментарий от rezedent12

Тоже так подумал, часто делают раздельные пакеты.

anonymous ()
Ответ на: комментарий от rezedent12

Не, всё полностью ставится, так как нормально работает с OpenGL, за исключением графических приложений, запускаемых через ssh (конкретно с ParaView проблема). В чём дело — я не знаю, но с nouveau всё работает. Только подвисает иногда...

Sahas ★★★★★ ()
Ответ на: комментарий от Sahas

Не, всё полностью ставится, так как нормально работает с OpenGL, за исключением графических приложений, запускаемых через ssh (конкретно с ParaView проблема). В чём дело — я не знаю, но с nouveau всё работает. Только подвисает иногда...

У тебя X11 туннель?

rezedent12 ☆☆☆ ()
Ответ на: комментарий от Sahas

X11 Forwarding

Аппаратное ускорение не работает через X11, оно работает через библиотеки. И библиотеки должны быть установлены там где выполняется программа. Поставь на сервере MESA.

rezedent12 ☆☆☆ ()
Ответ на: комментарий от rezedent12

Та всё там есть. Работало раньше на более старых иксах. И с нуво работает.

И вообще, лучше разбираться, почему нуво виснет, чем с блобом ковыряться.

Sahas ★★★★★ ()
Последнее исправление: Sahas (всего исправлений: 1)
Ответ на: комментарий от Sahas

И вообще, лучше разбираться, почему нуво виснет, чем с блобом ковыряться.

Ну сам его и переписывай...

rezedent12 ☆☆☆ ()

Проблема наблюдается как с nouveau, так и с блобом. По моим наблюдениям, происходит в момент, когда открыто много приложений и памяти не хватает (начинает свопить). Буду тестить память, что ли...

Sahas ★★★★★ ()
Ответ на: комментарий от Sahas

Рекомендуемый на сайте нвидиа для geforce 6200 «старый блоб» 304.135 поддерживает самый новый xorg 1.19.

anonymous ()
Ответ на: комментарий от Sahas

Попробуй вообще без драйвера, вернее с иксовым vesa. Скорее всего ты просто нуво не умеешь удалять.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.