LINUX.ORG.RU

Установи сам локализацию

apt-get install  firefox-l10n-ru  libreoffice-l10n-ru 

Dron ★★★★★ ()
Последнее исправление: Dron (всего исправлений: 1)

см. еще. apt show task-russian-desktop

logon ()
Ответ на: комментарий от Dron

Вопрос не о том как мне установить локализацию, я об этом знаю, вопрос в том, почему эти две софтины не локализованы из коробки...

Novichok2014 ★★ ()

Очень много раз ставлю дебиан (8.5/8.6) на реальное железо и так же на вм и всегда эти две софтины не имеют русскую локализацию..

Novichok2014 ★★ ()
Ответ на: комментарий от Novichok2014

спроси у майнтейнеров пакетов :D Просто они посчитали ненужным автоматом определять локаль и качать лишние пакеты и всё)

Dron ★★★★★ ()
Последнее исправление: Dron (всего исправлений: 1)
Ответ на: комментарий от Novichok2014

firefox-l10n-ru libreoffice-l10n-ru
не имеют русскую локализацию

А ?

bdfy ★★★★ ()
Ответ на: комментарий от Novichok2014

Очень много раз ставлю дебиан (8.5/8.6) на реальное железо и так же на вм и всегда эти две софтины не имеют русскую локализацию..

С какого образа ставишь?

eugeno ★★★★★ ()
Ответ на: комментарий от Dron

Просто они посчитали ненужным автоматом определять локаль и качать лишние пакеты и всё)

Почему тогда к остальному софту они сочли нужным автоматом определять локализацию и качать лишние пакеты? )))

Могли бы и все остальное по выбору оставить, а так, все переведено, кроме этих двух программ...

Novichok2014 ★★ ()
Ответ на: комментарий от Novichok2014

Спроси:
pkg-mozilla-maintainers@lists.alioth.debian.org
debian-openoffice@lists.debian.org :D

Dron ★★★★★ ()

Потому что некоторые не знают о наличии пакетов task-russian и task-russian-desktop, но уже лезут ставить всякие боксы.

Polugnom ★★★★★ ()
Ответ на: комментарий от Novichok2014

debian-live-8.6.0-amd64-xfce-desktop.iso

Ну и что ты хочешь? В этом образе нет пакетов локализации ни для какого языка:

http://cdimage.debian.org/cdimage/release/current-live/amd64/iso-hybrid/debia...

и так же нетинсталл, крыса.

А вот здесь лукавишь. Если ты при установке выбрал русскую локализацию, то инсталлятор поставит task-russian-desktop, где будет и firefox-esr-l10n-ru, и libreoffice-l10n-ru, и даже libreoffice-help-ru.

eugeno ★★★★★ ()
Ответ на: комментарий от Novichok2014

Чтоб не страдали нормальные пользователи, а маргиналы пусть себе каку сами качают!

timdorohin ★★★ ()
Ответ на: комментарий от eugeno

Но у меня есть факты о том что я пишу...

В этом образе нет пакетов локализации ни для какого языка:

Ставлю этот образ и он имеет русскую локализацию, только две эти софтины не имею локализацию.

то инсталлятор поставит

Именно что он их не ставит.

Novichok2014 ★★ ()
Ответ на: комментарий от Novichok2014

Ставлю этот образ и он имеет русскую локализацию, только две эти софтины не имею локализацию.

Потому что у этих двух софтин локализация вынесена в отдельные пакеты. Если этих пакетов нет на диске, то они не установятся.

Именно что он их не ставит.

Вывод locale для системы, поставленной с netinst, в студию.

eugeno ★★★★★ ()
Ответ на: комментарий от eugeno

Потому что у этих двух софтин локализация вынесена в отдельные пакеты. Если этих пакетов нет на диске, то они не установятся.

Почему...вот в чем вопрос...

Вывод locale для системы, поставленной с netinst, в студию.

Обязательно, как раз на днях думал ее ставить на вм.

Novichok2014 ★★ ()
Ответ на: комментарий от Novichok2014

Почему...вот в чем вопрос...

Что почему?

Обязательно, как раз на днях думал ее ставить на вм.

Я уже установил. Все пакеты локализации установились.

eugeno ★★★★★ ()
Ответ на: комментарий от eugeno

Что почему?

Вот что почему:

у этих двух софтин локализация вынесена в отдельные пакеты.

Почему у всего софта что идет из коробки в дебиан пакеты локализации не внесены в отдельные пакеты, а пакеты лисы и либры они отдельно?

Все пакеты локализации установились.

У меня к сожалению ни разу не было при установки дебиан xfce что бы лиса и либра имели русскую локализацию и это факт...

Novichok2014 ★★ ()
Ответ на: комментарий от Novichok2014

Почему у всего софта что идет из коробки в дебиан пакеты локализации не внесены в отдельные пакеты, а пакеты лисы и либры они отдельно?

В дебиане пакеты часто разделяются на бинарники и файлы данных в целях экономии места и трафика. Для лисы и либры пакеты локализации занимают около 0,5 Мб, и если бы они были включены в основной пакет, их пришлось бы дублировать для всех архитектур, которых сейчас 10 штук. Ты можешь сказать, что 5 Мб для каждой программы — это мелочь, но сообществу Debian, которому приходится содержать сотни зеркал по всему миру, так не кажется.

У меня к сожалению ни разу не было при установки дебиан xfce что бы лиса и либра имели русскую локализацию и это факт...

Значит, ты что-то не так делал. Или устанавливал Xfce вручную после установки, или выбирал не ту локаль, или отключал установку recommended зависимостей.

eugeno ★★★★★ ()
Ответ на: комментарий от eugeno

В 8.6 Iceweasel нет совсем, в 8.6 теперь лиса и она в моем случае без локализации...

Novichok2014 ★★ ()

Иди вантузятник в вантуз. Здесь тебе никто ничего не должен.

anonymous ()
Ответ на: комментарий от Novichok2014

В 8.6 Iceweasel нет совсем, в 8.6 теперь лиса и она в моем случае без локализации...

Это одно и то же, только названия разные.

Ты показал видео для Debian 7.5.0, что не есть корректно, потому что в 8.6.0 немного изменился инсталлятор. Чтобы всё получилось, нужно делать так:

  1. использовать образ debian-8.6.0-amd64-netinst.iso;
  2. выбрать русскую локаль в начале установки;
  3. на этапе выбора ПО выбрать Xfce.

Ты уверен, что всё делаешь так? На видео не видно, какой образ используется, но подозреваю, что обычный CD, не netinst, потому что там не видно, что ты выбираешь Xfce, а он тем не менее устанавливается. С netinst такой фокус не пройдёт, он установит только то, что ты укажешь. Если ты устанавливал только базовую систему, а Xfce доустанавливал потом, то никаких языковых пакетов не будет. Если же ты выберешь Xfce в инсталляторе, то tasksel установит заодно task-russian-desktop.

Кстати, чтобы не иметь лишних проблем, лучше сразу выбирать Expert install.

eugeno ★★★★★ ()
Последнее исправление: eugeno (всего исправлений: 1)

Есть несколько софтин, с вынесенными отдельно локализациями - smplayer, chromium, firefox, libreoffice, qpdfview. Наверняка, есть и другие. В Debian, похоже, принято выносить локализации в отдельный пакет.

Kron4ek ★★★ ()
Ответ на: комментарий от Kron4ek

Не то чтобы «принято», просто они реально жрут дофига места. И реально 99% юзеров нужны только 2 из них - en_US, и местная по вкусу.

Посмотри например, сколько тебе высвободит localepurge при первом запуске.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.