LINUX.ORG.RU

Проблема с установкой ядра из бэкпортов на Debian 8

 , , ,


0

2

Поставил я себе текущий Debian в VirtualBox для плотного ознакомления и экспериментов смелых.

Начать решил с установки ядра из бэкпортов. Ну что, отредактировал по инструкции sources.list, добавил contrib и non-free, апдейтнулся. Ввожу

apt-get -t jessie-backports install linux-image-amd64

И тут он мне заявляет, что невозможно поставить этот пакет, так как он зависит от

linux-image-4.6.0-0.bpo.1-amd64
, а он недоступен.

Вот что я раскопал:

Собственно, что скорее всего случилось и что мне делать?

для плотного ознакомления и экспериментов смелых

Ну так не ставь виртуальный пакет, ставь всё руками.

Что случилось?

Что-то сломалось.

Ну или ставь из бекпортов https://packages.debian.org/jessie-backports/linux-image-amd64, у тебя один фиг виртуалка.

mandala ★★★★ ()
Последнее исправление: mandala (всего исправлений: 2)
Ответ на: комментарий от mandala

Какой ещё виртуальный пакет? У меня просто Debian 8 в VirtualBox стоит.

Читай внимательней, я и так ставлю из бэкпортов ядро, и на той самой странице, на которую ты ссылаешься, написано:


    dep: linux-image-4.6.0-0.bpo.1-amd64
        Пакет недоступен 

Vsevolod-linuxoid ★★★★★ ()
Последнее исправление: Vsevolod-linuxoid (всего исправлений: 1)
Ответ на: комментарий от Vsevolod-linuxoid

Какой ещё виртуальный пакет?

Виртуальный пакет — пакет, который ссылается на группу пакетов и ставит их тебе пачкой. В дебиане любят каждую нормальную «прогу» надо разделить на несколько штук, ты не знал? Это не слака тебе.

У меня просто Debian 8 в VirtualBox стоит

Да хоть в контейнере, пофиг.

на той самой странице, на которую ты ссылаешься, написано:

Ну извини, не заметил.

https://packages.debian.org/jessie-backports/linux-image-4.7.0-0.bpo.1-amd64-... и остальные пакеты руками тяни.

mandala ★★★★ ()
Ответ на: комментарий от Vsevolod-linuxoid

Или ты хочешь сказать, что мне следует вручную скачать пакет с сайта и поставить его с помощью dpkg, игнорируя зависимости?

Нет. Я говорю, что можешь попробовать поставить нужные пакеты linux-* через APT без мета-пакетов (список пакетов в бекпортах с кратким описанием https://packages.debian.org/jessie-backports/allpackages?format=txt.gz). Так интереснее, кстати: будешь лучше понимать всю местную наркоманию.

mandala ★★★★ ()
Ответ на: комментарий от mandala

Спасибо. Сделал

apt-get -t jessie-backports install linux-image-4.7.0-0.bpo.1-amd64-unsigned
и всё получилось. Видимо разрабы ещё не успели изменить зависимости у метапакета под новое ядро.

Vsevolod-linuxoid ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.