LINUX.ORG.RU

Fedora 24 GNOME - не открываются Параметры системы

 , , ,


1

2

Не могу открыть Параметры - в строке состояния вверху отображется название «Параметры» и рядом значок-волчок типа «думает». и всё. Через 5...10 сек исчезает. Ни ошибки, нихрена.

Аналогичн, если правой по рабочему столу и выберешь «Параметры дисплея» - Покажет вверху «Мониторы» + значок-волчок. Всё.

Когда установил, увидел этот косяк, сделал:

dnf update - не помогло

Думал, исправлю подключением репозитория rpmfusion. Фиг.

Больше ничего криминального не делал.

Помогите исправить, плииииз.

зачем тебе гуевина? Правь через конфиги чё надо. быстрее в разы.

anonymous ()

Попробуй запустить из терминала gnome-control-center, посмотри что напишет, выхлоп сюда (ну или в гугле пробей).

anonymous ()

А. ну и яркость же не меняется совсем :( Ноут картой АТИ на борту.

papatut ()
Ответ на: комментарий от anonymous

выхлоп: gnome-control-center: error while loading shared libraries: libwbclient.so.0: cannot open shared object file: No such file or directory

короч запустил параметры вроде командой из гугло-выдачи:

LD_LIBRARY_PATH=/usr/lib64/samba/wbclient/ gnome-control-center

выхлоп:

(gnome-control-center:6131): GLib-CRITICAL **: g_variant_get_type: assertion 'value != NULL' failed

(gnome-control-center:6131): GLib-CRITICAL **: g_variant_type_is_subtype_of: assertion 'g_variant_type_check (type)' failed

(gnome-control-center:6131): GLib-CRITICAL **: g_variant_get_boolean: assertion 'g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-control-center:6131): GLib-CRITICAL **: g_variant_unref: assertion 'value != NULL' failed

(gnome-control-center:6131): GLib-CRITICAL **: g_variant_get_type: assertion 'value != NULL' failed

(gnome-control-center:6131): GLib-CRITICAL **: g_variant_type_is_subtype_of: assertion 'g_variant_type_check (type)' failed

(gnome-control-center:6131): GLib-CRITICAL **: g_variant_get_boolean: assertion 'g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-control-center:6131): GLib-CRITICAL **: g_variant_unref: assertion 'value != NULL' failed

(gnome-control-center:6131): GLib-CRITICAL **: g_variant_get_type: assertion 'value != NULL' failed

(gnome-control-center:6131): GLib-CRITICAL **: g_variant_type_is_subtype_of: assertion 'g_variant_type_check (type)' failed

(gnome-control-center:6131): GLib-CRITICAL **: g_variant_get_boolean: assertion 'g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-control-center:6131): GLib-CRITICAL **: g_variant_unref: assertion 'value != NULL' failed

(gnome-control-center:6131): GLib-CRITICAL **: g_variant_get_type: assertion 'value != NULL' failed

(gnome-control-center:6131): GLib-CRITICAL **: g_variant_type_is_subtype_of: assertion 'g_variant_type_check (type)' failed

(gnome-control-center:6131): GLib-CRITICAL **: g_variant_get_boolean: assertion 'g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-control-center:6131): GLib-CRITICAL **: g_variant_unref: assertion 'value != NULL' failed

papatut ()
Ответ на: комментарий от papatut

snd_hda_intel

звук тут конечно не причем. Попробуй libwbclient.so.0.rpm загрузить и поставить. Все таки похоже на ошибку винта. У меня что то похожее было запускал fsck на lvm а потом что то восстанавливал из репов.

SergeySVold ★★★★ ()
Ответ на: комментарий от SergeySVold

Попробуй libwbclient.so.0.rpm загрузить и поставить.

@SergeySVold: Щас получишь вопрос где взять libwbclient.so.0.rpm.

@papatut:

# dnf provides '*/libwbclient.so.0'

Куришь выхлоп, далее

# dnf install libwbclient
debugger ★★★ ()
Ответ на: комментарий от debugger

курю выхлоп)) - файл есть по всем источникам

днф инсталл говорит - пакет есть

может его снести/установить?

пол.системы за собой не утянет при удалении как либрофис)?

пысы соррян, я совсем ламо) днище прям))

papatut ()
Ответ на: комментарий от papatut

короче, я всё снёс :)

установил по-новой с разбивкой разделов на полу-автомате (увеличил своп в два раза и системный раздел +10Гб)

Прямо в программе установки уже заработал регулятор яркости экрана. Запустился блюпуп (у меня на нем мышь). Запустился Вифи. Установилось. Гуёвина параметров запускается. Работает.

Хух.

papatut ()
Ответ на: комментарий от papatut

На будущее - пакеты можно удалять не трогая зависимости. Как минимум, рабочий вариант

sudo rpm -evh --nodeps имя_пакета
потом dnf-ом заново ставишь. Но наверняка и в самом dnf есть подобный (--nodeps) флаг. Как говорится, man dnf.

anonymous ()
Ответ на: комментарий от papatut

днф инсталл говорит - пакет есть

man dnf курить не пробовал? Есть такая команда dnf reinstall. А в твоём случае ещё rpm -Va можно было бы запустить. Не исключено что не только у libwbclient файлы попортились.

короче, я всё снёс :)

Дело хозяйское. Тоже метод, однако.

debugger ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.