LINUX.ORG.RU

rpm-build не установлено

 , ,


0

1

здравствуйте, нужно установить rpm-build на centos 7 пишем:

# yum install rpm-build

и не может установиться из-за кучи отсутствующих пакетов, например:

libreport-rhel-anaconda-bugzilla-2.1.11-32.el7.centos.x86_64

glibc-2.17-106.el7_2.1.i686

а чтобы установить пакеты нужен этот rpm-build( т.к. тупо скачиваю .src.rpm)

как быть то, помогите нубу

нужен например, например, libwebp.so.4()(64 bit), но он уже есть как ссылка на libwebp.so.4.0.2... и так с десяток .so-шек нужны, которые вроде бы есть...

xperious ★★ ()

воспользуйтесь mock-build rpm. создаете chroot окружение, в котором происходит компиляция пакетов, после компиляции получаете пакеты, а chroot можете удалить. позволяет не засорять систему лишними компиляторами.

https://fedoraproject.org/wiki/Mock

Nurmukh ★★★ ()

.src.rpm можно собрать в mock(если заранее известно, что оно точно соберётся). Он rpmbuild для работы не требует.

Если совсем прижало, давай .src.rpm сюда. Я соберу.

nexfwall ★★★★ ()
Последнее исправление: nexfwall (всего исправлений: 1 )

Только сдаётся мне, ты делаешь что-то не так. Буд-то ты пытаешься пересобрать весь RHEL из .src.rpm. Когда это бинарный дистрибутив...

nexfwall ★★★★ ()

всем спасибо за ответы, буду разбираться

xperious ★★ ()
Ответ на: комментарий от Nurmukh

# yum install epel-release - уже установлено

# yum install mock

вылезают ошибки:

Ошибка: Пакет: libreport-2.1.11-32.el7.centos.i686 (base)

Необходимо: libreport-filesystem = 2.1.11-32.el7.centos

Удаление: libreport-filesystem-2.1.11-32.el7.centos.x86_64 (@base)

libreport-filesystem = 2.1.11-32.el7.centos

Обновил: libreport-filesystem-2.6.3-1.fc23.x86_64 (warning:fedora)

libreport-filesystem = 2.6.3-1.fc23

и с десяток таких ошибок, нету некоторых rpm. Для того, чтобы эти самые rpm установить, хотел скачать rpm-build, а он тоже в свою очередь не скачивается из-за отсутствия некоторых rpm... замкнутый кргу... помогите пожалуйста

xperious ★★ ()
Ответ на: комментарий от Deleted

поставил centos 7 x86_64 minimal и все, больше нету предыстории. мало что ставится, везде вылетают ошибки при инсталляции, требуются то glibc.i686, то .so-шки, то еще чего... ну я и думал поставить по отдельности все rpm-пакеты которые требуются. в итоге на glibc все заглохло, даже gnome теперь не грузится, тупо черный экран и все, только консоль работает...

xperious ★★ ()
Ответ на: комментарий от xperious

Что-то у тебя там не так. Не должен свежепоставленный x86_64 просить i686 если там никто не навтыкал кривых репозиториев
. А зачем ставить минимал если нужен десктоп с гномом?

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.