LINUX.ORG.RU

Gentoo, Openbox и монтирование дисков

 , , ,


0

1

Пытаюсь перелезть на Openbox. Возникла проблема с монтированием и размонтированием разделов. При попытке размонтировать раздел Caja (файловый менеджер из MATE) пишет:

Not authorized to perform operation
Искал решения в интернете, но все они старые и относятся к использованию consolekit, которого у меня нет, поскольку я использую systemd. Либо надо редактировать правила polkit, что тоже не хотелось бы, поскольку это удар по безопасности. Тогда уж проще было бы дать юзеру права рута.
Мне бы хотелось, чтобы при попытке монтирования/размонтирования раздела появлялось окно gksu с предложением ввести пароль от рута и после этого все спокойно работало бы. Так же, как это сделано в большинстве DE.
Можно ли так сделать в Openbox?

★★★★★

при попытке монтирования/размонтирования раздела появлялось окно gksu с предложением ввести пароль от рута и после этого все спокойно работало бы

/usr/lib/mate-polkit/polkit-mate-authentication-agent-1 &, раз MATE

WDWTFWW ()
Ответ на: комментарий от Meyer
[I] sys-fs/udisks
     Доступные версии:      
     (0)    1.0.5-r1
     (2)    2.1.4 (~)2.1.6
       {cryptsetup debug +gptfdisk +introspection nls remote-access selinux systemd}
     Установленные версии:  2.1.6(2)(22:51:10 04.07.2015)(gptfdisk introspection systemd -cryptsetup -debug -selinux)

Стоит.

Rinaldus ★★★★★ ()
Ответ на: комментарий от WDWTFWW

Да я его снести собираюсь, как только настрою Openbox. Оставлю только необходимые программы (типа файлового менеджера и архиватора), которыми планирую пользоваться из Openbox. P.S. Кстати, такого каталога у меня нет в /usr/lib.

Rinaldus ★★★★★ ()
Последнее исправление: Rinaldus (всего исправлений: 1)

Так вроде MATE && Caja все равно используют PolicyKit для разрешения подобного рода прав, не?

pztrn ★★★★ ()
Ответ на: комментарий от pztrn

Да там не только Caja такое выдает. Я пробовал и Thunar, и pcmanfm, все они выдают подобные ошибки.

Rinaldus ★★★★★ ()
Ответ на: комментарий от Rinaldus

Тогда необязательно MATE, у всех DE есть подобные «policykit authentication agent» как раз с подобным поведением.

WDWTFWW ()
Ответ на: комментарий от WDWTFWW

Разумеется, необязательно. Но мне нравится файловый менеджер из MATE, хотелось бы продолжать им пользоваться. Впрочем, если это невозможно, то я не отказался бы и от Thunar, и от Nemo из Cinnamon. Главное, чтобы проблема с монтированием решилась.

Rinaldus ★★★★★ ()

udisks, udisks2, udevil и ещё целая пачка подобного софта — выбирай. Я пользуюсь последним, ибо зависимостей близко к нулю, и настраивать не требуется.

r3lgar ★★★★★ ()
Ответ на: комментарий от WDWTFWW

Проблема решена. Надо было добавить в ~/.config/openbox/autostart

/usr/libexec/polkit-gnome-authentication-agent-1 &
Спасибо, что навел меня на эту мысль. MATE я снесу, а polkit-gnome снести так просто не получится, так как там прямая зависимость от systemd. Да и не потребуется его сносить, так как он нужен. С ним все монтируется нормально.

Rinaldus ★★★★★ ()
Ответ на: комментарий от Rinaldus

/usr/libexec/polkit-mate-authentication-agent-1 Аналог МАТЕ-шный тоже работает(Если конечно у васкак у меня изначальный МАТЕ а не гном)

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.