LINUX.ORG.RU

QtCreator тянет Viber О_о

 , ,


0

3

В общем-то, сабж. Fedora 22, GNOME. При установке QtCreator заметил, что вместе с ним устанавливается Viber. При этом

[~]> sudo dnf remove viber
[sudo] пароль для ecko: 
Зависимости разрешены.
==================================================================================================================================================================================
 Пакет                                                 Архитектура              Версия                                     Репозиторий                                      Размер
==================================================================================================================================================================================
Удаление:
 botan                                                 x86_64                   1.10.9-4.fc22                              @fedora                                          3.0 M
 draftsight                                            x86_64                   2015.3.0.3020-1.2.fc22.R                   @russianfedora-nonfree-updates                   402 M
 gcc-c++                                               x86_64                   5.1.1-4.fc22                               @updates                                          23 M
 geoclue                                               x86_64                   0.12.99-7.fc22                             @fedora                                          335 k
 gl-manpages                                           noarch                   1.1-9.20140424.fc21                        @fedora                                          936 k
 gnome-icon-theme                                      noarch                   3.12.0-2.fc21                              @fedora                                          9.9 M
 gstreamer                                             x86_64                   0.10.36-11.fc22                            @fedora                                          3.4 M
 gstreamer-plugins-base                                x86_64                   0.10.36-12.fc22                            @fedora                                          6.3 M
 gstreamer-tools                                       x86_64                   0.10.36-11.fc22                            @fedora                                           94 k
 libX11-devel                                          x86_64                   1.6.3-1.fc22                               @fedora                                          1.0 M
 libXau-devel                                          x86_64                   1.0.8-4.fc22                               @fedora                                          6.4 k
 libXdamage-devel                                      x86_64                   1.1.4-6.fc22                               @fedora                                          2.5 k
 libXext-devel                                         x86_64                   1.3.3-2.fc22                               @fedora                                           99 k
 libXfixes-devel                                       x86_64                   5.0.1-4.fc22                               @fedora                                          9.0 k
 libXxf86vm-devel                                      x86_64                   1.1.4-1.fc22                               @fedora                                           12 k
 libdrm-devel                                          x86_64                   2.4.61-3.fc22                              @fedora                                          324 k
 libstdc++-devel                                       x86_64                   5.1.1-4.fc22                               @updates                                         8.7 M
 libxcb-devel                                          x86_64                   1.11-8.fc22                                @updates                                         2.6 M
 libxshmfence-devel                                    x86_64                   1.2-1.fc22                                 @fedora                                          1.9 k
 mesa-libEGL-devel                                     x86_64                   10.6.9-1.20151008.fc22                     @updates                                          64 k
 mesa-libGL-devel                                      x86_64                   10.6.9-1.20151008.fc22                     @updates                                         1.3 M
 nas-libs                                              x86_64                   1.9.4-2.fc21                               @fedora                                          185 k
 openal-soft                                           x86_64                   1.16.0-5.fc22                              @fedora                                          624 k
 qt-creator                                            x86_64                   3.5.0-1.fc22                               @updates                                          47 M
 qt-creator-data                                       noarch                   3.5.0-1.fc22                               @updates                                         4.5 M
 qt5-qtbase-devel                                      x86_64                   5.5.0-18.fc22                              @updates                                          22 M
 qt5-qtdoc                                             noarch                   5.5.0-2.fc22                               @updates                                         7.3 M
 qt5-qtlocation                                        x86_64                   5.5.0-3.fc22                               @updates                                         2.4 M
 qt5-qtmultimedia                                      x86_64                   5.5.0-3.fc22                               @updates                                         2.7 M
 qt5-qtquick1                                          x86_64                   5.5.0-3.fc22                               @updates                                         4.3 M
 qt5-qtquickcontrols                                   x86_64                   5.5.0-3.fc22                               @updates                                         3.5 M
 qt5-qtscript                                          x86_64                   5.5.0-3.fc22                               @updates                                         3.3 M
 qt5-qtsensors                                         x86_64                   5.5.0-3.fc22                               @updates                                         754 k
 qt5-qtsvg                                             x86_64                   5.5.0-3.fc22                               @updates                                         442 k
 qt5-qttools-common                                    noarch                   5.5.0-4.fc22                               @updates                                          34 k
 qt5-qttools-libs-designer                             x86_64                   5.5.0-4.fc22                               @updates                                         5.0 M
 qt5-qttools-libs-designercomponents                   x86_64                   5.5.0-4.fc22                               @updates                                         2.5 M
 qt5-qtwebkit                                          x86_64                   5.5.0-4.fc22                               @updates                                          39 M
 qt5-qtx11extras                                       x86_64                   5.5.0-2.fc22                               @updates                                          50 k
 viber                                                 x86_64                   4.2.2.6-8.fc22.R                           @russianfedora-nonfree-updates                   136 M
 xorg-x11-proto-devel                                  noarch                   7.7-12.fc21                                @fedora                                          1.4 M

Результат операции
==================================================================================================================================================================================
Удаление  41 Packages

Может кто-нибудь подтвердить или опровергнуть этот косяк? И, при наличии известного бага, ткнуть меня в него?

Deleted

подозреваю дело в этом @russianfedora-nonfree-updates

rpm -e --nodeps всегда прийдёт на выручку, если что.

ukr_unix_user ★★★★ ()
Ответ на: комментарий от ukr_unix_user

rpm -e --nodeps всегда прийдёт на выручку, если что

Не, ты не подумай, я не фанатик, и один лишний пакет в системе мне жизнь не испортит. Просто если это косяк моих рук, то хотелось бы знать, где именно, а если нет — хотелось бы сообщить в багзиллу или подписаться на существующий баг. За наводку с russianfedora спасибо, попробую поковырять.

Deleted ()

Да и вообще что-то странное с этим пакетом вышло. QtCreator после установки стартовать не захотел. Ругался

[~]> qtcreator
Failed to load core: /usr/lib64/qtcreator/plugins/libCore.so: Cannot load library /usr/lib64/qtcreator/plugins/libCore.so: (libQt5Help.so.5: невозможно открыть разделяемый объектный файл: Нет такого файла или каталога)
что разрешилось установкой пакета qt5-qttools-libs-help, а затем
[~]> qtcreator
Failed to load core: /usr/lib64/qtcreator/plugins/libCore.so: Cannot load library /usr/lib64/qtcreator/plugins/libCore.so: (libQt5CLucene.so.5: невозможно открыть разделяемый объектный файл: Нет такого файла или каталога)
что разрешилось уже установкой пакета qt5-qttools-libs-clucene соответственно. Либо я смог сторонними репами поломать зависимости пакета (что ппц странно), либо с этим пакетом какой-то глобальный косяк О_о

Deleted ()
Ответ на: комментарий от takino

Из системного.

[~]> dnf info qt-creator
Last metadata expiration check performed 0:49:27 ago on Sun Oct 18 23:03:48 2015.
Установленные пакеты
Имя         : qt-creator
Архитектура : x86_64
Эпоха       : 0
Версия      : 3.5.0
Релиз       : 1.fc22
Размер      : 47 M
Репозиторий : @System
Из репозито : updates
Краткое опи : Cross-platform IDE for Qt
URL         : http://qt-project.org/wiki/Category:Tools::QtCreator
Лицензия    : LGPLv2 or LGPLv3, with exceptions
Описание    : Qt Creator is a cross-platform IDE (integrated development environment)
            : tailored to the needs of Qt developers.

Deleted ()
$ sudo dnf remove qt-creator
Dependencies resolved.
==============================================================================================================================================================================
 Package                                       Arch                                 Version                                      Repository                              Size
==============================================================================================================================================================================
Removing:
 botan                                         x86_64                               1.10.9-4.fc22                                @fedora                                3.0 M
 qt-creator                                    x86_64                               3.5.0-1.fc22                                 @updates                                47 M
 qt-creator-data                               noarch                               3.5.0-1.fc22                                 @updates                               4.5 M
 qt5-qtdoc                                     noarch                               5.5.0-2.fc22                                 @updates                               7.3 M

Transaction Summary
==============================================================================================================================================================================
Remove  4 Packages

Installed size: 61 M
Is this ok [y/N]: n
Operation aborted.
$ sudo dnf remove viber
Dependencies resolved.
==============================================================================================================================================================================
 Package                              Arch                           Version                                     Repository                                              Size
==============================================================================================================================================================================
Removing:
 qt5-qtquick1                         x86_64                         5.5.0-3.fc22                                @updates                                               4.3 M
 viber                                x86_64                         4.2.2.6-8.fc22.R                            @russianfedora-nonfree-updates                         136 M

Transaction Summary
==============================================================================================================================================================================
Remove  2 Packages

Installed size: 141 M
Is this ok [y/N]: n
Operation aborted.

Интересно здесь то, что при удалении вайбера, пакет qt5-qtquick1 тоже хочет удалиться. Что делать, не знаю, просто для информации привел.

Deleted ()

Просто некоторые мейнтейнеры любят понатыкать ненужных зависимостей.

sudopacman ★★★★★ ()

Цитата на твою проблему

проблема замечена, ведутся работы по исправлению. И, что о багах в первую очередь надо сообщать в багтрекер http://redmine.russianfedora.pro/

region51 ★★ ()

russianfedora ломает зависимости
я как то запустил autoremove - -10 гигабайт

mystery ★★ ()

Совсем пообалдевали, тыкают зонды во все щели.

А на чём Вайбер под онтоп написан? Не на кутях случайно?

Deleted ()
Ответ на: комментарий от mystery

а ты что не смотришь, что он тянет?

или вбил autoremove, нажал да и ушел пить чай???

region51 ★★ ()
Ответ на: комментарий от region51

Оно предложило, я отказался есс-но
Просто дело в том, не все умеют рассписывать зависимости
Из-за скайпа кстати тоже

mystery ★★ ()
Ответ на: комментарий от mystery

russianfedora ломает зависимости

Не исключено. Но ппц странно же! qt-creator в @System, viber, вроде, тоже (сейчас не у компьютера, точно не скажу). Так с какого?

Deleted ()
Ответ на: комментарий от Deleted

@System, viber, вроде, тоже

Лицензию на Viber видел? Точнее исходники.
region51, я почему-то не нашёл такой баг в redmine.

yurikoles ★★★ ()
Последнее исправление: yurikoles (всего исправлений: 1)
Ответ на: комментарий от Deleted

Нет. У меня уже были комментарии в техразделы сегодня (вроде бы).

sudopacman ★★★★★ ()
Ответ на: комментарий от yurikoles

я почему-то не нашёл такой баг в redmine

Ну так правильно, никто же туда не писал, а я через конференцию ...

region51 ★★ ()
Ответ на: комментарий от sudopacman

Тогда какого хрена ты делаешь тут, если тебе нечего сказать?

Deleted ()
Ответ на: комментарий от yurikoles

Лицензию на Viber видел?

Нет, не видел.

Точнее исходники.

Тоже не видел. Я ж и сказал, что уверенности нет.

я почему-то не нашёл такой баг в redmine

Проверю вечером. Если выяснится, что баг точно в Russian Fedora, то репортну

Deleted ()
Ответ на: комментарий от Deleted

Почему нечего ? Ты задал вопрос, я ответил, в чём причина. Хочешь убрать ненужные зависимости — пересобери.

sudopacman ★★★★★ ()
Ответ на: комментарий от sudopacman

Ты говоришь совершенно очевидные вещи. То, что QtCreator тянет Viber, является — СЮРПРИИИИЗ! — проблемой зависимостей, было ясно и без тебя. Так что толку от твоего коммента — ноль. Так что прекращай шланговать и возвращайся в галерею.

Deleted ()
Ответ на: комментарий от region51

Да, подтверждаю, поправили! Удалил viber спокойно. С ним ещё, оказывается, draftsight был скачан О_о

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.