LINUX.ORG.RU

ошибка при yum update

 , ,


0

1

Добрый день. Хотелось бы предупредить недовольство участников форума и принести извИнения, если не верно выбрал раздел для вопроса. Ну и за то, что не смог найти решение своей проблемы в поисковике.

Преамбула: Линуксом пользуюсь, от силы, второй день - т.ч...

По проблеме: Fedora 21, выполнен yum update, после первой загрузки, добавлены какие-то репозитории (К сожалению не могу сказать какие - команды для просмотра не знаю, по какой статье делал не помню... Вот такой вот ламер 8( )

При выполнении sudo yum update следующая ошибка:

Загружены модули: langpacks
adobe-linux-i386                                            |  
951 B  00:00     
adobe-linux-x86_64                                          |  951 B  00:00     
fedora/21/x86_64/metalink                                   |  31 kB  00:00     
rpmfusion-free                                              | 1.2 kB  00:00     
rpmfusion-free-updates                                      | 2.7 kB  00:00     
rpmfusion-nonfree                                           | 1.2 kB  00:00     
rpmfusion-nonfree-updates                                   | 2.7 kB  00:00     
Could not retrieve mirrorlist http://mirrors.rfremix.ru/mirrorlist?repo=free-fedora-updates-released-21&arch=x86_64 error was
12: Timeout on http://mirrors.rfremix.ru/mirrorlist?repo=free-fedora-updates-released-21&arch=x86_64: (28, 'Connection timed out after 30001 milliseconds')
^CCould not retrieve mirrorlist http://mirrors.rfremix.ru/mirrorlist?repo=nonfree-fedora-21&arch=x86_64 error was
14: curl#56 - "Callback aborted"


 One of the configured repositories failed (Russian Fedora for Fedora 21 - Nonfree),
 and yum doesn't have enough cached data to continue. At this point the only
 safe thing yum can do is fail. There are a few ways to work "fix" this:

     1. Contact the upstream for the repository and get them to fix the problem.

     2. Reconfigure the baseurl/etc. for the repository, to point to a working
        upstream. This is most often useful if you are using a newer
        distribution release than is supported by the repository (and the
        packages for the previous distribution release still work).

     3. Disable the repository, so yum won't use it by default. Yum will then
        just ignore the repository until you permanently enable it again or use
        --enablerepo for temporary usage:

            yum-config-manager --disable russianfedora-nonfree

     4. Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=russianfedora-nonfree.skip_if_unavailable=true

Cannot find a valid baseurl for repo: russianfedora-nonfree/21/x86_64

______________________________

Пробовал сделать: sudo yum-config-manager --disable russianfedora-nonfree Результат:



========================= repo: russianfedora-nonfree ==========================
[russianfedora-nonfree]
async = True
bandwidth = 0
base_persistdir = /var/lib/yum/repos/x86_64/21
baseurl = 
cache = 0
cachedir = /var/cache/yum/x86_64/21/russianfedora-nonfree
check_config_file_age = True
cost = 1000
deltarpm_metadata_percentage = 100
deltarpm_percentage = 
enabled = 0
enablegroups = True
exclude = 
failovermethod = priority
gpgcadir = /var/lib/yum/repos/x86_64/21/russianfedora-nonfree/gpgcadir
gpgcakey = 
gpgcheck = True
gpgdir = /var/lib/yum/repos/x86_64/21/russianfedora-nonfree/gpgdir
gpgkey = file:///etc/pki/rpm-gpg/RPM-GPG-KEY-russianfedora-nonfree-fedora
hdrdir = /var/cache/yum/x86_64/21/russianfedora-nonfree/headers
http_caching = all
includepkgs = 
ip_resolve = 
keepalive = True
keepcache = False
mddownloadpolicy = sqlite
mdpolicy = group:small
mediaid = 
metadata_expire = 21600
metadata_expire_filter = read-only:present
metalink = 
minrate = 0
mirrorlist = http://mirrors.rfremix.ru/mirrorlist?repo=nonfree-fedora-21&arch=x86_64
mirrorlist_expire = 86400
name = Russian Fedora for Fedora 21 - Nonfree
old_base_cache_dir = 
password = 
persistdir = /var/lib/yum/repos/x86_64/21/russianfedora-nonfree
pkgdir = /var/cache/yum/x86_64/21/russianfedora-nonfree/packages
proxy = False
proxy_dict = 
proxy_password = 
proxy_username = 
repo_gpgcheck = False
retries = 10
skip_if_unavailable = False
ssl_check_cert_permissions = True
sslcacert = 
sslclientcert = 
sslclientkey = 
sslverify = True
throttle = 0
timeout = 30.0
ui_id = russianfedora-nonfree/21/x86_64
ui_repoid_vars = releasever,
   basearch
username = 

После чего еще раз запустить: sudo yum update - результат аналогичен первому запуску.

При этом смущает, что http://mirrors.rfremix.ru в браузере не открывается, ping на mirrors.rfremix.ru не проходит.

Но форуме, вот в этой теме: Fedora 18 ошибка при обновлении

Нашел вариант с: repoquery --whatrequires --recursive PACKAGENAME

Но, повторюсь, т.к. с линуксом полный ноль - даже не представляю, что делает данная команда (ушел читать).

_______________________________________________

Решение
_______________________________________________

Если кто-то из таких же нубов, как и я, зайдет - что бы не читать комментарии по оформлению и ошибкам:

yum clean all

Данная команда очищает кэш, на сколько понял из описания. Кстати, есть еще и команда на создание кэша, но я её не применял:

yum makecache

После этого я получил ошибку по flash'y и «Разрешение зависимостей» - было решено через «yum remove» для флэша и его переустановкой.

хм...

Дамы и господа, прошу прощения за вопрос.

Было сделано yum clean all, после чего пошло обновление. Но, есть следующая проблема - после обновления начал ругаться на flash

_____________________________- adobe-linux-i386 2/2 adobe-linux-x86_64 2/2 rpmfusion-free 470/470 rpmfusion-nonfree 178/178 Разрешение зависимостей --> Проверка сценария ---> Пакет flash-plugin.x86_64 0:11.2.202.457-release помечен для обновления ---> Пакет flash-plugin.x86_64 7:11.2.202.451-1.fc21.R помечен как обновление ---> Пакет workaround-cyrillic-console.noarch 0:1.1-3.fc21.R помечен для установки --> Проверка зависимостей окончена Ошибка: Multilib version problems found. This often means that the root cause is something else and multilib version checking is just pointing out that there is a problem. Eg.: 1. You have an upgrade for flash-plugin which is missing some dependency that another package requires. Yum is trying to solve this by installing an older version of flash-plugin of the different architecture. If you exclude the bad architecture yum will tell you what the root cause is (which package requires what). You can try redoing the upgrade with --exclude flash-plugin.otherarch ... this should give you an error message showing the root cause of the problem. 2. You have multiple architectures of flash-plugin installed, but yum can only see an upgrade for one of those architectures. If you don't want/need both architectures anymore then you can remove the one with the missing update and everything will work. 3. You have duplicate versions of flash-plugin installed already. You can use «yum check» to get yum show these errors. ...you can also use --setopt=protected_multilib=false to remove this checking, however this is almost never the correct thing to do as something else is very likely to go wrong (often causing much more problems). Защищённые версии multilib: 7:flash-plugin-11.2.202.451-1.fc21.R.x86_64 != flash-plugin-11.2.202.457-release.i386

SmallCKYHC ()

Так-с.. Видмо зря создавал тему - после удаления всех флэшов и выполнения в предыдушем ответе все работает. Извините.

SmallCKYHC ()

А еще есть

тег code 
. Весь выхлоп из консоли вставляй туда если не очень много, а если много на pastebin. Пометь тему решенной.

aplay ★★★★★ ()
Последнее исправление: aplay (всего исправлений: 1)
Ответ на: комментарий от aplay

Принято. Первый пост исправил, комментарии не получается.

Пробовал, в начале, использовать

для листинга - он не сработал...

SmallCKYHC ()

Хотелось бы предупредить недовольство участников форума и принести извенения

извенения

Теперь и за это принесешь извинения

Deleted ()
Ответ на: хм... от SmallCKYHC

Мог бы в лоркод оформить, нихрена не понятно.

Deleted ()
Ответ на: комментарий от Deleted

По вашему первому посту: Исправлено. По вашему второму посту: А можно отвлечься от грамматических ошибок и написать, что такое лоркод (или, хотя бы, как оно набирается на английском)? Поиск в гугле, по «лоркод» выдает ссылку на баркоды и прочие ean-13. При первом оформлении просмотрел хелп по оформлению, попробовал использовать «cut», который не сработал.

SmallCKYHC ()
Ответ на: комментарий от SmallCKYHC

LORCODE это слово можно встретить под формой отправки сообщения.

aplay ★★★★★ ()

У тебя RFRremix?
http://mirrors.rfremix.ru/mirrorlist?repo=nonfree-fedora-21&arch=x86_64 выдает

# repo = nonfree-fedora-21 arch = x86_64 country = RU country = EN
http://mirror.yandex.ru/fedora/russianfedora/russianfedora/nonfree/fedora/releases/21/Everything/x86_64/os/
ftp://mirror.yandex.ru/fedora/russianfedora/russianfedora/nonfree/fedora/releases/21/Everything/x86_64/os/
Что выглядит корректно. Так-что лучше включить обратно russianfedora-nonfree
sudo yum-config-manager --enable russianfedora-nonfree
И сделать как предлагает следующий пункт сообщения об ошибке:
Configure the failing repository to be skipped, if it is unavailable.
        Note that yum will try to contact the repo. when it runs most commands,
        so will have to try and fail each time (and thus. yum will be be much
        slower). If it is a very temporary problem though, this is often a nice
        compromise:

            yum-config-manager --save --setopt=russianfedora-nonfree.skip_if_unavailable=true

aplay ★★★★★ ()
Последнее исправление: aplay (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.