LINUX.ORG.RU
решено ФорумAdmin

Обновление OpenSuse с 42,3 до 15.

 , , ,


0

1

Доброго времени суток всем!

Тут намедни собрался таки взять и обновить системы до 15. НО! Меня несколько смущает то, что zypper dup говорит, что 1893 packages to upgrade, 811 to downgrade, 759 new, 369 to remove, 88 to change vendor, 10 to change arch.

Я бы сказал что меня очень смущает, что 400 пакетов будет удалено.

Кто обновлялся - не подскажете - нормально ли это? Это те репозитории, что включены на обновление:

3 | Leap:15.0                           | Leap:15.0                                            | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/repositories/openSUSE:Leap:15.0/standard/ 
4 | repo-update                         | openSUSE-Leap-42.3-Update                            | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/15.0/oss/                                           
5 | repo-update-non-oss                 | openSUSE-Leap-42.3-Update-Non-Oss                    | Yes     | (r ) Yes  | Yes     | http://download.opensuse.org/update/leap/15.0/non-oss/
The following 369 packages are going to be REMOVED:
  android-tools apache2-mod_php5 atftp baloo5 baloo5-lang bind-libs boost_1_61-devel boost-license1_61_0 catdoc
  cpp48 cpp5 cpp6 cups-filters-cups-browsed cups-filters-foomatic-rip cups-filters-ghostscript cups-libs
  cups-libs-32bit dbus-1-python dbus-1-python3 DirectFB-Mesa dirmngr dirmngr-lang discord
  drm-kmp-default-4.9.33_k4.4.79_4-5.2 drm-kmp-default-4.9.33_k4.4.114_42-7.1
  drm-kmp-default-4.9.33_k4.4.120_45-10.2 drm-kmp-default-4.9.33_k4.4.126_48-13.3 eiskaltdcpp-cli esound-daemon
  gcc48 gcc48-c++ gcc5 gcc5-c++ gcc6 gcc6-c++ gd-32bit gegl-0_2 gegl-0_2-lang genisoimage gstreamer-0_10
  gstreamer-0_10-lang gstreamer-0_10-plugins-base gstreamer-0_10-plugins-base-lang java-1_8_0-openjdk-plugin
  kdelibs4-branding-openSUSE ksplash-qml-branding-openSUSE ksplashx-branding-openSUSE ktp-accounts-kcm
  ktp-accounts-kcm-lang libamd-2_4_1 libasan0 libasan2 libasan3 libboost_atomic1_61_0 libboost_chrono1_61_0
  libboost_container1_61_0 libboost_context1_61_0 libboost_coroutine1_61_0 libboost_date_time1_54_0
  libboost_date_time1_61_0 libboost_filesystem1_54_0 libboost_filesystem1_61_0 libboost_graph1_61_0
  libboost_graph_parallel1_61_0 libboost_iostreams1_54_0 libboost_iostreams1_61_0 libboost_locale1_54_0
  libboost_locale1_61_0 libboost_log1_61_0 libboost_math1_61_0 libboost_mpi1_61_0 libboost_program_options1_61_0
  libboost_python1_61_0 libboost_python3-1_61_0 libboost_random1_61_0 libboost_regex1_61_0
  libboost_serialization1_61_0 libboost_signals1_61_0 libboost_system1_61_0 libboost_test1_61_0
  libboost_thread1_54_0 libboost_thread1_61_0 libboost_timer1_61_0 libboost_wave1_61_0 libbotan-1_10-1 libcamd-2_4_1
  libccolamd-2_9_1 libcholmod-3_0_6 libclang libcolamd-2_9_1 libcrypto41 libcrypto41-32bit libcryptsetup4
  libdialog11 libdirectfb-1_7-1 libelf0 libesd0 libesd0-32bit libevent-2_0-5 libffi4 libffi4-32bit libgegl-0_2-0
  libgfortran3 libgit2-24 libGLEW1_13 libgltf-0_0-0 libgps22 libgstapp-0_10-0 libgstinterfaces-0_10-0
  libgstreamer-0_10-0 libhdf5-10 libhdf5_hl10 libhttp-parser-suse0 libical1 libicu52_1 libicu52_1-data libiec61883
  libieee1284 libieee1284-32bit libiscsi7 libixion-0_12-0 libjasper1 libjasper1-32bit libjavascriptcoregtk-1_0-0
  libjson-c2 libjson-c2-32bit libkolab1 libktorrent6 libktorrent6-lang libktpaccountskcminternal9 liblash1
  liblash1-32bit liblcms-devel liblensfun0 liblept4 libLLVM libLLVM-32bit liblmdb-0_9_14 liblua5_1 liblua5_1-32bit
  libmarblewidget-qt5-27 libmicrohttpd10 libmpx0 libmpxwrappers0 libmysql56client18 libmysqlclient18
  libmysqlclient-devel libmysqlclient_r18 libmysqld18 libnetcdf7 libntfs-3g84 libOpenCOLLADA0 libopencv3_1
  libopencv-qt56_3 liborcus-0_12-0 libp8-platform2_0 libpodofo0_9_3 libpoppler60 libprocps3 libpsm2-compat libpth20
  libpython3_4m1_0 libqalculate6 libqmi-glib1 libqpdf13 libqpdf18 libqrencode3 libqt4-sql-mysql libQt5CLucene5
  libQtWebKit4 libQtWebKit-devel libraw15 libreoffice-templates-en libreoffice-templates-labels-a4
  libreoffice-templates-labels-letter libreoffice-templates-presentation-layouts librest0 libruby2_1-2_1
  libsgutils2-2 libsidplay1 libsilc-1_1-4 libsilcclient-1_1-4 libsmbios2 libsmbldap0 libsmbldap0-32bit
  libSPIRV-Tools-1_1 libSPIRV-Tools-1_1-32bit libssl43 libssl43-32bit libstdc++48-devel libstdc++6-devel-gcc5
  libstdc++6-devel-gcc6 libstorage7 libstorage-ruby libsuitesparseconfig-4_4_5 libswscale3 libts-1_0-0 libtxc_dxtn
  libumfpack-5_7_1 libunistring0 libva-egl1 libvigraimpex5 libvirt-python libvlccore8 libvpx1-32bit
  libwebkitgtk-1_0-0 libwebkitgtk2-lang libwebp5-32bit libwebpdemux1 libwebpmux1 libwx_baseu-2_8-0-stl
  libwx_baseu_net-2_8-0-stl libwx_baseu_net-suse1 libwx_baseu-suse1 libwx_baseu_xml-2_8-0-stl libwx_baseu_xml-suse1
  libwx_gtk2u_adv-2_8-0-stl libwx_gtk2u_adv-suse1 libwx_gtk2u_aui-2_8-0-stl libwx_gtk2u_aui-suse1
  libwx_gtk2u_core-2_8-0-stl libwx_gtk2u_core-suse1 libwx_gtk2u_gizmos-2_8-0-stl libwx_gtk2u_gl-2_8-0-stl
  libwx_gtk2u_gl-suse1 libwx_gtk2u_html-2_8-0-stl libwx_gtk2u_html-suse1 libwx_gtk2u_media-2_8-0-stl
  libwx_gtk2u_qa-suse1 libwx_gtk2u_richtext-2_8-0-stl libwx_gtk2u_stc-2_8-0-stl libwx_gtk2u_xrc-2_8-0-stl
  libwx_gtk2u_xrc-suse1 libxapian22 libxcb-xevie0 libxcb-xprint0 libXScrnSaver-devel libxtables10 libyui7
  libyui-ncurses7 libyui-ncurses-pkg7 libyui-qt7 libyui-qt-graph7 libyui-qt-pkg7 libzip2 lua mpg123-esound
  mysql-community-server mysql-community-server-bench mysql-community-server-client
  mysql-community-server-errormessages mysql-community-server-test mysql-community-server-tools
  patterns-openSUSE-apparmor patterns-openSUSE-apparmor_opt patterns-openSUSE-base patterns-openSUSE-enhanced_base
  patterns-openSUSE-enhanced_base_opt patterns-openSUSE-fonts patterns-openSUSE-fonts_opt patterns-openSUSE-games
  patterns-openSUSE-imaging patterns-openSUSE-imaging_opt patterns-openSUSE-kde patterns-openSUSE-kde_games
  patterns-openSUSE-kde_imaging patterns-openSUSE-kde_internet patterns-openSUSE-kde_multimedia
  patterns-openSUSE-kde_office patterns-openSUSE-kde_plasma patterns-openSUSE-kde_utilities
  patterns-openSUSE-kde_utilities_opt patterns-openSUSE-kde_yast patterns-openSUSE-multimedia
  patterns-openSUSE-multimedia_opt patterns-openSUSE-office patterns-openSUSE-office_opt
  patterns-openSUSE-sw_management patterns-openSUSE-sw_management_kde patterns-openSUSE-x11
  patterns-openSUSE-x11_opt patterns-openSUSE-xen_server patterns-openSUSE-yast2_basis perl-IO-Socket-IP perl-PlRPC
  perl-Term-ShellUI php5 php5-bz2 php5-ctype php5-curl php5-dom php5-fastcgi php5-fpm php5-gd php5-gettext
  php5-iconv php5-json php5-mbstring php5-mysql php5-openssl php5-pdo php5-sqlite php5-tokenizer php5-xmlreader
  php5-xmlwriter php5-zip php5-zlib pinentry-qt4 providers python3-cups python3-smbc
  python-backports.ssl_match_hostname python-cached-property python-cairo python-cffi python-configobj
  python-cryptography python-decorator python-docker-pycreds python-docopt python-gconf python-gobject
  python-gobject-cairo python-gobject-Gdk python-idna python-ipaddr python-libxml2 python-ndg-httpsclient
  python-numpy python-protobuf python-pyasn1 python-pycparser python-pyOpenSSL python-pyudev python-PyYAML
  python-requests python-setuptools python-six python-virtualenv python-wxWidgets python-wxWidgets-lang
  python-xcb-proto-devel qt-creator rdesktop recode rpm-python ruby2.1 ruby2.1-rubygem-abstract_method
  ruby2.1-rubygem-cfa ruby2.1-rubygem-cfa_grub2 ruby2.1-rubygem-cheetah ruby2.1-rubygem-fast_gettext-1_2
  ruby2.1-rubygem-gem2rpm ruby2.1-rubygem-ruby-augeas ruby2.1-rubygem-ruby-dbus ruby2.1-stdlib s2tc-32bit sash
  silc-toolkit steam susehelp susehelp_en unrar vaapi-dummy-driver vlc-codecs xdelta yast2-inetd yast2-storage
  zypp-plugin-python

Ну щас тебе i386 снесут да и ладно, лишнее не нужно, система линукса то одна на все окружения просто никто не хочет это признать

anonymous ()
Ответ на: комментарий от anonymous

Я приписал выше - оно грохнет мне мускуль, все паттерны, xdelta, discord, весь второй питон, часть третьего.

PearlyDragon ()

759 new

Там скорее всего все пакеты из 369 to remove

Allakka ★★★ ()

Таки всё нормально. Правда пришлось переустановить кое-что + сделать ссылку на libldap.so - без этого ни yast2, ни zypper не работали. И не работает kde-й NetworkManager. А в остальном - пошустрее будет.

PearlyDragon ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.