LINUX.ORG.RU

Сильно шумит куллер

 


0

2

У меня ноут с двумя видеокартами: Radeon R7 u Radeon R5. Установил чистый Arch. Установил:

xf86-video-ati

После включения начинает шуметь куллер.

Сначала решил, что задействованы 2 видеокарты. Решил проверить:

$ lspci | grep VGA

00:01.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Mullins [Radeon R4/R5 Graphics] (rev 05)

Ага, получается задействована только одна. Прочитал, что в новом ядре используется какой-то (не разбираюсь) спецаильный модуль для автоматического переключения между видеокартами. Так, хорошо. Идём дальше.

Проверил температуру процессора:

$ sensors acpitz-virtual-0 Adapter: Virtual device temp1: +47.0°C (crit = +255.0°C)

k10temp-pci-00c3 Adapter: PCI adapter temp1: +46.2°C (high = +70.0°C) (crit = +97.0°C, hyst = +90.0°C)

fam15h_power-pci-00c4 Adapter: PCI adapter power1: N/A (crit = 15.05 W)

radeon-pci-0008 Adapter: PCI adapter temp1: +47.0°C (crit = +120.0°C, hyst = +90.0°C)

Температура в норме. Что тогда может быть? Как устранить причину?

P.S. Выставил в БИОС опцию «Smart Always ON» на «Disable» - не помогло


В моём ноутбуке nvidia + intel, а охлаждение у них одно на двоих, поэтому температура всегда одинаковая. Это я к тому что возможно у тебя видео карта не выключена. Кстате вывод lspci | grep VGA как бы намекает, что система не видит второй видео карты и собственно не может управлять её энергопотреблением. Можешь ещё посмотреть кто больше всего кушает энергии через powertop

sany0k ()
Ответ на: комментарий от sany0k

Summary: 548,8 wakeups/second, 0,0 GPU ops/seconds, 0,0 VFS ops/sec and 18,0% CPU use

Usage Events/s Category Description

39,2 ms/s 162,5 Process kwin -session 1014cd7d2d4000144297394000000005420000_1443014078_161249

45,0 ms/s 108,0 Process kdeinit4: plasma-desktop [kdeinit]

22,6 ms/s 118,7 Process /usr/bin/firefox

100,0% Device Audio codec hwC0D0: ATI

25,2 ms/s 43,8 Process /usr/lib/xorg-server/Xorg -br -novtswitch -quiet :0 vt7 -nolisten tcp -auth /var/run/xauth/A:0-wqoRjb

1,0 ms/s 56,4 kWork od_dbs_timer

26,3 ms/s 15,6 Process /usr/bin/konsole

463,3 µs/s 22,4 Process [rcu_preempt]

135,2 µs/s 8,8 Timer ehci_hrtimer_func

11,7 ms/s 0,00 Process powertop

2,4 ms/s 2,9 Timer hrtimer_wakeup

0,9 ms/s 2,9 Timer tick_sched_timer

0,8 ms/s 1,0 Process ksysguardd

79,9 µs/s 1,0 Process [khungtaskd]

25,3 µs/s 1,0 Process [watchdog/3]

15,7 µs/s 1,0 Process [watchdog/1]

14,7 µs/s 1,0 kWork flush_to_ldisc

9,9 µs/s 1,0 Process [watchdog/2]

5,6 µs/s 1,0 Process [watchdog/0]

0,9 ms/s 0,00 Timer delayed_work_timer_fn

630,6 µs/s 0,00 Interrupt [7] sched(softirq)

571,6 µs/s 0,00 Interrupt [9] RCU(softirq)

425,5 µs/s 0,00 Interrupt [1] timer(softirq)

285,6 µs/s 0,00 Timer process_timeout

263,7 µs/s 0,00 Process [kworker/0:2]

238,0 µs/s 0,00 Process [kworker/1:1]

236,9 µs/s 0,00 Process [kworker/3:1]

208,3 µs/s 0,00 Process kdeinit4: krunner [kdeinit]

203,6 µs/s 0,00 Process [kworker/2:0]

161,6 µs/s 0,00 Process /usr/bin/dbus-daemon --session --address=systemd: --nofork --nopidfile --systemd-activation

91,8 µs/s 0,00 Process [ksoftirqd/3]

57,1 µs/s 0,00 Timer watchdog_timer_fn

55,0 µs/s 0,00 Process [ksoftirqd/1]

33,0 µs/s 0,00 kWork vmstat_update

25,0 µs/s 0,00 Process [ksoftirqd/0]

20,9 µs/s 0,00 Timer clocksource_watchdog

11,4 µs/s 0,00 kWork vmstat_shepherd

10,5 µs/s 0,00 kWork radeon_fence_check_lockup

5,6 µs/s 0,00 kWork cgroup_pidlist_destroy_work_fn

5,2 µs/s 0,00 Process [ksoftirqd/2]

n199a ()
Ответ на: комментарий от n199a

Какая-то версия powertop у тебя не там, у меня показывает потребляемые устройствами ваты. Но раз без зарядки не шумит смотри в сторону laptop-mode-tools

sany0k ()
Ответ на: комментарий от sany0k

PowerTOP показывает потребляемую мощность (точнее, её оценку) только после ~300 измерений при работе от батареи.

Впрочем, показывает оно её крайне херово и неточно, поэтому я советую вообще забыть про эту фичу.

intelfx ★★★★★ ()
Последнее исправление: intelfx (всего исправлений: 1)
Ответ на: комментарий от intelfx

kiotoze посоветовал:

У самого была такая проблема через этот баг https://bbs.archlinux.org/viewtopic.php?id=192255

До 4.0.1 я лично проверял и баг был, поэтому сидел на старом ядре, которое добавил в екслюд пакмана

Остальные вроде как отморозились от обсуждения. Надеюсь на твою помощь.

n199a ()
Ответ на: комментарий от intelfx

Цитата ещё оттуда:

I'm having the same issue with a HP Compaq 8510w. Upgraded from linux-3.17.6-1-i686 to linux-3.18.2-2-i686 and the fan was on what seems to be full speed. Downgraded back to linux-3.17.6-1-i686 and it's normal again.

Has anyone found/filed a kernel bug report?

n199a ()
Ответ на: комментарий от n199a

У меня нет этого железа и мне нечего сказать по теме. Откатывайся дальше, делай бисект, играйся с acpi_osi, пинай вендора и так далее. Всё как обычно.

intelfx ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.