LINUX.ORG.RU

APT-GET <--3.14@#%&#*@#!!


0

0

Ставил пакетик dpkg -i pack_name.deb, он что-то попросил. Я нашел что-то, что-то попросило еще что-то и т.д.

В итоге: попробовав dpkg -i --force-all pack_name.deb, получил шиш вместо установленного пакета. А теперь при установке любого пакета через apt-get install ошибка:

sudo apt-get install muine Password: Reading package lists... Done Building dependency tree... Done E: The package pack_name needs to be reinstalled, but I can't find an archive for it.

Ессесно, ничего не устанавливается=( Как быть???

ЗЫ куда только ни пробовал закладывать pack_name.deb, даже в /var/cache/apt/archives/

Re: APT-GET <--3.14@#%&#*@#!!

Как насчёт purge этого пакета через dpkg? А после этого не выёживаться с dpkg -i --force-all, а использовать всё-таки apt для обработки зависимостей?

Eldhenn ()
Ответ на: Re: APT-GET <--3.14@#%&#*@#!! от Eldhenn

Re: APT-GET <--3.14@#%&#*@#!!

Здесь похоже что-то по-запущенней=)

~$sudo dpkg --force-all --remove purge pack_name dpkg - warning: ignoring request to remove purge which isn't installed. dpkg - warning, overriding problem because --force enabled: Package is in a very bad inconsistent state - you should reinstall it before attempting a removal. (Reading database ... 63130 files and directories currently installed.) Removing pack_name ... /var/lib/dpkg/info/pack_name.postrm: line 2: /sbin/chkconfig: No such file or directory dpkg: error processing pack_name (--remove): subprocess post-removal script returned error exit status 127 Errors were encountered while processing: pack_name ~$

cheezee ()
Ответ на: Re: APT-GET <--3.14@#%&#*@#!! от cheezee

Re: APT-GET <--3.14@#%&#*@#!!

Поковыряй скрипт /var/lib/dpkg/info/pack_name.postrm, чтоб он хоть как-то мог выполниться.

WFrag ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.