LINUX.ORG.RU

Версии «связанных» пакетов в Debian

 , , , ,


1

3

Привет, Лор. Сегодня от нечего делать почитывал Лурк, наткнулся там на статейку про Debian. Автор пишет следующее:

Упоротый патчинг и скрещивание версий. Если в Fedora/Arch/Opensuse просто помещают свежий софт с зависимостями и не **** себе мозг, то debian позволяет себе обновлять половину зависимостей софта. Примером служит Gnome, где некоторые компоненты до сих пор 3.8 и при том напатченные, а некоторые - свежие. Стабильностью тут и не пахнет теперь.

Нетрудно убедиться, что это действительно так. Почему мейнтейнеры Debian-а так поступают?
Заранее спасибо за ответы.

Сегодня от нечего делать почитывал Лурк

Нетрудно убедиться, что это действительно так

...может и пруфы с лурка приведешь?

Google_Play ()

Какой-то рачешкольник или активист russianfedora от зависти написал полный бред на лурке. Кого это волнует?

Polugnom ★★★★★ ()

За весь Debian не отвечу, но по многим пакетам на период заморозки Debian Release Team предпочитает патчи новым версиям пакетов. Иными словами, если в репозитории было 1.4, в версии 1.5 добавили одну возможность и исправили 6 ошибок, то зачастую от разработчика хотят не 1.5, а 1.4 с шестью патчами. Вот и получается 1.4-2, которое почти 1.5.

Я тоже считаю, что этот подход приносит больше проблем, чем решает, но — что имеем, то имеем.

JackYF ★★★★ ()
Ответ на: комментарий от mandala

Ну если они неохотно суют новые пакеты в период заморозки, то тогда понятно, JackYF дело сказал. Но тогда впорос, почему нельзя в Sid-е все по-человечески сделать, там тоже разброс будь здоров.

happycorsair ()
Последнее исправление: happycorsair (всего исправлений: 1 )
Ответ на: комментарий от mandala

Разброс версий уж очень: 3.8 > 3.14.

Да, пожалуй. Что ж, тогда это наверняка выбор конкретной команды, в данном случае сопровождающих GNOME. Спроси в списке рассылки у них напрямую.

JackYF ★★★★ ()
Ответ на: комментарий от Tactile

Вот мне посоветовали спросить в списке рассылки debian. Если сильное желание, последуй совету.

mandala ★★★★ ()
Ответ на: комментарий от mandala

Почему именно так, мне по барабану, чесно говоря

Потому что старые gnome-panel, gnome-flashback и прочие вещи больше не часть гнома. У них свои версии и что ты на них смотришь. 99% гнома сейчас в testing версии 3.14.

Polugnom ★★★★★ ()
Последнее исправление: Polugnom (всего исправлений: 1 )
Ответ на: комментарий от JackYF

Хотят старые ошибки исправить, а не новые [возможности и ошибки] добавлять. ПО отлаживал?

Deleted ()
Ответ на: комментарий от Deleted

Хотят старые ошибки исправить, а не новые [возможности и ошибки] добавлять.

Непременно, и в каких-то случаях наверняка оправдано. Но я не далеко не убеждён, что риск от выборочного наложения патчей, наложенных в конфигурации, скорее всего не тестировавшейся больше нигде (включая разработчиков самого ПО) всегда ниже риска «взять последнюю версию стабильной ветки», особенно если сопровождающий предпочёл бы второй вариант.

JackYF ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.