LINUX.ORG.RU

Gentoo обновление браузера firefox

 ,


0

1

Всем доброго времени суток!
Совсем недавно перешел на Gentoo, поэтому прошу помочь, а не отправлять обратно на Ubuntu.
Вопрос вот в чем. Хочу установить браузер - Firefox.
# emerge --search firefox
Найден пакет в www-client/firefox версии 24 А в /usr/portage/www-client/firefox лежит файл firefox-32.0.ebuild

В итоге установилась 24 версия.
Правильно ли я понимаю, что если в portage есть файл firefox-32.0.ebuild то его можно установить?
Если да то почему он сразу не установился?

Потому что лентяи не читающие хэндбук в районе слов ACCEPT_KEYWORDS должны сидеть на бубунте.

devl547 ★★★★★ ()

man ACCEPT_KEYWORDS

Стабильная версия будет устанавливаться до тех пор, пока ты не разрешишь портажу ставить нестаб^W свежую.

mathcrosp ★★ ()
Последнее исправление: mathcrosp (всего исправлений: 2)

Рекомендую либо прочитать хэндбук, либо идти обратно на Ubuntu.

wakuwaku ★★★★ ()

Просто генточка защищает тебя от убогого интерфейса 32й версии.

Lavos ★★★★★ ()

emerge --search

мой совет, осиль eix, он для поиска пакетов тортовее

Если да то почему он сразу не установился?

как уже выше сказали, осиль хэндбук

Deleted ()

Есть stable и unstable.

http://packages.gentoo.org/package/www-client/firefox

ff 24 идет в stable
ff 32 идет в unstable

Надо размаскировать пакет, тогда его можно будет установить в стабильную систему.

P.S. Всегда пользовался анстейбл, по этому не скажу как это правильно делается.

afterlanding ★★ ()
Ответ на: комментарий от afterlanding

P.S. Всегда пользовался анстейбл, по этому не скажу как это правильно делается.

echo "www-client/firefox ~amd64" >> /etc/portage/package.keywords
Deleted ()

Найден пакет в www-client/firefox версии 24 А в /usr/portage/www-client/firefox лежит файл firefox-32.0.ebuild

Тебе уже ответили, но я переформулирую в менее резкой форме.

Такое может быть по 3м причинам:

1. Такую версию требует какая-то зависимость. Не твой случай.
Посмотреть можно командой:

$ equery d <пакет>
выведет перечень пакетов, которые зависят от того, что ты хочешь удалить/обновить. Далее у этих пакетов можно посмотреть зависимости (здесь я не буду рассказывать как, хорошо?). Далее думать что делать; например, бывает что зависимости включаются только из-за каких-то флагов - самый простой вариант. Бывают другие случаи.

2. Пакет замаскирован по каким-то причинам (не твой случай, это я так для расширения кругозора).
Я такое смотрю указывая явно установить данную версию. Вот, например, у меня замаскирован sddm версии 0.9.0-r1:

$ emerge -p1 --nodeps "=x11-misc/sddm-0.9.0-r1"

These are the packages that would be merged, in order:

[ebuild     U #] x11-misc/sddm-0.9.0-r1 [0.9.0]

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by =x11-misc/sddm-0.9.0-r1 (argument)
=x11-misc/sddm-0.9.0-r1
Обрати внимание на решетку в квадратных скобках. Как видишь, оно само говорит, мол, размаскируй. Если не ты маскировал, то размаскировать можно посредством /etc/portage/package.unmask. равда, если оно замаскировано не тобой, следует задуматься: это ведь неспроста.

3. Пакет не для твоей ветки. Это твой случай.
Проверить можно, опять же, попросив явно установить версию - оно само напишет, мол, ACCEPT_KEYWORDS и все такео. Еще, как тебе уже сказали, eix удобно покажет что в твоей ветки, а что нет. Я еще люблю смотреть на сайте http://gpo.zugaina.org - там оно еще оверлеи показывает. Еще можно в сам ebuild заглянуть; в общем, вариантов масса.

Для firefox (из ebuild):

KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
Или вот: http://gpo.zugaina.org/www-client/firefox
Все с тильдами. Значит из нестабильной ветки. Пакеты, которые будут «приниматься у тебя», можешь посмотреть так:
$ emerge --info | grep ACCEPT_KEYWORDS
Как перейти на нестабильную (точнее, тестовую) ветку, думаю, найдешь. Если нужно не глобально, а для конкретного пакета, см. в сторону /etc/portage/package.accept_keywords .

Пока ты на Gentoo недавно, не рекомендую переводить всю систему на нестабильную/тестовую ветку: проблем чуть больше.

P. S. firefox компилится очень долго: ставь firefox-bin. Особенно если нет причин ставить именно самую последнюю версию.

Kroz ★★★★★ ()
Последнее исправление: Kroz (всего исправлений: 1)
Ответ на: комментарий от Kroz

Благодарю за развернутый ответ!

Сейчас как раз читаю про ACCEPT_KEYWORDS. Решил только для firefox прописать ~amd64.Вся система пусть на стабильной ветке остается.

isildur ()
Ответ на: хэндбук читал от isildur

Да ладно, не такой уж и большой. То есть устанавливая, ты читал только тот текст который непосредственно говорил, что делать для установки? Или тебе кто-то другой генту ставил?

zinfandel ★★ ()
Ответ на: комментарий от zinfandel

Gentoo ставил сам по хэндбуку

Потихоньку разбираюсь, поставил KDE. Старую Ubuntu снес напрочь, теперь буду методом проб и ошибок Gentoo до рабочего состояния доводить.

isildur ()
Ответ на: Всем спасибо за помощь. от isildur

Не мучайся и ставь firefox-bin, можно нестабильный. Ничего важного ты флагами компиляции для фф не настроишь.

grem ★★★★★ ()
Последнее исправление: grem (всего исправлений: 1)

С Firefox уже решил

echo «www-client/firefox ~amd64» >> /etc/portage/package.keywords
Теперь с плагином adobe flash разбираюсь))

isildur ()
Ответ на: комментарий от anonymous

Могу сказать что до 29 версии у меня краш был раз в год, после неё уже раз в неделю/две.

invokercd ★★★★ ()
Ответ на: комментарий от mathcrosp

С этим тоже разобрался.

Сейчас другая проблема.
Dragon player видео не показывает на файлах .mp4 и .mov на остальных не пробовал.
Звук есть, а видео нет.

isildur ()
Ответ на: комментарий от afterlanding

P.S. Всегда пользовался анстейбл, по этому не скажу как это правильно делается.

Что, ни разу 9999 не размаскировал?

vurdalak ★★★★★ ()
Ответ на: комментарий от Deleted

Разве не рекомендуемый способ - отдельные файлы в подкаталогах package.use/, package.accept_keywords/ и т.д.?

anonymous ()
Ответ на: комментарий от anonymous

Разве не рекомендуемый способ

я если честно хз на счет «рекомендуемый», мне способ с одним файлом больше нравится, мне он как то удобнее.

Deleted ()
Ответ на: комментарий от afterlanding

Сейчас есть такая штука, как autounmask-write. Говоришь точную версию, добавляешь эту опцию, и оно само тебе предлагает добавить нужную строку в файл.

vurdalak ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.