LINUX.ORG.RU

OpenWRT и TP-LINK (TL-WR743ND)

 , ,


0

1

Здравствуйте!

Уважаемые форумчане, нужна ваша помощь! Имеется роутер TL-WR743ND, со сгоревшим WAN портом после грозы. Я решил прошить его альтернативной прошивкой OpenWRT, и переназначить WAN на один из LAN портов. Я нашёл статью как это сделать через web-интерфейс OpenWRT. Прошить получилось, но прошивка под мою ревизию (2.0) роутера оказалась без web-морды. По SSH могу зайти, пароль руту уже установил, но так как я не на ты с консолью Linux, я зашёл в тупик! Мне нужна web-морда, что-бы настроить порты (как я писал, в консоли понятия не имею как это сделать), а что-бы установить web-морду, нужно что-бы роутер имел доступ в интернет! Круг замкнулся, не знаю что теперь делать))

Помогите пожалуйста!

Залей обратно стоковую прошивку. Там должен быть режим с веб-мордой для этого встроенной.

vurdalak ★★★★★ ()
Ответ на: комментарий от analogg

В инструкции к роутеру должно быть. У меня это было так: 30 секунд подержать кнопку ресета, на 30 секунд отпустить, снова 30 подержать. Потом заходишь на 192.168.0.1 кажется, и там страничка загрузки прошивки. Которая работала только в IE :)

vurdalak ★★★★★ ()

Ищи как поставить luci

dvrts ★★★ ()
Ответ на: комментарий от vurdalak

Хороший совет, но как я загружу прошивку, если WAN порт не работает, и не будет доступа в интернет?! =)

analogg ()
Ответ на: комментарий от dvrts

Поставить то я нашёл как, только как я без доступа в интернет поставлю!?

analogg ()
Ответ на: комментарий от analogg

блджад, воткни кабель провайдера прямо в сетевую карту своего ПК

Ford_Focus ★★★★★ ()
Ответ на: комментарий от Ford_Focus

Ну воткну, а как я тогда подключусь к роутеру, если ситевуха у меня одна?

analogg ()
Ответ на: комментарий от analogg

Люди, вы суть вопроса в первом посте поняли?! У меня такое ощущение что нет. Я думал мне здесь подскажут как через SSH решить назначение порта, а в итоге, говорят что, да куда воткнуть. Это форум по linux, или по чём!?

analogg ()
Ответ на: комментарий от analogg

Вариант 1 - настроить через uci, думаю стоит смотреть в сторону uci show network, как там для wan настроено. Но вроде у разных устройств всё может быть по разному.
Вариант 2 - отдельно скачать пакеты с luci, закинуть на устройство и установить.

dinn ★★★★★ ()
Ответ на: комментарий от analogg

Это форум по linux, или по чём!?

Именно.
И здесь не любят, когда кто-то ведет себя так, как будто ему кто-то что-то должен, вот как вы сейчас.

Мне нужна web-морда, что-бы настроить порты
как через SSH решить назначение порта

Эгммм ...


1) Подключи шнурок к компу, скачай luci
2) Не отключая шнурок погугли про scp
3) Шнурок к роутеру.
4) ... бла-бла-бла.

Подробно и с картинками - только за деньги.

Myp3ik ★★ ()
Ответ на: комментарий от Myp3ik

И здесь не любят, когда кто-то ведет себя так, как будто ему кто-то что-то должен, вот как вы сейчас.
Подробно и с картинками - только за деньги.

ну и мудоебы анимешниги, однако
analogg
редактируешь /etc/config/network
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0t 2 3 4 5'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0t 1'
делаешь, например:
config switch_vlan
option device 'switch0'
option vlan '1'
option ports '0t 3 4 5'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0t 1 2'

parrto ()
Ответ на: комментарий от analogg

//_-

скачай всё необходимое, открой все нужные инструкции, воткни кабель от роутера

Ford_Focus ★★★★★ ()
Ответ на: комментарий от analogg

в стартовом посте посте нет не обозначено что нужно настроить именно через SSH - там как раз стоит предупреждение, что с работой в терминале у тебя не очень.

по сабжу - как настоить онное через терминал я тоже не нашёл, но:

http://wiki.openwrt.org/doc/howto/luci.essentials#minimalistic.offline.instal...

http://unixforum.org/index.php?showtopic=132528&st=0&p=1243145&#e...

Ford_Focus ★★★★★ ()
Ответ на: комментарий от parrto

Спасибо за ответ! Я решил идти другим путём, настроил wlan на OpenWRT в режиме клиента, и подцепился к другой точке доступа, интернет есть. Но меня ждало еще одно препятствие, при установке (через opkg) web-интерфейса luci, пишет что не достаточно памяти. Как можно обмануть?

analogg ()
Ответ на: комментарий от inoremap

Спасибо! Я уже откатил на родную. Я вижу они уже сегодня обновили. У меня вопрос, если сейчас заново установить, то мне нужно скачать factory, вместо sysupgrade который вы дали (с той же папки), и он тоже будет с web-интерфейсом? И как узнать что прошивка идёт с web-интерфейсом, или без?

analogg ()
Ответ на: комментарий от analogg

В общем прошил я роутер, всё отлично установилось, работает. Но опять не обошлось без проблем, когда настраиваю VLAN и включаю WANом один из LAN портов, роутер начинает жутко зависать, и через раз пингуется. Мосты настроил между VLANми, всё работает, WAN (exLAN) порт получает ip-адрес и шлюз от провайдера (у провайдера привязка по mac), с роутера могу пинговать сайты в интернете, а с компа нет.

analogg ()
Ответ на: комментарий от analogg

Возможно ли что зависания (или временный отвал локалки) из-за сырой прошивки? Так как начинается именно после включения VLANa.

analogg ()
Ответ на: комментарий от analogg

После долгих мучений, понял в чём проблема. У моего провайдера привязка по mac-адресу, если mac подходит, то устройству назначается определённый ip-адрес (он всегда у меня один и тот-же). Когда мне проводили интернет, и роутера у меня тогда не было, соответственно привязку сделали к сетевой карте моего ПК. Когда я купил этот роутер, в нём была функция клонирования mac-адреса, которая клонировала его с моей сетевой карты, и прикручивала к WAN-порту. Так вот, в настройках OpenWRT я к WAN-порту тоже прикрутил mac как у моей сетевой карты ПК, в итоге роутер получает ip-адрес, шлюз и т.д. Интернет с терминала роутера есть, всё пингуется! Но на моём ПК интернета нет, из командной строки ничего не пингуется (хотя ip сайта узнает, но ответа нет). Когда настраиваю wi-fi на роутере в режиме клиента, и подключаюсь к точке доступа соседей, интернет на ПК тоже есть. Долго ломал я голову, пошёл взял на время у соседей их роутер, настроил, подключил, всё интернет есть. И что-бы проверить работу WAN-порта на своём роутере, я подключил витую пару от ихнего LAN-порта в свой новый WAN (exLAN4). И увидел я такую-же картину, мой роутер получает ip, gateway, интернет на нём есть, а моему ПК не даёт. И тут я решил удалить mac-адрес сетевой карты моего ПК с интерфейса WAN в настройках Luci, и какое было моё удивление, всё заработало, интернет на ПК пошёл! Получается, что был конфликт mac-адресов, и ПК не получал интернет!

Но это не выход, т.к. я не смогу подключится к провайдеру без клонированного mac-адреса, как быть, подскажите!?

analogg ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.