LINUX.ORG.RU

Не работает USB

 ,


0

1

Добрый вечер. Помогите разобратся с проблемой- установил linuxcnc 2.6 на основе Debian Wheezy. ядро 3.4-9-rtai-686-pae после загрузки системы ни один из USB портов не работает.

mikhail@localhost:~$ dmesg | grep usb
[    1.267584] usbcore: registered new interface driver usbfs
[    1.267621] usbcore: registered new interface driver hub
[    1.284217] usbcore: registered new device driver usb
[    1.319699] usb usb1: New USB device found, idVendor=1d6b, idProduct=0002
[    1.319704] usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.319709] usb usb1: Product: EHCI Host Controller
[    1.319712] usb usb1: Manufacturer: Linux 3.4-9-rtai-686-pae ehci_hcd
[    1.319716] usb usb1: SerialNumber: 0000:00:1d.0
[    1.320599] usb usb2: New USB device found, idVendor=1d6b, idProduct=0002
[    1.320604] usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.320608] usb usb2: Product: xHCI Host Controller
[    1.320611] usb usb2: Manufacturer: Linux 3.4-9-rtai-686-pae xhci_hcd
[    1.320615] usb usb2: SerialNumber: 0000:00:14.0
[    1.320956] usb usb3: New USB device found, idVendor=1d6b, idProduct=0003
[    1.320961] usb usb3: New USB device strings: Mfr=3, Product=2, SerialNumber=1
[    1.320964] usb usb3: Product: xHCI Host Controller
[    1.320968] usb usb3: Manufacturer: Linux 3.4-9-rtai-686-pae xhci_hcd
[    1.320972] usb usb3: SerialNumber: 0000:00:14.0
[    1.631110] usb 1-1: new high-speed USB device number 2 using ehci_hcd
[   17.160510] usb 1-1: device not accepting address 2, error -110
[   17.272313] usb 1-1: new high-speed USB device number 3 using ehci_hcd
[   32.801772] usb 1-1: device not accepting address 3, error -110
[   32.913528] usb 1-1: new high-speed USB device number 4 using ehci_hcd
[   43.327711] usb 1-1: device not accepting address 4, error -110
[   43.439521] usb 1-1: new high-speed USB device number 5 using ehci_hcd
[   53.853668] usb 1-1: device not accepting address 5, error -110
пробовал ядро 3.10.32-xenomai-2.6.3- проблемма присутствует. при этом в ubuntu 12.04 и 14.04 все работает без проблем. материнка GIGABYTE J1800N Mini-ITX

ни один из USB не работает.

Судя по логу, втыкаешь девайс (кстати, какой?) в USB 2.0 порты. А с 3.0 что?

supreme ()
Ответ на: комментарий от supreme

дело в том что ничего не втыкаю. не работают ни порты сзади материнки, ни те что на корпусе.

kutsjuice ()
Ответ на: комментарий от kutsjuice

Попробуй выключить компьютер, вытащить всё из USB, подождать 5 минут, включить, после загрузки вставлять девайсы по одному. Этот странный метод иногда помогает, в т.ч. и мне.

ЕМНИП, этот код ошибки означает недостаток питания.

supreme ()
Ответ на: комментарий от supreme

дело в том что все порты пусты. подключены ps/2 клава и мышь и монитор, однако все равно выдает ошибку. и при попытке подключить к работающему компу хоть какое-то usb устройство не происходит ничего- в dmesg не появляется новых записей.

kutsjuice ()

Может, это udev так забавно глючит?

slamd64 ★★★★ ()
Ответ на: комментарий от kutsjuice

при попытке подключить к работающему компу хоть какое-то usb устройство не происходит ничего- в dmesg не появляется новых записей.

А # udevadm monitor не говорит ничего? Модули ehci*, uhci*, xchi* загружены?

yars068 ★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.