LINUX.ORG.RU

Не обновляются некоторые пакеты

 


0

1

Сделал сегодня eclean-dist -d, освободилось ~1G места и вывелся такой текст.

The following unavailable installed packages were found
             app-admin/eselect-ctags-1.14
             dev-perl/Locale-gettext-1.50.0
             dev-perl/XML-LibXML-2.1.400
             dev-perl/XML-NamespaceSupport-1.110.0
             dev-perl/XML-SAX-0.990.0
             dev-perl/XML-SAX-Base-1.80.0
             dev-perl/XML-Simple-2.200.0
             dev-python/m2crypto-0.21.1-r1
             g-octave/control-2.4.1
             sys-devel/bin86-0.16.19

Смотрю дальше.

fakemoon ~ # eselect ctags list
Available ctags symlink targets:
  [1]   exuberant-ctags *
fakemoon ~ # emerge -avNuD eselect-ctags

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] app-admin/eselect-ctags-1.16 [1.14] 9 kB

Total: 1 package (1 upgrade), Size of downloads: 9 kB

Would you like to merge these packages? [Yes/No] No

Quitting.

fakemoon ~ # emerge -avNuD world

These are the packages that would be merged, in order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 kB

Nothing to merge; quitting.

fakemoon ~ # equery d eselect-ctags
\ * These packages depend on eselect-ctags:
dev-util/ctags-5.8 (app-admin/eselect-ctags)
fakemoon ~ # equery d ctags
 * These packages depend on ctags:
app-editors/gvim-7.4.273 (dev-util/ctags)
app-editors/vim-7.4.273 (!minimal ? dev-util/ctags)
app-vim/tagbar-2.6.1 (>=dev-util/ctags-5.5)

Vim установлен, minimal флаг снят. С остальными пакетами похоже аналогично, все не проверял. Про dev86 была ложь, ebuild для него есть.

fakemoon ~ # ls /usr/portage/sys-devel/dev86/
ChangeLog  Manifest  dev86-0.16.19.ebuild  dev86-0.16.20.ebuild  dev86-0.16.21.ebuild  files  metadata.xml

Чего это такое происходит?

★★

У меня такое с перловыми пакетами постоянно. Приходится ручками emerge -1 делать.

iVS ★★★★★ ()

Спасся --with-bdeps=y. Но я не очень все же понимаю, пока. Наверно эти пакеты обновляются чаще тем те, которым они нужны в момент сборки.

amaora ★★ ()
Последнее исправление: amaora (всего исправлений: 3)

в моём тестинге такого нет

wakuwaku ★★★★ ()
Ответ на: комментарий от amaora

После обновления с --with-bdeps=y остался только один unavailable пакетg-octave/control. Но с ним все ясно, он установлен не через emerge.

amaora ★★ ()
Ответ на: комментарий от amaora

Вроде бы это разрешение на пересборку сборочных зависимостей.

Я думаю, что логика такая: «раз их ставили не явно, а это всего лишь зависимости, и они пока что удовлетворяют требования новых (обновляющихся сейчас) пакетов, то пересобирать их не нужно». А этот параметр делает пересборку зависимостей обязательной.

xasecoro ()
Ответ на: комментарий от xasecoro

Это не просто зависимости, а зависимости, которые используются только во время установки пакета. По умолчанию, emerge такие зависимости не обновляет без явного указания того, что это надо сделать. Если такое поведение не нравится, добавь в make.conf:

EMERGE_DEFAULT_OPTS="--with-bdeps y"

Black_Shadow ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.