LINUX.ORG.RU

Портал госуслуг

 , ,


3

4

У меня есть ключ, выданный ростелекомом.

захожу на портал госуслуг, там предлагают установить пакет IFCPlugin-x86_64.deb

Устанавливаю:

# dpkg -i IFCPlugin-x86_64.deb 
Selecting previously unselected package ifcplugin.
(Reading database ... 143573 files and directories currently installed.)
Unpacking ifcplugin (from IFCPlugin-x86_64.deb) ...
dpkg: dependency problems prevent configuration of ifcplugin:
 ifcplugin depends on pcscd; however:
  Package pcscd is not installed.

dpkg: error processing ifcplugin (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 ifcplugin

apt-get install pcscd

# dpkg -i IFCPlugin-x86_64.deb 
(Reading database ... 143611 files and directories currently installed.)
Preparing to replace ifcplugin 2.0.5.7 (using IFCPlugin-x86_64.deb) ...
Unpacking replacement ifcplugin ...
Setting up ifcplugin (2.0.5.7) ...
searching for Info.plist to update...
updating /usr/lib/pcsc/drivers/ifd-ccid.bundle/Contents/Info.plist
ards_p11_update_ifd_ccid_bundle.sh [user.warning] Sections to update   
ards_p11_update_ifd_ccid_bundle.sh [user.warning] Sections to update   
Done.

перезапускаю firefox, но всё равно ничего не работает. Пишет на сайте:

=== Cut ===
Ошибка: не установлен плагин

Для входа с помощью электронной подписи или УЭК необходимо:
Установить специальную программу — плагин для работы с электронной подписью на Портале государственных услуг. Для этого нажмите на ссылку Plugin для работы с электронной подписью. При появлении диалогового окна с кнопками «Выполнить» и «Сохранить» выберите «Выполнить». После установки плагина перезапустите браузер.
Для некоторых носителей электронной подписи требуется установить специальную программу — криптопровайдер. Для использвания УЭК установите криптопровайдер КриптоПро УЭК CSP (для загрузки потребуется пройти простую регистрацию).
Присоединить к компьютеру носитель ключа электронной подписи (USB-ключ, УЭК или смарт-карта). Должен быть вставлен только один носитель.
Средство электронной подписи можно получить в одном из аккредитованных Минкомсвязью России удостоверяющих центров. УЭК можно получить в уполномоченных организациях субъектов Российской Федерации.
Добавить адрес https://esia.gosuslugi.ru в список надёжных узлов (только для браузера Internet Explorer). Для этого необходимо:
- зайти в «Свойства обозревателя»;
- выбрать закладку «Безопасность»;
- выбрать зону для настройки параметров безопасности – «Надежные узлы», нажать на кнопку «Узлы»;
- в поле «Добавить в зону следующий узел» ввести адрес https://esia.gosuslugi.ru, нажать «Добавить» и закрыть данное окно.
=== Cut ===

Что сделать, чтобы заработало?

Что в пакете? Разархивируй и выложи.

crutch_master ★★★★★ ()
Ответ на: комментарий от crutch_master
root@machine:/home/user/Downloads# tar -tzvf data.tar.gz
drwxr-xr-x jenkins/root      0 2014-02-19 23:28 ./
drwxr-xr-x root/root         0 2014-02-19 23:28 ./etc/
drwxr-xr-x root/root         0 2014-02-19 23:28 ./etc/update_ccid_boundle/
-rwxr-xr-x root/root      2421 2014-02-19 23:28 ./etc/update_ccid_boundle/ards_p11_update_ifd_ccid_bundle.sh
-rwxr-xr-x root/root       512 2014-02-19 23:28 ./etc/update_ccid_boundle/update_ccid_boundle.sh
-rw-r--r-- root/root      1375 2014-02-19 23:28 ./etc/ifc.cfg
drwxr-xr-x root/root         0 2014-02-19 23:28 ./usr/
drwxr-xr-x root/root         0 2014-02-19 23:28 ./usr/lib/
drwxr-xr-x root/root         0 2014-02-19 23:28 ./usr/lib/mozilla/
drwxr-xr-x root/root         0 2014-02-19 23:28 ./usr/lib/mozilla/plugins/
-rw-r--r-- root/root   1084416 2014-02-19 23:28 ./usr/lib/mozilla/plugins/npIFCPlugin.so
drwxr-xr-x root/root         0 2014-02-19 23:28 ./usr/lib/mozilla/plugins/lib/
-rw-r--r-- root/root    108624 2014-02-19 23:28 ./usr/lib/mozilla/plugins/lib/libpkcs11_engine.so
-rw-r--r-- root/root     24160 2014-02-19 23:28 ./usr/lib/mozilla/plugins/lib/libengine_logger.so
-rw-r--r-- root/root   1975336 2014-02-19 23:28 ./usr/lib/mozilla/plugins/lib/libcrypto.so.1.0.0
-rw-r--r-- root/root     47736 2014-02-19 23:28 ./usr/lib/mozilla/plugins/lib/libconfig.so.9
-rw-r--r-- root/root    429920 2014-02-19 23:28 ./usr/lib/mozilla/plugins/lib/libssl.so.1.0.0
-rw-r--r-- root/root    122376 2014-02-19 23:28 ./usr/lib/mozilla/plugins/lib/libifc.so
-rw-r--r-- root/root   1611112 2014-02-19 23:28 ./usr/lib/mozilla/plugins/lib/libjcPKCS11x.so.1
-rw-r--r-- root/root   3371848 2014-02-19 23:28 ./usr/lib/mozilla/plugins/lib/rtPKCS11ECP.so
-rw-r--r-- root/root    287024 2014-02-19 23:28 ./usr/lib/mozilla/plugins/lib/libjcPKCS11.so
vmw8sl ()

Глупый вопрос, но оно точно всё скопировалось верно?

И да, через хромиум проверял?

sT331h0rs3 ★★★★★ ()
Ответ на: комментарий от vmw8sl

В адресной строке лисы - about:plugins. Что говорит?
УЭК - зонд. Сожги его.

crutch_master ★★★★★ ()
Ответ на: комментарий от sT331h0rs3

Глупый вопрос, но оно точно всё скопировалось верно?

Глупый ответ:

root@machine:/home/user/Downloads# md5sum -b /etc/update_ccid_boundle/ards_p11_update_ifd_ccid_bundle.sh /etc/update_ccid_boundle/update_ccid_boundle.sh /etc/ifc.cfg /usr/lib/mozilla/plugins/npIFCPlugin.so /usr/lib/mozilla/plugins/lib/libpkcs11_engine.so /usr/lib/mozilla/plugins/lib/libengine_logger.so /usr/lib/mozilla/plugins/lib/libcrypto.so.1.0.0 /usr/lib/mozilla/plugins/lib/libconfig.so.9 /usr/lib/mozilla/plugins/lib/libssl.so.1.0.0 /usr/lib/mozilla/plugins/lib/libifc.so /usr/lib/mozilla/plugins/lib/libjcPKCS11x.so.1 /usr/lib/mozilla/plugins/lib/rtPKCS11ECP.so /usr/lib/mozilla/plugins/lib/libjcPKCS11.so
83da432d8672c26f0361c686cfd02ba3 */etc/update_ccid_boundle/ards_p11_update_ifd_ccid_bundle.sh
a2047248aed320cfa0524fdc0e0aa4c7 */etc/update_ccid_boundle/update_ccid_boundle.sh
c672861a2ddf0f37568cfb37f52a16b9 */etc/ifc.cfg
eaa7005c8b48a6b0e9cb05a1d8077dac */usr/lib/mozilla/plugins/npIFCPlugin.so
64222d24e218b9e9db7644f08e0f887d */usr/lib/mozilla/plugins/lib/libpkcs11_engine.so
17e9fa299a96947eb8a0d3a60621d30e */usr/lib/mozilla/plugins/lib/libengine_logger.so
18efc58011c6948c5cdcd16a7d942545 */usr/lib/mozilla/plugins/lib/libcrypto.so.1.0.0
451fccc644b91e512bdc171d9468fc8e */usr/lib/mozilla/plugins/lib/libconfig.so.9
b0863c88f7fdb55b22d869fe33520cb6 */usr/lib/mozilla/plugins/lib/libssl.so.1.0.0
f55cbf7364d1458a1f3ad1619f6ac6c9 */usr/lib/mozilla/plugins/lib/libifc.so
4d4009aa3daaae9f818f3dd05988e330 */usr/lib/mozilla/plugins/lib/libjcPKCS11x.so.1
45ae84323adf4a923b53105f14b8cde9 */usr/lib/mozilla/plugins/lib/rtPKCS11ECP.so
2fa88870cf6b6ed2ebc2f5dc7960ba57 */usr/lib/mozilla/plugins/lib/libjcPKCS11.so

через хромиум проверял?

да, тоже выдается сообщение «Ошибка: не установлен плагин» такое же как в стартовом сообщении топика.

vmw8sl ()
Ответ на: комментарий от crutch_master

В адресной строке лисы - about:plugins. Что говорит?

Shockwave Flash
Gnome Shell Integration
iTunes Application Detector

vmw8sl ()
Ответ на: комментарий от vmw8sl

Значит лиса его не подцепила. about:addons проверь. Есть они там?

crutch_master ★★★★★ ()

сделай симлинки этого кала из пакета в ~/.mozilla/кудатотамplugins

anonymous ()
Ответ на: комментарий от crutch_master

about:addons проверь. Есть они там?

нет

Значит лиса его не подцепила.

да, наверное

сделай симлинки файлов из пакета в ~/.mozilla/кудатотамplugins

не понятно, в какой точно папке делать симлинки

vmw8sl ()
Ответ на: комментарий от vmw8sl

не понятно, в какой точно папке делать симлинки

~/.mozilla/plugins

dexpl ★★★★★ ()
Ответ на: комментарий от dexpl

Сделал

root@machine:/home/user/.mozilla/firefox# mkdir plugins
root@machine:/home/user/.mozilla/firefox# cd plugins
root@machine:/home/user/.mozilla/firefox/plugins# ln -s /usr/lib/mozilla/plugins/npIFCPlugin.so .
root@machine:/home/user/.mozilla/firefox/plugins/lib# ln -s /usr/lib/mozilla/plugins/lib/* .

перезапустил ff, ничего не поменялось

vmw8sl ()
Ответ на: комментарий от vmw8sl

перенёс из диры /home/user/.mozilla/firefox/plugins в диру /home/user/.mozilla/plugins, перезапустил firefox - не поменялось

vmw8sl ()
Ответ на: комментарий от vmw8sl

root@machine:/home/user/.mozilla/firefox/plugins# ln -s /usr/lib/mozilla/plugins/npIFCPlugin.so .

А зачем из-под рута в юзерском хомяке что-либо делать?

перезапустил ff, ничего не поменялось

Если запустить FF из эмулятора терминала (не из под рута, разумеется), он в stderr ничего не напишет?

dexpl ★★★★★ ()
Ответ на: комментарий от vmw8sl

вместо /home/user/.mozilla/plugins разместил симлинки в /home/user/.mozilla/extensions - не работает тоже

vmw8sl ()
Ответ на: комментарий от dexpl

А зачем из-под рута в юзерском хомяке что-либо делать?

да, ты прав, я ошибся.

стёр созданные симлинки, переделал из-под пользователя:

user@machine:~/.mozilla$ cd ~/.mozilla/
user@machine:~/.mozilla$ mkdir plugins
user@machine:~/.mozilla$ cd plugins
user@machine:~/.mozilla/plugins$ ln -s /usr/lib/mozilla/plugins/npIFCPlugin.so .
user@machine:~/.mozilla/plugins$ mkdir lib
user@machine:~/.mozilla/plugins$ cd lib
user@machine:~/.mozilla/plugins/lib$ ln -s /usr/lib/mozilla/plugins/lib/* .

Если запустить FF из эмулятора терминала (не из под рута, разумеется), он в stderr ничего не напишет?

перезапустил, в терминале ничего не пишет

vmw8sl ()
Ответ на: комментарий от vmw8sl

да, тоже выдается сообщение «Ошибка: не установлен плагин» такое же как в стартовом сообщении топика.

Я имел в виду, разумеется, с симлинками плагина в директории хромиума.

sT331h0rs3 ★★★★★ ()

Позвонил в техподдержку, сказали что создали заявку INC000000589850 и ответят в течение 4-х дней

vmw8sl ()
Ответ на: комментарий от sT331h0rs3

в директории хромиума

напиши, пожалуйста, в какой точно

vmw8sl ()
Ответ на: комментарий от sT331h0rs3

/usr/lib/chromium-browser/plugins/

нет такой диры, есть
/usr/lib/chromium/plugins/

скопировал в неё, эффекта нет

chrome://plugins/ показывает один плагин
Chromoting Viewer

в консоли пишет

user@machine:~$ chromium
[12473:12473:0710/150208:ERROR:component_loader.cc(138)] Failed to parse extension manifest.
vmw8sl ()
Ответ на: комментарий от vmw8sl

но про манифест он пишет и в том случае, если стереть всё из папки /usr/lib/chromium/plugins/

vmw8sl ()
Ответ на: комментарий от crutch_master

Нашел плагин для Gentoo:
http://gpo.zugaina.org/app-crypt/ifcplugin

# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

EAPI=5

DESCRIPTION="Plugin for gosuslugi.ru auth"
HOMEPAGE="http://gosuslugi.ru"
SRC_URI="
	amd64?	( https://esia.gosuslugi.ru/sia-web/htdocs/plugin/IFCPlugin-x86_64.deb )
	x86?	( https://esia.gosuslugi.ru/sia-web/htdocs/plugin/IFCPlugin-i386.deb )"

RESTRICT="strip"
LICENSE=""
SLOT="0"
KEYWORDS="**"
IUSE=""

DEPEND=""
RDEPEND="${DEPEND}"
S="${WORKDIR}"

src_unpack() {
	unpack ${A}
	unpack ./data.tar.gz
	cd "${S}"

	# removing not necessary content
	rm control.tar.gz data.tar.gz debian-binary 
}

src_install() {
	cp -pPR * "${D}"/ || die "installing data failed"
}
vmw8sl ()

обычно в конце делаю еще один dpkg -i IFCPlugin-x86_64.deb, чтобы доконфигурялся

MyTrooName ★★★★★ ()

захожу на портал госуслуг, там предлагают установить пакет IFCPlugin-x86_64.deb
Устанавливаю:

А правильно закрывать вкладку и никогда больше не открывать, если без этого не работает.

Deleted ()

Я решил проблему скопировав в другой каталог. Надо ставить сюда: /usr/lib64/nsbrowser/plugins И всё заработало.

keeper_b ★★★ ()

ты должен использовать internet explorer

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.