LINUX.ORG.RU

Ошибка с libssl-dev

 ,


0

1

Качаю пакет

http://ports.ubuntu.com/pool/main/o/openssl/libssl-dev_1.1.1f-1ubuntu2_arm64.deb

Ставлю пакет

sudo dpkg -i libssl-dev_1.1.1f-1ubuntu2_arm64.deb

ошибка

dpkg: warning: downgrading libssl-dev:arm64 from 3.0.2-0ubuntu1.6 to 1.1.1f-1ubuntu2
(Reading database ... 108982 files and directories currently installed.)
Preparing to unpack libssl-dev_1.1.1f-1ubuntu2_arm64.deb ...
Unpacking libssl-dev:arm64 (1.1.1f-1ubuntu2) over (3.0.2-0ubuntu1.6) ...
dpkg: dependency problems prevent configuration of libssl-dev:arm64:
 libssl-dev:arm64 depends on libssl1.1 (= 1.1.1f-1ubuntu2); however:
  Package libssl1.1 is not installed.

dpkg: error processing package libssl-dev:arm64 (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libssl-dev:arm64

при попытке поставить libssl1.1

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package libssl1.1 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'libssl1.1' has no installation candidate

помогите пж

скачай пакет и разархивируй куда-нибудь в opt, программам, которым требуется эта либа прописывай LD_PRELOAD

я так делал с диваном и либами из ubuntu, и бинарниками, собранными для ubuntu

IvanRia ()
Последнее исправление: IvanRia (всего исправлений: 1)
Ответ на: комментарий от Danger271

Что тебе не понятно? «-dev» это пакет с заголовочными файлами программы (библиотеки) зависимостью «-dev» пакета является сам пакет. Скачай и его и ставь их вместе

dpkg -i package package-dev
kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

не не не ниче не понял, https://ubuntu.pkgs.org/20.04/ubuntu-main-arm64/libssl-dev_1.1.1f-1ubuntu2_arm64.deb.html

тут есть только один пакет который мне нужен, какие мне вместе ставить?

Danger271 ()
Последнее исправление: Danger271 (всего исправлений: 1)
Ответ на: комментарий от Danger271

Не вижу, где там используется openssl, ну да ладно.

Вам проще будет добавить репозитории от 20.04; поскольку версии пакетов в ней более старые, ничего случайно установиться оттуда и что-то сломать не должно.

Rootlexx ★★★ ()
Ответ на: комментарий от Danger271

А теперь проанализируй твой вопрос, вывод команды и ответы, что тебе даны и оцени, достаточны ли они были для решения проблемы или нет.

На мой взгляд ты просто не хотел думать.

kostik87 ★★★★★ ()
Для того чтобы оставить комментарий войдите или зарегистрируйтесь.