LINUX.ORG.RU

Тонкая настройка laptop mode tools

 ,


0

1

Не могу настроить некоторые тонкие материи через LMT. Некоторые параметры энергосбережения переключаются в конфигах просто on-off, хотя у них есть числовые значения соответственно эффекту, например /proc/sys/vm/laptop_mode или /sys/module/snd_hda_intel/parameters/power_save. По дефолту оно переключается с 0 на 2 в обоих случаях, хотя самые агрессивные настройки 5 и 10 соответственно и вот их то я и не могу прописать. А что самое странное, ручной посыл значений через exec-commands.conf не срабатывает. Все писано по ману и арчевики, сам LMT 1.65, xubuntu 14.04.

Например есть строка

BATT_EXEC_COMMAND_0="echo 5 > /proc/sys/vm/laptop_mode" # Enable power saving feature 0 here
выдергиваю шнур, выдавливаю стекло, пишу
 cat /proc/sys/vm/laptop_mode
и вижу 2 вместо 5, хотя руками в консоли все работает. И так с 3-4 разными параметрами. Подскажите куда копать.

★★★★★

попробуй лучше TLP, там возможностей по настройке больше + поддержка лучше

Stribog ()

А с чего ты взял, что состиояний больше, чем два? А если больше, то для каких целей предназначены?

Также, не стоит забывать, что основное управление осуществляет ядро напрямую и pm-utils, laptop mode tools лишь набор скриптов.

anonymous ()
Ответ на: комментарий от anonymous

Я же это и написал, после «echo 5 > /proc/sys/vm/laptop_mode» руками, «cat /proc/sys/vm/laptop_mode» показывает «5», как и должно быть. LMT переключает только на «2», а кастомные команды игнорирует.

Lordwind ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.