LINUX.ORG.RU

Не отображается иконка nm-applet в трее

 , ,


0

1

Debian 7. Изначально с Gnome 3, потом dwm + systray patch.

При запуске nm-applet занимает место в трее и работает (открывает меню при нажатиях), но не отображает иконку.
При запуске второй копии nm-applet обе иконки появляются:

$ nm-applet &
#иконки нет
$ nm-applet &
#обе иконки отображаются
$ killall nm-applet
#убиты
$ nm-applet &
#иконки снова нет

Единственное нагугленное решение установить NoDisplay=false в /etc/xdg/autostart/nm-applet.desktop не помогает.

Что за?

А nm-applet стартует после dwm? Как его запускаете?

anonymous ()
Ответ на: комментарий от anonymous

Да, после. Запускает патч autostart, командой nm-applet &. Можно вручную из консоли или dmenu — разницы нет.

metrokto ★★ ()
Ответ на: комментарий от anonymous_sama

1. В /etc/xdg/autostart/nm-applet.desktop и в ./config/autostart/nm-applet.desktop (если есть) должно быть: NoDisplay=true

Не помогает.

2. sudo service network-manager stop
sudo rm /var/lib/NetworkManager/NetworkManager.state
sudo service network-manager start

До перезагрузки.

3. В dconf-editor Apps –> nm-applet show-applet, поставить галочку

nm-applet там отсутствует.

Если все не возымело эффект, то добавить 'nm-applet --sm-disable'

Без эффекта.

metrokto ★★ ()
Ответ на: комментарий от metrokto

Я думаю это проблема

dwm + systray patch

Попробуй убрать nm-applet.desktop c /etc/xdg/autostart и запускать отдельно с 'nm-applet --sm-disable' с autostart скрипта/конфига твоего dwm, возможно с wait, если все совсем плохо.
Проше говоря, я предлагаю тебе убрать nm-applet из автостарта совсем, и запускать его уже после запуска dwm, его средствами.

anonymous_sama ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.