LINUX.ORG.RU
ФорумGames

GL_EXT_texture_sRGB_decode is not supported

 , ,


0

1

Запускаю стим. Все игры работают, кроме как team fortress 2, который при запуске вываливается с такой ошибкой. Гуглил. Проблема не только у меня, много у кого, кто пользует 64 бит линуксы. Решение проблемы найдено не было, так как топики на пол пути забрасывали. Может тут сможем разобраться? Итак, что имею:

$ eix -I ati-dri | grep Installed
     Installed versions:  12.6_beta_pre897(1)^d(19:57:55 27.01.13)(kernel_linux modules multilib -debug -qt4 -static-libs)

$ eix -I xorg-server | grep Installed
     Installed versions:  1.12.4(20:08:15 27.01.13)(ipv6 nptl udev xorg -dmx -doc -kdrive -minimal -selinux -static-libs -tslib -xnest -xvfb)

$ uname -a
Linux sysadmin 3.5.7-gentoo #4 SMP Mon Jan 21 21:25:58 Local time zone must be set--see zic  x86_64 Pentium(R) Dual-Core CPU T4500 @ 2.30GHz GenuineIntel GNU/Linux~ 

$ lspci | grep VGA
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV710 [Mobility Radeon HD 4500/5100 Series]

Так а что тут разбираться? Железо или драйвер не поддреживает расширение GL_EXT_texture_sRGB_decode, которое нужно игре.

andreyu ★★★★★ ()

Installed versions: 12.6_beta_pre897

Разве не очевидно? :) Даже для legacy-карт уже есть 13.1.

ArtKun ★★★★★ ()

Залей бинарь от TF, который юзаешь, на тот же rghost и скинь сюда ссылку. Хочу взглянуть на ошибку поближе.

Sadler ★★★ ()
Ответ на: комментарий от Sadler

Залей бинарь от TF, который юзаешь, на тот же rghost и скинь сюда ссылку. Хочу взглянуть на ошибку поближе.

Весь дистрибутив игры или как?

KERNEL_PANIC ★★★ ()
Ответ на: комментарий от KERNEL_PANIC

Только непосредственно бинарь. Ресурсы игры меня не интересуют. Ну, ещё либы можно положить, если весят в пределах разумного.

Sadler ★★★ ()
Ответ на: комментарий от Sadler

Заменил библиотеку. Запустилось. Пока в менюшке лазил игру выбило и после этого она перестала запускаться. Пускаю с консоли, вывод показывает, что она сегфолтиться:

SDL video target is 'x11'
SDL video target is 'x11'
This system supports the OpenGL extension GL_EXT_framebuffer_object.
This system supports the OpenGL extension GL_EXT_framebuffer_blit.
This system supports the OpenGL extension GL_EXT_framebuffer_multisample.
This system DOES NOT support the OpenGL extension GL_APPLE_fence.
This system DOES NOT support the OpenGL extension GL_NV_fence.
This system supports the OpenGL extension GL_ARB_sync.
This system supports the OpenGL extension GL_EXT_draw_buffers2.
This system supports the OpenGL extension GL_EXT_bindable_uniform.
This system DOES NOT support the OpenGL extension GL_APPLE_flush_buffer_range.
This system supports the OpenGL extension GL_ARB_map_buffer_range.
This system supports the OpenGL extension GL_ARB_vertex_buffer_object.
This system supports the OpenGL extension GL_ARB_occlusion_query.
This system DOES NOT support the OpenGL extension GL_APPLE_texture_range.
This system DOES NOT support the OpenGL extension GL_APPLE_client_storage.
This system DOES NOT support the OpenGL extension GL_ARB_uniform_buffer.
This system supports the OpenGL extension GL_ARB_vertex_array_bgra.
This system supports the OpenGL extension GL_EXT_vertex_array_bgra.
This system supports the OpenGL extension GL_ARB_framebuffer_object.
This system DOES NOT support the OpenGL extension GL_GREMEDY_string_marker.
This system DOES NOT support the OpenGL extension GL_ARB_debug_output.
This system supports the OpenGL extension GL_EXT_direct_state_access.
This system DOES NOT support the OpenGL extension GL_NV_bindless_texture.
This system supports the OpenGL extension GL_AMD_pinned_memory.
This system DOES NOT support the OpenGL extension GL_EXT_framebuffer_multisample_blit_scaled.
This system DOES NOT support the OpenGL extension GL_EXT_texture_sRGB_decode.
This system DOES NOT support the OpenGL extension GL_NVX_gpu_memory_info.
This system supports the OpenGL extension GL_ATI_meminfo.
This system supports the OpenGL extension GL_EXT_texture_compression_s3tc.
This system DOES NOT support the OpenGL extension GLX_EXT_swap_control_tear.
GL_NV_bindless_texture: DISABLED
GL_AMD_pinned_memory: DISABLED
GL_EXT_texture_sRGB_decode: NOT AVAILABLE
/home/keed/Steam/SteamApps/a_kondratiev/Team Fortress 2/hl2.sh: рядок 72: 24903 Segmentation fault      ${GAME_DEBUGGER} "${GAMEROOT}"/${GAMEEXE} "$@"
Game removed: AppID 440 "Team Fortress 2", ProcID 24898 
saving roaming config store to 'sharedconfig.vdf'
roaming config store 2 saved successfully
А обновлять не получается, так как это последняя версия драйвера, на котором заводится Х :(

KERNEL_PANIC ★★★ ()

Кстати, то ли в ЛОРе что-то поменяли, толи мне повылазило, хм...

KERNEL_PANIC ★★★ ()
Ответ на: комментарий от andreyu

http://devgurus.amd.com/thread/160129

Железо поддерживает. Железо вообще много чего поддерживает. Линуксовый драйвер не поддерживает. В opengl вендовом драйвере amd куда больше расширений.

bhfq ★★★★★ ()
Ответ на: комментарий от KERNEL_PANIC

А обновлять не получается, так как это последняя версия драйвера, на котором заводится Х :

Вот вам и «линукс готов для десктоп», вот вам и «вендекопец».

bhfq ★★★★★ ()
Ответ на: комментарий от bhfq

Вот вам и «линукс готов для десктоп», вот вам и «вендекопец»

та да :(

KERNEL_PANIC ★★★ ()
Ответ на: комментарий от KERNEL_PANIC

Пока в менюшке лазил игру выбило и после этого она перестала запускаться. Пускаю с консоли, вывод показывает, что она сегфолтиться:

Ну, значит ему действительно так необходимо это расширение, либо я криво оторвал сообщение об ошибке (ибо так и не нашёл нормальный дебагер под линукс с возможностью патчить инструкции на месте и сохранять результат)

Sadler ★★★ ()
Ответ на: комментарий от KERNEL_PANIC

Обновись до Catalyst 13.1 наконец!

Написали ведь уже, что у тебя legacy-карта, для которой нужен legacy-драйвер, последняя версия которого вышла пару недель назад.

anonymous ()

Аноним все правильно пишет. hd 2600 xt, была такая же ошибка, в 13.1 исправили. В генту тормозят, до сих пор нету 13.1-legacy, хотя 2 недели уже прошло. Пришлось пилить в локальный оверлей. Все работает, но тормозит жутко.

 Installed versions:  13.1(1)^d[1](09:47:15 PM 01/22/2013)(kernel_linux modules multilib qt4 -debug -static-libs)
vladkuzm ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.