LINUX.ORG.RU

Проблемы с запуском hackmud

 , , ,


0

1

Добрый день, при попытке запуска hackmud в steam игра на секунду запускается (появляется статус в игре, само окно не открывалось), а потом сразу же завершается. При запуске через терминал вот что выводит

./hackmud_lin.x86_64                                           
Set current directory to /home/kirill/.steam/steam/steamapps/common/hackmud
Found path: /home/kirill/.steam/steam/steamapps/common/hackmud/hackmud_lin.x86_64
Mono path[0] = '/home/kirill/.steam/steam/steamapps/common/hackmud/hackmud_lin_Data/Managed'
Mono config path = '/home/kirill/.steam/steam/steamapps/common/hackmud/hackmud_lin_Data/Mono/etc'
Preloaded 'ScreenSelector.so'
Preloaded 'libCSteamworks.so'
Preloaded 'libsteam_api.so'
Unable to preload the following plugins:
        ScreenSelector.so
        libCSteamworks.so
        libsteam_api.so
Display 0 '0': 1024x600 (primary device).
Logging to /home/kirill/.config/unity3d/DrizzlyBear/hackmud/Player.log
В логе
cat /home/kirill/.config/unity3d/DrizzlyBear/hackmud/Player.log
Desktop is 1024 x 600 @ 60 Hz
Unable to find a supported OpenGL core profile
Failed to create valid graphics context: please ensure you meet the minimum requirements
E.g. OpenGL core profile 3.2 or later for OpenGL Core renderer
[Vulkan init] extensions: count=2
[Vulkan init] extensions: name=VK_EXT_debug_report, enabled=0
[Vulkan init] extensions: name=VK_EXT_debug_utils, enabled=0
Vulkan error VK_ERROR_INCOMPATIBLE_DRIVER (-9) file: ./Runtime/GfxDevice/vulkan/VKContext.cpp, line: 313
Vulkan detection: 0
No supported renderers found, exiting

(Filename:  Line: 590)
Проблема в OpenGL? Вот доп инфа
glxinfo | grep OpenGL
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Pineview M 
OpenGL version string: 1.4 Mesa 19.0.0-devel (git-4d3f6cb 2019-01-03 bionic-oibaf-ppa)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 2.0 Mesa 19.0.0-devel (git-4d3f6cb 2019-01-03 bionic-oibaf-ppa)
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 1.0.16
OpenGL ES profile extensions:
inxi -G  
Graphics:  Device-1: Intel Atom Processor D4xx/D5xx/N4xx/N5xx Integrated Graphics driver: i915 v: kernel 
           Display: x11 server: X.Org 1.19.6 driver: intel unloaded: fbdev,modesetting,vesa resolution: 1024x600~60Hz 
           OpenGL: renderer: Mesa DRI Intel Pineview M v: 1.4 Mesa 19.0.0-devel (git-4d3f6cb 2019-01-03 bionic-oibaf-ppa)

Unable to find a supported OpenGL core profile Failed to create valid graphics context: please ensure you meet the minimum requirements E.g. OpenGL core profile 3.2 or later for OpenGL Core renderer
OpenGL version string: 1.4

xDShot ★★★★ ()

Можешь смело запрашивать возврат в стиме, так как в требованиях ничего не сказано было о современной карте. Да и таким разрабам в лицо надо плевать за использование Unity (!!!) для текстовиков.

xDShot ★★★★ ()

можно попробовать

export MESA_GL_VERSION_OVERRIDE=3.2

если повезёт то реально оно расширений из 3.2 не использует и всё заработает.. если нет, то можно подсунуть игре софтовый опенгл, но тут я уже не поскажу как..

Thero ★★★★★ ()