LINUX.ORG.RU

По офф вики ничего не получается, а layman не хочет ставится.Может кто-то кинуть .ebuild файл для стима?

тогда должен страдать.

UPD.

Может кто-то кинуть .ebuild файл для стима?

http://gpo.zugaina.org/

Deleted ()
Последнее исправление: nepank (всего исправлений: 1)

ничего не получается... не хочет ставится

Ты какой-то неправильный гентушник. Что не получается? Что делал? К чему привело? Какие ошибки?
Может тебе лучше на Убунту переехать?
Или, чего уж мелочиться, на Винду? Там Стим работает как часы.

JacobTwoTwo ()
Ответ на: комментарий от sehellion
# eix -I steam
[I] games-util/steam-client-meta [1]
     Available versions:  (~)0-r20160828 **0-r20161126 {flash +pulseaudio steamfonts +steamruntime streaming trayicon VIDEO_CARDS="intel nvidia"}
     Installed versions:  0-r20160828(03:30:32 PM 08/20/2017)(pulseaudio steamruntime -flash -steamfonts -streaming -trayicon VIDEO_CARDS="nvidia -intel")
     Homepage:            http://steampowered.com
     Description:         Meta package for Valve's native Steam client

[I] games-util/steam-games-meta [1]
     Available versions:  (~)0-r20160812 {mono s3tc steamgames_bioshock_infinite steamgames_defenders_quest steamgames_dirt_rally steamgames_dirt_showdown steamgames_dont_starve steamgames_dwarfs steamgames_hammerwatch steamgames_ironclad_tactics steamgames_journey_down steamgames_narcissu steamgames_painkiller steamgames_portal steamgames_shadow_mordor steamgames_shatter steamgames_source_engine steamgames_te120 steamgames_tf2 steamgames_trine2 steamgames_unwritten_tales steamgames_voidexpanse steamgames_witcher2 +steamruntime VIDEO_CARDS="fglrx intel nouveau nvidia radeon"}
     Installed versions:  0-r20160812(03:30:27 PM 08/20/2017)(steamruntime -mono -s3tc -steamgames_bioshock_infinite -steamgames_defenders_quest -steamgames_dirt_rally -steamgames_dirt_showdown -steamgames_dont_starve -steamgames_dwarfs -steamgames_hammerwatch -steamgames_ironclad_tactics -steamgames_journey_down -steamgames_narcissu -steamgames_painkiller -steamgames_portal -steamgames_shadow_mordor -steamgames_shatter -steamgames_source_engine -steamgames_te120 -steamgames_tf2 -steamgames_trine2 -steamgames_unwritten_tales -steamgames_voidexpanse -steamgames_witcher2 VIDEO_CARDS="nouveau nvidia -fglrx -intel -radeon")
     Homepage:            http://steampowered.com
     Description:         Meta package for Steam games

[I] games-util/steam-launcher [1]
     Available versions:  ~1.0.0.52-r2^md ~1.0.0.53^md ~1.0.0.54^md ~1.0.0.54-r1^md **1.0.0.54-r2^md (~)1.0.0.54-r3^md {+steamruntime}
     Installed versions:  1.0.0.54-r3^md(05:26:32 PM 08/19/2017)(steamruntime)
     Homepage:            http://steampowered.com
     Description:         Installer, launcher and supplementary files for Valve's Steam client

[I] games-util/steam-meta [1]
     Available versions:  (~)0-r20160817 {+steamruntime}
     Installed versions:  0-r20160817(05:26:37 PM 08/19/2017)(steamruntime)
     Homepage:            https://steampowered.com
     Description:         Meta package for Valve's Steam environment

[1] "steam-overlay" /usr/local/portage/steam-overlay

Found 4 matches



Как-то так

sehellion ★★★★★ ()
Ответ на: комментарий от JacobTwoTwo

вот ошибка какая: The ebuild selected to satisfy «app-crypt/pinentry» has unmet requirements. - app-crypt/pinentry-0.9.7-r1::gentoo USE=«gnome-keyring gtk ncurses qt4 qt5 -caps -emacs -static» ABI_X86="(64)"

The following REQUIRED_USE flag constraints are unsatisfied: at-most-one-of ( qt4 qt5 )

The above constraints are a subset of the following complete expression: any-of ( ncurses gtk qt4 qt5 ) gtk? ( !static ) qt4? ( !static ) qt5? ( !static ) static? ( ncurses ) at-most-one-of ( qt4 qt5 ) Хотя флаги qt5 и qt4 стоят в /etc/portage/package.use/layman

playX ★★ ()
Ответ на: комментарий от playX

Показывый вывод целиком.

вот ошибка какая: The ebuild selected to satisfy «app-crypt/pinentry» has unmet requirements. - app-crypt/pinentry-0.9.7-r1::gentoo USE=«gnome-keyring gtk ncurses qt4 qt5 -caps -emacs -static» ABI_X86="(64)"

The following REQUIRED_USE flag constraints are unsatisfied: at-most-one-of ( qt4 qt5 )

The above constraints are a subset of the following complete expression: any-of ( ncurses gtk qt4 qt5 ) gtk? ( !static ) qt4? ( !static ) qt5? ( !static ) static? ( ncurses ) at-most-one-of ( qt4 qt5 ) Хотя флаги qt5 и qt4 стоят в /etc/portage/package.use/layman

Здесь написано, что должен быть включён один из флагов qt4 или qt5.

Так же, если включен флаг gtk, то именно для этого пакета должен быть выключен флаг static;
Если включен флаг qt4 или qt5, то так же должен быть выключен флаг static;
Если включен флаг static, то должен быть включен флаг ncurses.

В общем, включай и выключай флаги, пока не будут удовлетворены указанные зависимости.

Но судя по зависимостям, то флаг static и ncurses должен быть выключен.

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

вот флаги в /etc/portage/package.use/layman pp-portage/layman sync-plugin-portage static -gtk static ncurses git -qt5 qt4 и вот ошибка !!! The ebuild selected to satisfy «app-crypt/pinentry» has unmet requirements. - app-crypt/pinentry-0.9.7-r1::gentoo USE=«gnome-keyring gtk ncurses qt4 qt5 -caps -emacs -static» ABI_X86="(64)"

The following REQUIRED_USE flag constraints are unsatisfied: at-most-one-of ( qt4 qt5 )

The above constraints are a subset of the following complete expression: any-of ( ncurses gtk qt4 qt5 ) gtk? ( !static ) qt4? ( !static ) qt5? ( !static ) static? ( ncurses ) at-most-one-of ( qt4 qt5 )

(dependency required by «app-crypt/gnupg-2.1.20-r1::gentoo» [ebuild]) (dependency required by «dev-vcs/git-2.13.5::gentoo[gpg]» [ebuild]) (dependency required by «app-portage/layman-2.4.2::gentoo[git]» [ebuild]) (dependency required by «app-portage/layman» [argument])

playX ★★ ()
Ответ на: комментарий от playX

Т.е. что бы строка была

>=app-crypt/pinentry-0.9.7-r1 gnome-keyring -qt4
или
>=app-crypt/pinentry-0.9.7-r1 gnome-keyring -qt5

Выучи lorcode: www.linux.org.ru/help/lorcode.md

Для помещения блока кода исползуй [code]текст[/code] будет вот так:

текст

та же ошибка

Показывай текст ошибки, показывай что написал и где.

kostik87 ★★★★★ ()
Последнее исправление: kostik87 (всего исправлений: 1)
Ответ на: комментарий от playX

Мда, ты же вот здесь написал как оно есть:

/etc/portage/package.use/iputils:>=app-crypt/pinentry-0.9.7-r1 gnome-keyring

надо было всего-лишь сюда дописать :)

Если указываешь версию пакета, то надо в начали имению пакета писать =, >= или <=, думаю объяснять в чём отличия не надо.

>=app-crypt/pinentry-0.9.7-r1 gnome-keyring -qt5

Если версию не указываешь, то можно писать просто:

app-crypt/pinentry gnome-keyring -qt5

kostik87 ★★★★★ ()
Ответ на: комментарий от kostik87

дело в том то что я создал отдельный текстовый файл для layman, а в iputils его не было, да и мне удобнее создать отдельный файл с юз флагами для приложения:)

playX ★★ ()