LINUX.ORG.RU

Теоретически да, mingw.

vga ★★ ()

Практически - скачал, запустил mingw32-configure, получил -

configure: error: 
PostgreSQL configuration script pg_config not found.  Make sure this is in your

Ставить постгрес мне не хочется.

vga ★★ ()
Ответ на: комментарий от JackYF

Ну естественно, а ставить их мне совсем неинтересно, я ж не ТС, оно мне не надо. И сомневаюсь, что линуксовый -devel подойдет, то есть надо будет еще libpq собрать, а тот может еще чего захочет.

vga ★★ ()
Ответ на: комментарий от JackYF

configure: error: Did not find the PQexec() function in libpq. This is the litmus test for a working libpq installation.

A source file using the PQexec() function did compile without problems, and the libpq library is available for linking, but for some reason a call to PQexec() failed to link properly to the libpq library. This may be because the libpq library file is damaged, or in some incorrect format. or if your libpq is much more recent than libpqxx version 3.1, perhaps libpq has undergone a radical ABI change.

The last parts of config.log may give you a clue as to what really went wrong, but be warned that this is no easy reading. Look for the last error message occurring in the file.

Что бы это могло значить? postgresql 4.4 libpqxx 3.1

Berluskoni ★★ ()
Ответ на: комментарий от AnDoR

что интересно, если просто ./configure, то все ок, а если cross-configure или, что проще ./configure --host=i586-mingw32msvc, то та ошибка, которую я запостил выше.

Berluskoni ★★ ()
Ответ на: комментарий от AnDoR

я не уверен, но по ходу он просто компилит и сполняет примитив, с частями библиотеки и на этом затыкается((

Berluskoni ★★ ()
Ответ на: комментарий от Cy6erBr4in

пробовал. VS 2003(в мане ниписано, что это идеальное средство для нее), но 2003 не компилится, 2005 компилится, но не работает((

Berluskoni ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.