LINUX.ORG.RU

Не могу установить Qt4


0

0

Добрый день! Нужна помощь.

Хочу установить чтобы "пощупать" qt4, архив с исходниками взял из CD книги Макса Шлее про Qt4, все делаю как у него написано, переношу в папку, разархвивирую, применяю утилиту ./configure и затем собираю утилитами make; make install.

Но мне выдается целый воз ошибок например: ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:50:22: error: X11/Xlib.h: No such file or directory ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:55:23: error: X11/Xutil.h: No such file or directory ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:56:21: error: X11/Xos.h: No such file or directory ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:63:23: error: X11/Xatom.h: No such file or directory ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:248: error: ‘Colormap’ does not name a type ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:249: error: ISO C++ forbids declaration of ‘Visual’ with no type ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:249: error: expected ‘;’ before ‘*’ token ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:258: error: ‘Time’ does not name a type ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:259: error: ‘Window’ does not name a type ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:260: error: ‘Window’ does not name a type ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:283: error: ‘Window’ does not name a type ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:286: error: ‘Window’ has not been declared ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:287: error: ‘Window’ has not been declared ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:287: error: ‘Atom’ has not been declared ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:288: error: ‘Atom’ has not been declared ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:289: error: ‘Window’ has not been declared ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:289: error: ‘Atom’ has not been declared ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:300: error: expected ‘,’ or ‘...’ before ‘*’ token ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:300: error: ISO C++ forbids declaration of ‘XSelectionRequestEvent’ with no type ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:302: error: ‘Atom’ has not been declared ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:303: error: ‘Atom’ does not name a type ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:305: error: ‘Atom’ has not been declared ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:306: error: ‘Atom’ does not name a type ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:307: error: ‘Atom’ has not been declared ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:308: error: ‘Atom’ has not been declared ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:308: error: ‘Atom’ has not been declared ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:309: error: ‘Atom’ was not declared in this scope ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:309: error: template argument 1 is invalid ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:310: error: ‘Atom’ has not been declared ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:311: error: ‘Atom’ does not name a type ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:366: error: ISO C++ forbids declaration of ‘Atom’ with no type ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:366: error: expected ‘;’ before ‘*’ token ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:368: error: ISO C++ forbids declaration of ‘Window’ with no type ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:368: error: expected ‘;’ before ‘*’ token ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:370: error: ‘Window’ does not name a type ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:376: error: ‘Time’ does not name a type ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:377: error: ‘Time’ does not name a type ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:403: error: ISO C++ forbids declaration of ‘Visual’ with no type ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:403: error: expected ‘;’ before ‘*’ token ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:404: error: ‘Colormap’ does not name a type ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:568: error: ‘Atom’ does not name a type ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:570: error: ‘Atom’ has not been declared ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:580: error: ‘FocusOut’ was not declared in this scope ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:581: error: ‘FocusIn’ was not declared in this scope ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:582: error: ‘KeyPress’ was not declared in this scope ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:583: error: ‘KeyRelease’ was not declared in this scope ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:584: error: ‘None’ was not declared in this scope ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:585: error: ‘RevertToParent’ was not declared in this scope ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:586: error: ‘GrayScale’ was not declared in this scope ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:587: error: ‘CursorShape’ was not declared in this scope ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:602: error: ‘XPoint’ was not declared in this scope ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:602: error: template argument 1 is invalid ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:603: error: ‘XRectangle’ was not declared in this scope ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:603: error: template argument 1 is invalid ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:604: error: ‘XChar2b’ was not declared in this scope ../../include/QtGui/private/../../../src/gui/kernel/qt_x11_p.h:604: error: template argument 1 is invalid make[1]: *** [.obj/release-shared/qapplication.o] Ошибка 1 make[1]: Leaving directory `/home/alex/PROGS/tmp/qt-x11-opensource-src-4.3.0/src/gui' make: *** [sub-gui-install_subtargets-ordered] Ошибка 2

Честно сказать я не знаю что делать, я начинающий линуксоид и с qt никогда не работал.

Система Debian 4 gcc версии 4.1

Что делать?

Re: Не могу установить Qt4

всегда читай readme, ну и gcc тебе явно говорит - error: X11/Xlib.h: No such file or directory, значит, что надо сделать....

lester ★★★★ ()

Re: Не могу установить Qt4

Проблема решается очень просто: нужно взять Qt4 из репозитория дистрибутива. Если его там нет, то обновить дистрибутив и взять Qt4 из репозитория дистрибутива.

Rikz ★★★ ()
Ответ на: Re: Не могу установить Qt4 от Rikz

Re: Не могу установить Qt4

>нужно взять Qt4 из репозитория дистрибутива. Если его там нет, то обновить дистрибутив и взять Qt4 из репозитория дистрибутива.
Нужно взять дистрибутив, где в репозиториях есть Qt4 ...

aydar ★★★★★ ()
Ответ на: Re: Не могу установить Qt4 от lester

Re: Не могу установить Qt4

>значит, что надо сделать....

А что хоть предположительно сделать-то нужно? у меня никаких идей честно сказать. А в README и INSTALL все в точности описано как я делал. То есть все как там описано.

Ну и из репозитория мог бы взять Qt4, но мне впринципе интересно почему не получается, хотябы в целях самообразования на будущее.

profbrown ()

Re: Не могу установить Qt4

Никогда не понимал, нахрена постить лог ошибок компилятора C++

От него абсолютно никакой пользы - свою ошибку, если она вообще в этом отблеве есть, ты там просто не найдешь.

Или это такой тонкий юмор?

anonymous ()
Ответ на: Re: Не могу установить Qt4 от profbrown

Re: Не могу установить Qt4

Если бы у тебя была слака я бы с определённой уверенностью сказал бы что ты забыл поставить Иксы. Поелику у тебя дебиан могу лишь смутно догадываться, что ты не поставил пакет libX11-dev или что-то в этом роде. Он же тебе ясно даёт понять: хедеров иксов не обнаружено.

KblCb ★★★★★ ()
Ответ на: Re: Не могу установить Qt4 от profbrown

Re: Не могу установить Qt4

> у меня никаких идей честно сказать.

Ну тебе же выше намекнули про отсутствующие заголовочные файлы X11. Ставь пакет xlibs-dev.

kondor ★★★ ()

Re: Не могу установить Qt4

>Система Debian 4 gcc версии 4.1

Ставь аптом и не трахай мозг

teferiincub ()

Re: Не могу установить Qt4

# aptitude install build-essential xorg-dev ~nlibqt4

alex_custov ★★★★★ ()
Ответ на: Re: Не могу установить Qt4 от profbrown

Re: Не могу установить Qt4

>>Ну и из репозитория мог бы взять Qt4, но мне впринципе интересно почему не получается, хотябы в целях самообразования на будущее

пишется, что нету файла X11/Xlib.h. Значит надо поставить -dev пакет с ним. Если apt-file не настроен, идём на packages.debian.org и ищем по содержимому пакетов, находим что это пакет libx11-dev.

Для всех Х-овых хедеров есть метапакет xorg-dev: http://packages.debian.org/lenny/xorg-dev

alex_custov ★★★★★ ()
Ответ на: Re: Не могу установить Qt4 от alex_custov

Re: Не могу установить Qt4

Спасибо друзья. Все поставил apt-ом недостающую либу, вроде скомпилилась Qt. Установил пути в /etc/profile.

Но все равно есть проблема не могу запустить приложения-примеры с диска пишет что то вроде - "пока не загружена часть библиотеки libQtGui.so.4. и т. д. то есть не запускает собранные бинарники.

Также не скомпилить не одного своего файла а-ля Hello World везде пишет, что не обнаруживет никаких Qt-шных классов: ‘QApplication’, ‘QLabel’ и т. д. Кстати правильно ли я компилю свои "поделки"? g++ -o hello hello.cpp

profbrown ()
Ответ на: Re: Не могу установить Qt4 от profbrown

Re: Не могу установить Qt4

Если твой hello.cpp написан на чистом cpp то может быть. Если он написан на qt - то быть не может. Как правильно - честно не помню, погугли.

P.S:Возможно местная публика сочтёт меня наивным, но это случайно не тонкий троллинг?

KblCb ★★★★★ ()
Ответ на: Re: Не могу установить Qt4 от profbrown

Re: Не могу установить Qt4

>Кстати правильно ли я компилю свои "поделки"? g++ -o hello hello.cpp

нет

qmake -project && qmake && make.

Ты книжку которую по qt купил вообще открывал?

teferiincub ()
Ответ на: Re: Не могу установить Qt4 от KblCb

Re: Не могу установить Qt4

Спасибо вроде теперь все проблемы решил. Прошу прощения если немного "достал", просто хотелось во всем разобраться до мельчайших подробностей и все-таки довести до ума поставленную цель. Просто никогда раньше здоровые проги не компилил еще из исходников. :)

>P.S:Возможно местная публика сочтёт меня наивным, но это случайно не тонкий троллинг?

Нет можете не беспокоиться - это не троллинг. :) Это еще хуже. Это поколение выросшее на "вантузах". -:D

profbrown ()
Ответ на: Re: Не могу установить Qt4 от teferiincub

Re: Не могу установить Qt4

>>> P.S:Возможно местная публика сочтёт меня наивным, но это случайно не тонкий троллинг?

>> Нет можете не беспокоиться - это не троллинг. :) Это еще хуже. Это поколение выросшее на "вантузах". -:D

> Тут такого не боятся. Тут боятся поколения выросшего на Убунту.

:D

/beagest/ Как бы намекает.

anonymous ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.