LINUX.ORG.RU

gi.require_version выдает ошибку о ненайденом атрибуте (python2, arch)

 , , ,


1

3

Запускаю данную тулзу - https://github.com/and3rson/vkplayer:

(vk_env) [foozzi@soul vkplayer]$ python2 app.py
Traceback (most recent call last):
  File "app.py", line 3, in <module>
    gi.require_version('Gtk', '3.0')
AttributeError: 'module' object has no attribute 'require_version'
На борту стоит gnome3, arch linux, python2.
Все завимисомсти для работы питона с gtk стоят, такие например как python2-gobject2.
Почему данная проблема есть и как ее устранить?

★★

python2-gobject2

Это разве не про второй gtk? Поставь python2-gobject.

Weres ★★★ ()
Ответ на: комментарий от greenman

если внимательно посмотреть кол, то mail.py подключает app.py, естественно я это тоже пробовал

foozzi ★★ ()
Ответ на: комментарий от foozzi

Если бы стоял - проблемы не было. Попробуйте переставить или поставить через pip2.

Weres ★★★ ()
Ответ на: комментарий от Weres

говорю же, стоит, проверил нахождение пакета в арче. Переставлял пакет несколько раз

foozzi ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.