LINUX.ORG.RU

Чего не хватает питону?

 ,


0

1
$ meld
Traceback (most recent call last):
  File "/usr/bin/meld", line 339, in <module>
    check_requirements()
  File "/usr/bin/meld", line 191, in check_requirements
    gi.require_version("Gtk", "3.0")
AttributeError: module 'gi' has no attribute 'require_version'

dev-python/pygobject-3.24.1
dev-python/pygtk-2.24.0-r4
установлены

eselect python list

Available Python interpreters, in order of preference:
  [1]   python3.5
  [2]   python3.4
  [3]   python2.7

Ответ на: комментарий от Virtuos86

Он просит 3-ю, у меня 3-я. Я в этом вашем питоне ничего не понимаю. Что делать - неясно.

и других версий у меня для вас нет:

$ find /usr/portage/dev-python/pygobject -iname "*.ebuild"
/usr/portage/dev-python/pygobject/pygobject-2.28.6-r55.ebuild
/usr/portage/dev-python/pygobject/pygobject-3.22.0.ebuild
/usr/portage/dev-python/pygobject/pygobject-3.24.1.ebuild
Einstok_Fair ★★☆ ()
Последнее исправление: Einstok_Fair (всего исправлений: 1)
Ответ на: комментарий от Einstok_Fair

Какие-то гентоприколы. Там что нет зависимостей? Если meld через pip поставить? Для какой версии питона стоит gi? Какой версией питона ты запускаешь meld?

pawnhearts ★★★★★ ()

Пхытону не хватает разработчиков, не сидящих на крепкой дури!

Наркоманский же псевдоЯП. Как им вообще пользоваться можно?

anonymous ()

Добавь строчки

PYTHON_TARGETS=«python2_7 python3_4 python3_5» PYTHON_SINGLE_TARGET=«python3_5

в свой make.conf и пересобери dev-python/pygobject и dev-python/pygtk А еще лучше - мир.

k0valenk0_igor ★★★ ()
Ответ на: комментарий от Einstok_Fair

На самом деле это не должно быть слишком долго, поскольку обновляться будут по преимуществу питоновые пакеты

k0valenk0_igor ★★★ ()
Ответ на: комментарий от k0valenk0_igor

Зачем вообще пересобирать, достаточно запустить meld тем питоном, для которого у него уже стоит gi. Странно что вообще оно поставилось для разных.

pawnhearts ★★★★★ ()
Ответ на: комментарий от pawnhearts

так не получается:

python2.7 /usr/bin/meld
Traceback (most recent call last):
  File "/usr/bin/meld", line 71, in <module>
    import meld.conf
ImportError: No module named meld.conf

ни для 2.7, ни для3.4

Einstok_Fair ★★☆ ()
Ответ на: комментарий от pawnhearts

Эти две строчки буквально говорят следующее: «для пакетов, которые могут работать с несколькими версиями питона, собери для версий 2.7, 3.4 и 3.5, а для тех, кто только с одной - 2.7»

Проблема человека, ИМХО, в том что часть пакетов была собрана не с теми версиями. Какие именно - сказать затруднительно. Проще пересобрать, с новыми настройками, все пакеты зависящие от питона

k0valenk0_igor ★★★ ()
Последнее исправление: k0valenk0_igor (всего исправлений: 3)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.