LINUX.ORG.RU

проблемы сборки Cutelyst

 , , , ,


0

1

Пытался собрать по инструкции сей фреймворк , но столкнулся с такой проблемой - версия в CMAKE-файлах Qt 5.5.1 , но требуется >=«5.6». Править конфиг в ручную или же есть какие-то способы апнуть версию автоматикой? Заранее - благодарю!

CMake Error at tests/CMakeLists.txt:3 (find_package): Could not find a configuration file for package «Qt5Test» that is

compatible with requested version «5.6.0».

The following configuration files were considered but not accepted:

/usr/lib/x86_64-linux-gnu/cmake/Qt5Test/Qt5TestConfig.cmake, version: 5.5.1

-- Configuring incomplete, errors occurred!

Обычно, когда требуется выше какой-то версии, это не просто так, а когда используются какие-то фичи, которых не было в старой. Так что ставь свежие культи.

peregrine ★★★★★ ()
Ответ на: комментарий от mister_LOB

sdk 5.6 у тебя, скорей всего, где-то в ~\ или куда там куда её qtcreator скачал, а 5.5.1 в системе установлена. Поэтому cmake и использует системную версию.

cool_hedin ()
Ответ на: комментарий от mister_LOB

Задай путь к подходящей версии Qt, передав cmake аргумент -DCMAKE_PREFIX_PATH=/твой/путь

annulen ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.