LINUX.ORG.RU

Сборка Kate поверх KF5

 , ,


0

1

Пітаюсь проделать сабж, но не могу найти все пакеты, для удовлетворения зависимостей CMake. Ошибка сейчас такая:

CMake Error at /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:108 (message):
  Could NOT find KF5 (missing: DocTools Init) (found suitable version
  «5.7.0», minimum required is «5.6.0»)
Call Stack (most recent call first):
  /usr/share/cmake-2.8/Modules/FindPackageHandleStandardArgs.cmake:315 (_FPHSA_FAILURE_MESSAGE)
  /usr/share/ECM/find-modules/FindKF5.cmake:113 (find_package_handle_standard_args)
  CMakeLists.txt:41 (find_package)

Соответственно не хватает пакетов *-dev для DocTools и Init, но я их не могу найти в репозиториях по шаблону libkf5*-dev. Подскажите, пожалуйста, что доустановить?

Сори, кажется решил. Поставил kdoctools-dev и kinit-dev. Но тут нарисовались другие проблемы. Много раз выдало на stderr:

Using CMake 2.8 way to call desktoptojson
Походу пора обновить cmake..

KennyMinigun ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.