LINUX.ORG.RU

Intel Quick Sync Video - кто-нибудь пытался юзать в своих программах?

 , , , ,


0

2

Судя по этой пдфке от штеуда всё плохо,

http://www.intel.com/content/dam/www/public/us/en/documents/white-papers/quic...

чтобы завести кодеки ффмпега, умеющие в сабж, нужно патчить ядро проприетарными интеловскими башескриптами, а изкоробочный драйвер i915 ванильного ядра сабж не умеет. Действительно всё так плохо? Для перекодирования видео на своём домашнем локалхосте ещё можно заморочиться, но для распространения софта с поддержкой данной фичи это не очень подходит

★★★★★

Когда я пытался с этим разобраться (довольно давно), ситуация была такая же. Думал, они уже в апстрим добавились, а вот оно как...

PtiCa ★★★★★ ()

Не заметил в PDF'ке ничего про патчинг ядра. Там предлагают VA-API драйвер другой подцеплять вместо i965. Это userspace драйвера, не ядро.

i-rinat ★★★★★ ()
Ответ на: комментарий от i-rinat

1. To unpack and install the user mode components, run this script as root: install_ sdk_UMD_CentOS.sh 2. Apply patches to the i915 driver as well as to the rest of the kernel. Rebuild and package as RPMs with build_kernel_rpm_CentOS.sh. Note: this step is run as a regular user, not as root.

Harald ★★★★★ ()
Ответ на: комментарий от i-rinat

ну и дальше предлагается с новым ядром перезагрузиться

Harald ★★★★★ ()

Кстати, чем открытый VA-API драйвер не подошёл? Он тоже может кодировать, а через GStreamer есть приличный интерфейс.

i-rinat ★★★★★ ()

Я пробовал. Всё отлично. Единственное, в ffmpeg не было кодеков, когда я это делал, пришлось самому запиливать. Мб сейчас что-то изменилось, я не в курсе.

hateyoufeel ★★★★★ ()
Ответ на: комментарий от hateyoufeel

в ffmpeg не было кодеков, когда я это делал, пришлось самому запиливать.

чтоб эти кодеки работали, предполагается патчинг ядра, о чём и тред

Harald ★★★★★ ()
Ответ на: комментарий от Harald

чтоб эти кодеки работали, предполагается патчинг ядра, о чём и тред

Нет, не предполагается. QS работает на ванильных ядрах (у нас - ядра из RHEL). Intel распространяет какой-то свой i915, но по факту всё работает и без него, если текущее ядро поддерживает твой чип.

hateyoufeel ★★★★★ ()
Последнее исправление: hateyoufeel (всего исправлений: 2)

нужно патчить ядро проприетарными интеловскими башескриптами

патчи лежат в том же архиве, не может быть проприетарным обычный башскрипт, наркоман проклятый!

Действительно всё так плохо?

продавай\сдавай в аренду в составе аппаратного комплекса

но для распространения софта с поддержкой данной фичи это не очень подходит

поцоны из ffmpeg и не знают, надо им написать срочно

представляю как у тебя бомбанет, когда узнаешь, что mediasdk 2015r6 поддерживает haswell но не поддерживает skylake, а mediasdk 2017 уже не держит haswell, зато поддерживает skylake

у intel есть форум, там нужно ныть разрабам в уши

hizel ★★★★★ ()
Ответ на: комментарий от hateyoufeel

надо потестить, обнаружил, что упоминаемые

# ls /dev/dri/
card0  controlD64  renderD128

у меня таки есть

Harald ★★★★★ ()
Ответ на: комментарий от hizel

патчи лежат в том же архиве, не может быть проприетарным обычный башскрипт, наркоман проклятый!

я про лицензию

поцоны из ffmpeg и не знают, надо им написать срочно

так они только сорсы кодеков распространяют, а скомпиленный бинарник уже несвободным будет, насколько я понял

Harald ★★★★★ ()
Ответ на: комментарий от Harald

QuickSync теребишь через GPL библиотеки libva/libdrm/mfx_dispatch в каком месте бинарник вдруг станет несвободным?

hizel ★★★★★ ()
Ответ на: комментарий от hizel

у меня уже бомбит от того, что для скачивания регистрация требуется

Harald ★★★★★ ()
Ответ на: комментарий от hizel

а почему в пдфке для компиляния ффмпега с *_qsv кодеками пишут --enable-nonfree указать?

Harald ★★★★★ ()
Ответ на: комментарий от Novell-ch

Так и ffpmeg\libav тоже умеют в ва-апи

Я как-то пропустил этот момент. Думал, что только декодировать умеют.

i-rinat ★★★★★ ()
Ответ на: комментарий от Harald

это фигня. Пока интеловцы из Нижнего Новгорода и Крылатского всё ещё пытались собирать дебиановские пакеты, у них имена пакетов были несостыкованы.

max_lapshin ★★ ()
Ответ на: комментарий от superuser
provides instructions for installing on the Gold OS:

    Intel® Media Server Studio 2016: CentOS* 7.1.1503 
    Intel® Media Server Studio 2017: CentOS* 7.2.1511

на дворе 7.3, то есть нужно ставить старую centos и сносить rpm/yum/dnf из системы

2017 выкинули поддержку haswell, в 2016 skylake не завезли

зато недавно Media SDK пооткрывали https://software.intel.com/en-us/blogs/2017/03/31/media-sdk-open-source-launch , но открыли не все, что не открыли искать в faq/readme

ну и да этот разрыв шаблона, когда на ark.intel про процессор написано quicksync, но в линуксе он работать не будет, Media SDK for linux свой список поддерживаемого

hizel ★★★★★ ()
Последнее исправление: hizel (всего исправлений: 1)
Ответ на: комментарий от Harald

Саботаж на фоне швабодкофилии направленный на пользователей а не на компании потому что. От террористом подрывающих мирняк не отличаются.

anonymous ()

Когда я последний раз пробовал эту технологию, оно не умело mpeg2 (на выходе был шедевр Малевича) и заметно хуже кодировало h264 - в выходном потоке было множество визуальных артефактов.

lizard ★★ ()
Ответ на: комментарий от hizel

Думаю, что тех инструкций хватит чтобы собрать под любой дистрибутив linux.

2017 выкинули поддержку haswell, в 2016 skylake не завезли

откуда такая информация?

superuser ★★ ()
Ответ на: комментарий от superuser

хватит чтобы собрать под любой дистрибутив linux

найдется герой который пропатчит перепатченное ядро 4.4 любого дистрибутива и справится с dependency hell из-за патченых libva, libdrm, i915

откуда такая информация?

release notes

hizel ★★★★★ ()
Ответ на: комментарий от hizel

Пропатчил ванильную версию 4.4.64 - всего 3 ошибки. Думаю заняться.

superuser ★★ ()
Ответ на: комментарий от hizel

Похоже там всё просто: патчи эти все только для i915, libva нужно собрать именно от intel (он у них свой) и libdrm пересобрать той версии, который находится в Intel Media Server Studio.
Вот только исходники iHD_drv_video.so не дают похоже. А так вроде всё гуд.
Ну и немного мозгов надо иметь, чтобы не запускать ихний установщик, а опакетить для своего дистрибутива только нужное. А то они там rf & cp применяют :)

superuser ★★ ()
Последнее исправление: superuser (всего исправлений: 2)
Ответ на: комментарий от superuser

Итак... Собрал для бубунты deb-пакеты libva и libdrm из Intel Media Server Studio. Собрал ffmpeg с опциями --enable-libmfx --enable-nonfree. Поправил патчи к ядру 4.4.66, и заметил, что в патчах для ядра упоминается максимум Skylake (HD 5xx)...
Стоит ли продолжать? Достаточно ли будет добавить идентификаторы HD 6xx Kabylake в /include/drm/i915_pciids.h и фирмвари соответствующие? Большие ли отличия HD 6xx от HD 5xx ? Кто что думает?
Плюс ко всему вот это - https://software.intel.com/en-us/forums/intel-media-sdk/topic/721038
Но там проблемы у людей могут быть из-за того, что, идентификаторы не прописаны.

superuser ★★ ()
Последнее исправление: superuser (всего исправлений: 2)
Ответ на: комментарий от superuser

Я правильно понимаю, через неделю ты что-то собрал и внезапно оказалось у тебя, таки, не skylake\brodwell?

Пишет Liu, Yan разраб:

I have confirmed the MSS 2017R3 will not support Kabylake. The reason is the Media Server Studio is a server product, it is not necessary to support the Kabelake—a desktop processor.

Открытие intel-ом исходников символизирует закапывание Intel Media Server Studio для linux. В intel-vaapi-driver завезли и kaby lake и hevc там подпиливают, можешь у них на гитхабе оценить, что нужно для поддержки KBL.

hizel ★★★★★ ()
Ответ на: комментарий от hizel

Да у меня kabylake. После покупки обнаружил, что не кодирует с хардварным ускорением.

В intel-vaapi-driver ...

а зачем тогда нужен MSS если всё уже есть в intel-vaapi-driver?

superuser ★★ ()
Ответ на: комментарий от superuser

ты сначала в vaapi потыкай, а потом решай кого закапывать. оцени разницу ffmpeg -hide_banner -h encoder=h264_vaapi и encoder=h264_qsv

по большей части, аппаратное кодирование нужно для всякого онлайн-телевидения низкого качества, кодировать коллекцию fhd порно только libx264, кому нужны vhs квадратные артефакты на сиськах, да и куда торопится

hizel ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.