LINUX.ORG.RU

Xfce и .Xresources


0

1

Xfce игнорирует файл .Xresources, даже если в автозагрузку поместить «xrdb -merge /home/`whoami`/.Xresources».
после ручного выполнения этой команды всё ок.
можрно как-нибудь пофиксить?

★★★★★

Скорее он его не игнорирует, а сам лезет к xrdb и перезаписывает свои настройки поверх настроек из Xresources. Посмотри конфиг xsettings, может быть можно его заставить не трогать xrdb. Ну или как вариант сделать sleep, чтобы пропустить обращение xfce к xrdb, и потом уже применить свои настройки.

PoMbl4 ()

Может, надо sh -c 'xrdb -merge /home/`whoami`/.Xresources'

Zubok ★★★★★ ()

И еще, а зачем тебе так делать? У тебя на аватаре Debian изображен. В Debian это автоматом делается. Пакет x11-common, файл /etc/X11/Xsession.d/30x11-common_xresources. Сама переменная из этого скрипта USRRESOURCES определяется в /etc/X11/Xsession. Да! И в файле /etc/X11/Xsession.options должна быть строчка allow-user-resources. Вообще-то, она там по умолчанию должна быть.

Твоя задача только ~/.Xresources создать. Зачем его подгружать с сессией самостоятельно?

Zubok ★★★★★ ()
Ответ на: комментарий от snoopcat

Полагаю, что он тупо у тебя не запускает Xsession. Поэтому и ресурсы не читает.А ты как-нибудь конфигурировал GDM? Вот тут что-то говорится о каком-то ключе X-GDM-BypassXsession, который может запретить вызов Xsession. Нет у меня GDM, поэтому не знаю, где он вообще указывается? Проверить бы его

https://help.gnome.org/admin/gdm/stable/configuration.html.en#sessionconfig

Zubok ★★★★★ ()
Ответ на: комментарий от snoopcat

Стер предыдущее. Я не туда посомтрел. Я посомтрел в Ubuntu! Вот тут: http://ubuntuforums.org/showthread.php?t=1785485

Глянул. Вроде бы должен запускать. Это из твоего снипета с pastebin.com для Xsession из /etc/gdm/Xsession

Устанавливает переменные

USRRESOURCES=$HOME/.Xresources
SYSSESSIONDIR=/etc/X11/Xsession.d

И запускает все файлы из /etc/X11/Xsession.d

#
# use run-parts to source every file in the session directory; we source
#
# instead of executing so that the variables and functions defined above
#
# are available to the scripts, and so that they can pass variables to each
#
# other
#
SESSIONFILES=$(run_parts $SYSSESSIONDIR)
if [ -n "$SESSIONFILES" ]; then
  for SESSIONFILE in $SESSIONFILES; do
    . $SESSIONFILE
  done
fi

А там у нас есть файл, который вызывает xrdb. То есть должно работать. Хм. Может, твой gdm забывает свой /etc/gdm/Xsession запустить?

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 1)
Ответ на: комментарий от snoopcat

да, проверил, всё на месте

И еще раз переспрошу. А в Xsession.options строчка allow-user-resources на месте? Без нее скрипт не грузит ресурсы пользователя.

И еще проверь наличие /etc/X11/Xsession.d/20x11-common_process-args и в ней процедуры has_option(), которая этот файл Xsession.options читает и проверяет наличие опции.

Zubok ★★★★★ ()
Ответ на: комментарий от snoopcat

Все на месте. Чудеса. А расскажи, как ты проверяешь, применились ресурсы или нет? На какой программе? И еще: в написании ~/.Xresources не ошибся? (большие, маленькие буквы).

Zubok ★★★★★ ()
Ответ на: комментарий от Zubok
annelin@somewhere ~ $ ls .Xresources 
.Xresources
annelin@somewhere ~ $ cat .Xresources 
Xcursor.size:	0
Xcursor.theme:	oxy-oxygen
Xcursor.theme_core:	1
Xft.antialias:	1
Xft.autohint:	0
Xft.dpi:	134
Xft.hinting:	1
Xft.hintstyle:	hintslight
Xft.lcdfilter:	lcddefault
Xft.rgba:	rgb

проверяю:

annelin@somewhere ~ $ xrdb -query | grep dpi
Xft.dpi:	96
snoopcat ★★★★★ ()
Ответ на: комментарий от snoopcat

И еще проверь вот что. Создай нового пользователя, перемести туда ~/.Xresources и попробуй залогиниться. Проверь, ресурсы приложились?

Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

А вот я читаю, что есть еще каталог /etc/gdm/Sessions. А там что?

нету такого:

annelin@somewhere /etc/gdm $ ls 
Init     PostLogin    PreSession  locale.conf     Xsession
modules  PostSession  gdm.conf    XKeepsCrashing

snoopcat ★★★★★ ()
Ответ на: комментарий от snoopcat

проверяю:

annelin@somewhere ~ $ xrdb -query | grep dpi

Xft.dpi: 96

Слушай, а ты только по dpi проверяешь и больше никак? Дело в том, что какая-то компонента десктопа может опять переиначить dpi на свой лад и тему курсоров может изменить. Надо проверить на чем-нибудь еще. Что-то у меня есть подозрение, что ресурсы у тебя читаются. Попробуй xterm поменять шрифт или цвета. Или какой там у тебя терминал? Вот это добавь в ~/.Xresources и перезайди через GDM. Цвета букв поменяются у терминала?


*VT100.color1:  red3
*VT100.color2:  green3
*VT100.color3:  yellow3
*VT100.color4: blue3
*VT100.color5: magenta3
*VT100.color6: cyan3
*VT100.color7: gray90
*VT100.color8: gray30
*VT100.color9: IndianRed1
*VT100.color10: LimeGreen
*VT100.color11: gold
*VT100.color12: LightSkyBlue
*VT100.color13: plum
*VT100.color14: Turquoise2
*VT100.color15: white
Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 1)
Ответ на: комментарий от snoopcat

у мне кроме dpi ничего и не надо задавать, смысл проверять -то?:)

в xfce4-settings dpi выставлен в 134, кстати

Смысл в том, чтобы не искать причину, почему не работает там, где ее нет. Вот ты пишешь, что ресурсы не грузятся. Мы пока и смотрели, грузятся ли они. Все вроде у тебя на месте. Должны грузиться! Вот я и прошу окончательно проверить это. Если они действительно грузятся, то причина не в ресурсах, а в другом месте.

134 в xfce4-settings? Это сразу после загрузки без ручного применения? Значит, ресурсы 100% читаются. И мы зря все это проверяли.

Zubok ★★★★★ ()
Ответ на: комментарий от Zubok

134 в xfce4-settings? Это сразу после загрузки без ручного применения? Значит, ресурсы 100% читаются. И мы зря все это проверяли.

там ручками это выставлено было:)
з.ы. проверил с цветами терминала - всё равно не загрузились. если выбрать xterm вместо xfce сессии - всё грузится
такое ощущение, что их кто-то переписывает

snoopcat ★★★★★ ()
Ответ на: комментарий от snoopcat

А вот такое нашел: запиши свои ресурсы в файл ~/.config/xfce4/Xft.xrdb.

Zubok ★★★★★ ()
Ответ на: комментарий от snoopcat

У тебя xfce4-settings может все перезаписывать. А где он хранит настройки? В gconf? Смотри, какой патчик был: http://mail.xfce.org/pipermail/xfce4-commits/2011-January/015554.html

Вот он, скорее всего, и твой курсор перезаписывает, и Xft. Если это так, то надо копать, где он хранит свои настройки.

А вот и сам баг https://bugzilla.xfce.org/show_bug.cgi?id=7014

Zubok ★★★★★ ()
Последнее исправление: Zubok (всего исправлений: 1)
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.