LINUX.ORG.RU

tuxonice на gentoo

 , ,


0

1

Поставил pf-sources. не работает спящий режим.

dmesg | grep TuxOnIce
[    5.409760] TuxOnIce 3.3 (http://tuxonice.net)
[    5.464638] TuxOnIce: No image found.
hibernate ругается на SMP, но в ядре все выставлял по wiki. думал, может дело в initrd, но оказалось не в нем. А в чем тогда?

[    5.464638] TuxOnIce: No image found.

Это когда выдаёт? При нормальной загрузке такое сообщение нормально. Ты гибернейтить-то пробовал?

post-factum ★★★★★ ()
Ответ на: комментарий от post-factum

Это выдает, если просто сделать dmesg. Если сделать hibernate, то вылазит Oops.

reddaemon ()
Ответ на: комментарий от reddaemon

http://pastebin.com/GecRhQfA вот такого плана вылазит, только содержимое другое, и сверху написано Try prepare image 1. Кнопки Esc и R работают, но ничего не делают, в остальном все висит.

reddaemon ()
Ответ на: комментарий от post-factum

отсюда: http://www.linuxforu.com/2011/01/understanding-a-kernel-oops/

кстати, если сделать s2disk, то система сначала сохраняет снапшот, потом отключается, и после включения TuxOnIce выдает:

[5.125190] TuxOnIce 3.3 (http://tuxonice.net)
[    6.515051] TuxOnIce: Unable to find a signature. Could you have moved a swap file?
[    6.515057] TuxOnIce: Block I/O: No signature found at /dev/sda6.

если сделать s2ram, система засыпает, но при просыпании - черный экран.

reddaemon ()
Ответ на: комментарий от reddaemon

Настраивать ice не пробовал? Иногда там нужно донастраивать особо упоротые модули для их автоматической выгрузки/загрузки и поочее…

И если что то да блоб nvidia, gentoo и ice на 3.8.3 и УМВР!

init_6 ★★★★★ ()
Ответ на: комментарий от init_6

а у меня radeon свободный и на 3.8.3, и на 3.8.1 одинаково не работает, а где их настраивать там в ice эти модули?

reddaemon ()
Ответ на: комментарий от reddaemon

а где их настраивать там в ice эти модули

Довольно подробно и с великолепными комментариями в /etc/hibernate/* и готовых рабочих примеров тоже масса в сети.

init_6 ★★★★★ ()
Ответ на: комментарий от post-factum

Если с ванильным, без tuxonice, то тоже не работает. Почему и решил пробовать ice.

reddaemon ()

попробуй с флешки с убунтой загрузиться и s2ram

Mr_Gentoo ()

а что за комп у тебя? проц, материнка. может железячная проблема. ты гуглил, есть еще у кого-то проблемы с гибернейтом с таким железом?

Mr_Gentoo ()
Ответ на: комментарий от Mr_Gentoo

ноут hp pavillion dv6-3107er, amd phenom II N930, видео amd 4250/5650.находил похожие проблемы, но решения так и не нашел пока. может дело в новых ядрах?

reddaemon ()
Ответ на: комментарий от reddaemon

может дело в новых ядрах?

кстати, да. я забыл, у меня на >3.6.4 s2ram не работал (гибернейтом не пользуюсь), поэтому я пока на этом 3.6.4 и остался

Mr_Gentoo ()
Ответ на: комментарий от reddaemon

попробовал 3.4.36 - не работает

ну хз, тогда вся надежда твоя на интуицию и гуголь

Mr_Gentoo ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.