LINUX.ORG.RU

Gnome3 + layout indicator == KDE?

 , ,


0

1

Очень долгое время в KDE существовал баг с индикатором раскладки клавиатуры. Теперь у гномоводов, видать похожая ситуация. Вот ссылка на баг: https://bugs.launchpad.net/ubuntu/ source/gnome-shell/ bug/1045914/

Ubuntu 12.10 + gnome-shell. Индикатора нет. Смотрю на расскладку по зажигающейся лампочке капса (не очень удобно). Хотя, может у кого-то оно таки работает и мне подскажут фикс?

УМВР ибо не Ubuntu а Arch

Не могу ничего посоветовать пока, но проблема либо убунтоспецифичная либо нужно ровнять руки. Чем-то добавлял раскладки?

rictb ()
Ответ на: комментарий от GreenBag

показывай:
xprop -root | grep XKB
gsettings get org.gnome.settings-daemon.plugins.keyboard active
gsettings get org.gnome.settings-daemon.peripherals.keyboard input-sources-switcher
gsettings get org.gnome.desktop.input-sources sources
gsettings get org.gnome.desktop.input-sources xkb-options
gsettings get org.gnome.libgnomekbd.keyboard model
gsettings get org.gnome.libgnomekbd.keyboard layouts
gsettings get org.gnome.libgnomekbd.keyboard options

bass ★★★★★ ()

Это бага в Ubuntu, в ней ibus ниже необходимой версии, поэтому и не отображается.

Dukat863 ()
Ответ на: комментарий от bass

показывай:

_XKB_RULES_NAMES_BACKUP(STRING) = "evdev", "pc105", "us", "", ""
_XKB_RULES_NAMES(STRING) = "evdev", "pc105", "us,ru", ",", "grp_led:caps,grp:caps_toggle"

➜  ~  gsettings get org.gnome.settings-daemon.plugins.keyboard active
true
➜  ~  gsettings get org.gnome.settings-daemon.peripherals.keyboard input-sources-switcher
No such key 'input-sources-switcher'
➜  ~  gsettings get org.gnome.desktop.input-sources sources
@a(ss) []
➜  ~  gsettings get org.gnome.desktop.input-sources xkb-options
@as []
➜  ~  gsettings get org.gnome.libgnomekbd.keyboard model
''
➜  ~  gsettings get org.gnome.libgnomekbd.keyboard layouts
['us', 'ru']
➜  ~  gsettings get org.gnome.libgnomekbd.keyboard options
['grp_led\tgrp_led:caps', 'grp\tgrp:caps_toggle']

GreenBag ★★ ()
Ответ на: показывай: от GreenBag

Похоже, что штатный гуй-конфигуратор настраивает переключение апплетом, который как раз смотрит в org.gnome.libgnomekbd.keyboard
apt-get install gkbd-capplet

Самому переключателю раскладок gnome-shell нужно org.gnome.desktop.input-sources, например:
gsettings set org.gnome.desktop.input-sources sources «[('xkb', 'us'), ('xkb', 'ru')]»,
gsettings set org.gnome.desktop.input-sources xkb-options «['grp:caps_toggle', grp_led:caps']»

bass ★★★★★ ()

В Gnome-shell решил проблему, только одним образом gxneur+topicons

Последнне из exptension

Теперь у меня в правом верхнем углу значек с флагом, все работает.

Костыль но зато 100 % работающий, без всяких правок конфигов и прочей лабуды .

zhenya0007 ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.