LINUX.ORG.RU

KDE Screen lock - пропала форма ввода пароля

 ,


0

1

Добра всем.
После апдейта kde до версии 4.10.00 появилась такая вот беда.
После блокировки эрана тупо вываливается чёрный экран с курсором и... ничего не происходит. Ну совсем. Чтобы снова залогиниться надо перезапускать саму kde, что несколько неудобно.
Проблема проявляется независимо от того, какой тип sreen locker'а я выберу (простой или там со всякими анимашками).
И что ещё более странно, под вторым, но редко используемым пользователем проблема не воспроизводится.
Кто-нибудь сталкивался с подобным?

Archlinux x64, Nvidia 313.18


Сразу после обновления скринлок пропал вообще, сейчас всё работает. Обновись, что ли.

tyakos ★★★ ()

А режим виджетов не пробовал? У меня он грузит проц на 100% что в режиме simple, что со скринсейвером. А в режиме виджетов нормально. Возможно проблема та же, просто на разном железе проявляется по разному.

firestarter ★★★☆ ()

Так и обновился уже полностью - не помогло.
С режимом виджетов тоже самое, только вместо черного экрана картинка, вот и всё.

ffomg ()

там, вроде бы, выпилили kdescreenlock. Может у тебя остался? Проверь, что вызывает ctrl-alt-l, должен что-то типа Lock Session.

fang90 ★★★★★ ()
Последнее исправление: fang90 (всего исправлений: 1)
Ответ на: комментарий от fang90

Действительно, ctrl+alt+l вызывал kdescreenlock.
Переназначил шорткат на Lock Session, однако результат прежний. Такая вот печаль!

ffomg ()

Новый локер очень кривой. Во-первых, он у меня начинает спрашивать пароль, даже если его об этом не попросить, во-вторых, не прячет курсор. Оба бага подтверждены и уже исправлены, ждем 4.10.1. Пока гуглил, вроде, видел баги о невозможности разблокировки, но сейчас искать лень. Я пока локер убрал, оставив только отключение монитора в настройках энергосбережения.

ATIpro ★★ ()
Ответ на: комментарий от ATIpro

Только что нашёл причину - этому локеру не приглянулся QtCurve.
Если сменить тему на Oxygen, то он срабатывает нормально.
Полностью согласен про его кривость. А какие причины сподвигли их менять старый, вполне рабочий локер?

ffomg ()
Ответ на: комментарий от ffomg

Для тех, кто столкнулся с такой же проблемой на QtCurve - есть способ всё исправить.
В настройках QtCurve (System Settings - Application appearance - Configure рядом со строкой Widget style) в разделе Applications просто надо добавить исключение для локера (kscreenlocker_greet) во все строки.

ffomg ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.