LINUX.ORG.RU

Adobe Flashplayer вешает систему

 , ,


0

1

При воспроизведении любого (видео, анимации, реклама, игры) флеш-элемента система, с вероятностью процентов в 70, зависает и не отвечает ни на какие нажатия клавиш.
Браузер - Firefox(Aurora) 10.0.11, но на хромиуме те же проблемы.
До этого стоял Дебиан и была та же беда.
Может кто сталкивался с этой проблемой и знает решение?


ты бы хоть расписал конфиг флеша и железо
версия флеша?
что с аппаратным ускорением? (конфиг флеша)
что пишет при попытке запустить браузер в консоли и последующем запуске флеша?
какая карта?
какие дрова?
...
ничего же нет

megabaks ★★★★ ()

Попробуй выключить аппаратное декодирование видео. Флеш течет более чем полностью, потому заваливает в своп твою систему. Посмотри что с памятью когда он «зависает»

vertexua ★★★★☆ ()
Ответ на: комментарий от megabaks

На такой ответ я и надеялся.

версия флеша? 11.2 r202
что с аппаратным ускорением? - Где посмотреть?
что пишет при попытке запустить браузер в консоли и последующем запуске флеша? - Сейчас проверю.
какая карта? nVidia GTX460 (GF104)
какие дрова? 310.19 (С оф.сайта)

TheX ()
Ответ на: комментарий от vertexua

Кстати, своп отключен.
Памяти 8Гб, неужели ему мало?

TheX ()
Ответ на: комментарий от TheX

что с аппаратным ускорением? - Где посмотреть?

grep -v \# /etc/adobe/mms.cfg
megabaks ★★★★ ()
Ответ на: комментарий от TheX

На такой ответ я и надеялся.

Тогда почему сразу не указал в оппосте, понимерзость?

Deleted ()
Ответ на: комментарий от megabaks
grep -v \# /etc/adobe/mms.cfg
AutoUpdateDisable = 1

что пишет при попытке запустить браузер в консоли и последующем запуске флеша? - Ничего не пишет. Если перенаправить вывод в файл, то файл после перезапуска системы остаётся пустым.

TheX ()
Ответ на: комментарий от Deleted

Тогда почему сразу не указал в оппосте

оппост?
Я не знал какая конкретно информация нужна.

понимерзость

:/

TheX ()
Ответ на: комментарий от TheX

если не получается запустив флеш добраться до менюшки по ПКМ, то у меня идей больше нет

megabaks ★★★★ ()

Попробуй включить (1) или выключить (0) аппаратное ускорение в /etc/adobe/mms.cfg:

OverrideGPUValidation = 1
EnableLinuxHWVideoDecode = 1

glibych ★★ ()
Ответ на: комментарий от megabaks

Когда он запускается, он либо работает, либо намертво вешает весь ввод-вывод.

Печально.

TheX ()

А можно нажать ctrl-alt-f1 и прибить процесс plugin-container? У меня флеш просто крешится, но показывается черный экран.

goingUp ★★★★★ ()
Ответ на: комментарий от goingUp

Система не отвечает на нажатия клавиш т.е. перейти из иксов в терминал не удаётся.

TheX ()
Ответ на: комментарий от TheX

Попробуй другой драйвер. У меня x11-drivers/nvidia-drivers-295.49 и www-plugins/adobe-flash-11.2.202.258 с аппараткой работают более менее. Хотя иногда на мидори (на основе net-libs/webkit-gtk-1.6.3-r200) не открывается второй ролик, с лисой вроде нет таких проблем. Из-за этого мидори перегружать приходится иногда. Зато работает аппаратное ускорение.

glibych ★★ ()
Ответ на: комментарий от byte_men

Потомучто в репозитории на момент установки драйвера была версия, в которой не хотел грузиться GLX.

TheX ()
Ответ на: комментарий от glibych

Установил драйвер из репозиториев, флеш не перестал вешать систему, зато GLX-приложения стали работать и при том быстрее.

С драйвером, оказалось, всё в порядке, просто я дно и не прочитал инструкцию, в которой таки было описано включение GLX, отключение DRI и задействование OpenCL.



Я вот подумал, а может флеш пытается получить доступ к какой-то железке, но не получив его, заставляет систему падать. Идея эта в голову пришла т.к. udev не настроен.

TheX ()
Ответ на: комментарий от TheX

Проверь emerge -p www-plugins/adobe-flash.

Должны быть включены флаги sse2check и vdpau.

glibych ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.