LINUX.ORG.RU

как добавить нужное разрешение экрана?

 , ,


0

1

Имеется жк монитор 16:10 разрешением 1920х1200 и видеокарточка geforce9800gt с блобом 302.17 из x-swat ppa.
На максимальном разрешении игры подтормаживают и надо бы уменьшить разрешение, но в nvidia-settings отсутствуют разрешения экрана формата 16:10
скрин
В параметрах системы - экран разрешения такие же

xrandr тоже поперхнулся

xrandr -s 1680x1050
Size 1680x1050 not found in available modes

Я прописал в xorg.conf нужные разрешения в modes, но это не дало никакого эффекта не только при перезапуске иксов, но и после перезагрузки. Поэтому все изменения в xorg.conf были откачены назад.
Гугл посоветовал использовать

sudo nvidia-xconfig --mode 1680x1050

Но эта команда просто добавила в modes разрешение 1680x1050. Так как я только что это же делал, то естественно что ничего не получилось Проблему также усложняет и то, что я очень давно ничего не правил в xorg.conf, может в нём что и поменялось.

Возможно ли как-то добавить нужные разрешения, или же это баг блоба и поэтому лучше просто сидеть на ж. ровно?

здесь xorg.conf

★★★

Ответ на: комментарий от kostik87

спасибо, сейчас мне надо ехать, но завтра все modeline сгенерирую

ss_ash ★★★ ()

поставь шиндошс для игр и не мучайся. заодно, в нормальные игры поиграешь.

x4DA ★★★★★ ()

Что ты творишь? Просто измени разрешение в игре О_о

f1xmAn ★★★★★ ()
Ответ на: комментарий от kostik87

скорее всего драйвер в ppa криво собран, потому что ничего не помогло. Я откатился на 295.40, что в репозитории, и всё заработало

ss_ash ★★★ ()
Ответ на: комментарий от leave

+ f1xmAn
Игра предлагала в точности те же разрешения, что и в nvidia-settings

ss_ash ★★★ ()
Ответ на: комментарий от kostik87

Да игры-то вообще ни при чём (я раз в месяц что-нибудь запущу и всё), это просто из-за них ковыряние началось. Вся соль оказалась в том, что драйвер из ppa игнорирует настройки, а с драйвером из репозитория всё заработало, как надо.

ss_ash ★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.