LINUX.ORG.RU

Skype и Ubuntu 12.04 amd64

 ,


0

1

Привет. У меня возникла такая проблема: ставил скайп из deb пакета, скачанного с офсайта. Пакет, по их словам, для amd64, но тянет с собой кучу i386 либ. И теперь иногда при удалении некоторых пакетов, aptitude предлагает мне снести полностью все 32 битные либы, скайп, естественно, ломается. Приходится ставить его заново, и всё повторяется.

Как это лечить? Может, у меня сильно кривые PYKN?

Ответ на: комментарий от Andreitsch

Сдается мне, что дело не в пакетном менеджере, а в отсутствии где-то настроенной мультиархетиктуры. Но сейчас попробую.

jessey ()
Ответ на: комментарий от bsdfun

Здрасте, приехали. Юзаю аптитуд с самого освоения никсов -_-

jessey ()

Пакет, по их словам, для amd64, но тянет с собой кучу i386 либ.

Всё ок, 64-разрядной сборки skype в природе не существует.

И теперь иногда при удалении некоторых пакетов, aptitude предлагает мне снести полностью все 32 битные либы, скайп, естественно, ломается. Приходится ставить его заново, и всё повторяется.

Возможно aptitue считает, что skype был установлен автоматически по зависимости от другого пакета и больше не нужен. Попробуй

aptitude unmarkauto skype

Deleted ()
Ответ на: комментарий от jessey

Теперь не трогает, потому что ты уже прописал skype как явно установленный.

delete83 ★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.