LINUX.ORG.RU

нет 3d ускорения xf86-video-ati в арче


0

1

где-то с год-полтора назад в арче с этим драйвером(xf86-video-ati) играл в кваку3, glxgears показывал fps около 1600, сейчас лишь 140. libgl, ati-dri, mesa - все стоит, xorg.conf сгенерирован и вписан туда драйвер radeon, все в точности как тогда, когда работало. Не пойму в чем дело, карта Radeon HD 2600, господа арчеводы, подскажите нубу что вы со свободными дровами делаете?

Deleted

что вы со свободными дровами делаете?

Меняем на проприетарные.

f1xmAn ★★★★★ ()

xorg.conf сгенерирован

А это зачем? Все будет работать и без него. Ну и логи загрузки иксов давай.

сейчас лишь 140

Что пишет «glxinfo | grep direct»?

ATIpro ★★ ()

Кроме низкого fps проблемы ещё есть? В тексте не видно, что ещё не работает.

Ничего не делаем, просто пользуемся.

kid_lester ()

glxgers: Running synchronized to the vertical refresh. The framerate should be approximately the same as the monitor refresh rate

vladkuzm ()
Ответ на: комментарий от vladkuzm

оказалось у меня vesa работала вместо ati, обнаружил забавный файлик /etc/xorg.conf.d/20-gpudriver.conf, в котором была прописана vesa, поменял на ati, vesa удалил. Теперь glxgears выдает именно это: glxgers: Running synchronized to the vertical refresh. The framerate should be approximately the same as the monitor refresh rate fps естественно низкий. Что-то невнятное нагуглил у гентушников, особо еще не смотрел, если знаешь как вырубить эту синхронизацию, то подскажи, будь любезен.

Deleted ()
Ответ на: комментарий от vladkuzm

да, и еще: $ vblank_mode=0 glxgears

fps около 1000, работает то есть.

Deleted ()

Господа, проблема решена отключением вертикальной синхронизации путем созданием файлика ~/.drirc следующего содержания:

<driconf>

<device screen=«0» driver=«dri2»>

<application name=«Default»>

<option name=«vblank_mode» value=«0» />

</application>

</device>

</driconf>

Всем спасибо.

Deleted ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.