LINUX.ORG.RU

[fglrx, Debian testing, gnome 3] вылетают иксы при воспроизведении видео


0

1

И снова проблемы! После обновления gnome до 3-ей версии, а также после всех этих проблем с совместимостью xserver-xorg и fglrx... В общем накатил я последние апдейты: fglrx 11.11 и xserver-xorg 1.11. В результате чего при попытке воспроизведения видео в любом из плееров вылетаю иксы.

Xorg.0.log.old:

Backtrace:
[  3758.395] 0: /usr/bin/Xorg (xorg_backtrace+0x26) [0x7ff1f15f48f6]
[  3758.395] 1: /usr/bin/Xorg (0x7ff1f1470000+0x188559) [0x7ff1f15f8559]
[  3758.395] 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7ff1f0798000+0xf020) [$
[  3758.395] 3: /usr/lib/xorg/modules/drivers/fglrx_drv.so (xs111LookupPrivate+$
[  3758.396] 4: /usr/lib/xorg/modules/drivers/fglrx_drv.so (xclLookupPrivate+0x$
[  3758.396] 5: /usr/lib/xorg/modules/amdxmm.so (X740XvPutImage+0x12e) [0x7ff1e$
[  3758.396] 6: /usr/bin/Xorg (0x7ff1f1470000+0xa693e) [0x7ff1f151693e]
[  3758.396] 7: /usr/lib/xorg/modules/extensions/libextmod.so (0x7ff1ed347000+0$
[  3758.396] 8: /usr/bin/Xorg (0x7ff1f1470000+0x51f59) [0x7ff1f14c1f59]
[  3758.396] 9: /usr/bin/Xorg (0x7ff1f1470000+0x411ba) [0x7ff1f14b11ba]
[  3758.396] 10: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xfd) [0x7f$
[  3758.396] 11: /usr/bin/Xorg (0x7ff1f1470000+0x414ad) [0x7ff1f14b14ad]
[  3758.396] Segmentation fault at address 0x20
Fatal server error:
[  3758.396] Caught signal 11 (Segmentation fault). Server aborting
[  3758.396]
[  3758.396]
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.

Также в messages появилась ругань pulseaudio:

Nov 20 15:15:38 dragonfly pulseaudio[1206]: [pulseaudio] alsa-mixer.c: Volume element Master has 8 channels. That's too much! I can't handle that!

Я так понимаю pulseaudio притащил gnome 3, до него у меня этого отродясь не было.

Ну и при установке пакетов выдает:

Gtk-Message **: Failed to load module "pk-gtk-module" at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 97, <> line 1.
Gtk-Message **: Failed to load module "pk-gtk-module" at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 103, <> line 1.

про последнее нагуглилось что-то, доустановил недостающие пакеты, но не помогло.

Да, и gnome-shell не работает вообще.

★★★

У меня так же, только у меня kde. workaround: mplayer -vo gl

ptah_alexs ★★★★★ ()
Ответ на: комментарий от ptah_alexs

Аналогичная проблема. Странно, но при запуске команды mplayer -vo gl на выходе получаю результат как-будто я подал mplayer -help. Пробовал в конце ставить запятую (в хелпе написано, что в этом случае будет использовать драйвер не из списка в случае проблем) - эффект тот же. Хотя mplayer -vo help выдает список драйверов. С чего бы это? Заранее спасибо. И не могли бы вы объяснить в чем проблема,когда запускаешь проигрыватель без указания драйвера вывода?

anonymous ()
Ответ на: комментарий от anonymous

Я в гуе настроил. Preferences, Video, Available drivers: gl OpenGL

MikeB ★★★ ()
Ответ на: комментарий от ptah_alexs

Спасибо за ответы. Но странная ситуация тут получается, для начала попробовал редактировать конфиг - не помогает, причем я заметил такую вещь, что mplayer в принципе из командной строки не запускается, а выдает help, я вчера думал, что это из-за ключей.... Спасает только gui настройка.... Хотелось бы конечно разобраться, но временеи нету... Так что пока обойдусь тем что есть.. Еще раз спасибо. И конечно непонятно как это все работало до обновлений.

anonymous ()
Ответ на: комментарий от anonymous

mplayer в принципе из командной строки не запускается, а выдает help, я вчера думал, что это из-за ключей

ему нужно аргументом медиафайл скормить.

Komintern ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.