LINUX.ORG.RU

Mandriva-2011 установка драйвера видеокарты


0

1

Здравствуйте! Извиняюсь если не там написал, я плохо ориентируюсь на форуме. Я установил себе Mandriva 2011. Но так как моя wi-fi карта не работает у меня нет интернета в Linux. Поэтому я скачиваю сам rpm пакеты и ставлю. Я установил проприетарный драйвер NVIDIA. У меня видеокарта NVIDIA 8600GTS

Скачал и установил следующие пакеты: dkms-nvidia-current-280.13 nvidia-current-doc-html-280.13 x11-driver-video-nvidia-current-280.13

В настройках Мандривы выбрал видеокарту NVIDIA после чего система спросила у меня — использовать проприетарный драйвер или нет.

Вобщем у меня этот драйвер плохо работает в играх. Например в игре Doom 3 все слишком темное. То есть ничего почти не видно. Игра для Linux. Я хотел спросить — все ли я правильно поставил? Может еще что нужно поставить?

Драйвер с официального сайта NVIDIA *.run не хочет ставится.

Может мне лучше поставить другую видеокарту, например ATI HD 2600XT ? Дело в том что с видеокартой ATI у меня система виснет при установке. Ставится только с nomodeset (как мне подсказали). Но после перезагрузки когда надо заводить пользователей в конце установки все равно все виснет.

Может как нибудь удастся установить систему с видеокартой ATI ? Может с драйверами ATI будет нормально работать игра Doom 3?

Подскажите пожалуйста.

Впринципе у меня есть еще старая видеокарта ATI x700 PRO. Если ничего не получится, можно ее попробовать поставить.


>Например в игре Doom 3 все слишком темное.

Так и задумано

Может мне лучше поставить другую видеокарту

Лучше играй в другую игру, более «светлую».

Led ★★★☆☆ ()
Ответ на: комментарий от Led

Да нет ))) Там некорректно игра отображается. Даже людей не видно, все черное. Драйвер NVIDIA плохой наверное.

revers ()

Например в игре Doom 3 все слишком темное.

А в игре не пробовал в настройках покопаться?

Драйвер с официального сайта NVIDIA *.run не хочет ставится.

Что значит не хочет ставиться?

Но так как моя wi-fi карта не работает у меня нет интернета в Linux.

Может сначала с этим надо разобраться? Интернет в последующей настройке был бы полезен.

mopsene ★★★ ()
Ответ на: комментарий от mopsene

Настройки игры у меня сделаны заранее. Я с этими настройками раньше играл в Mandriva 2008 например. Я два файлика кидаю чтобы снова не настраивать - там все ok.

Что значит не хочет ставиться?

ошибки пишет. Я не запомнил какие. Попозже приведу. Драйвер для wi-fi карты у меня на новых дистрибутивах на собирается. Для Mandriva 2008.1 он собирался. Я для 2011 не собирается. Карта wi-fi ASUS USB-N10 Там драйвер из исходников надо собирать. Но для новых дистрибутивов он не собирается. Использовать драйвер от виндоус тоже не получается. Так что сделать интернет я не надеюсь )))

revers ()
Ответ на: комментарий от revers

Там драйвер из исходников надо собирать. Но для новых дистрибутивов он не собирается.

4.2. Что делал? Какое ядро?

mopsene ★★★ ()
Ответ на: комментарий от mopsene

Ядро 2.6.38.7-desktop-1mnb2

Я так понимаю что для того чтобы собирать драйвер надо установить только kernel-devel. Они вроде установлены уже при установке системы я смотрел.

Я пишу команду make и make install.

При сборке драйвера для wi-fi карты пишет примерно следующее

make[1]: Вход в каталог `/usr/src/linux-2.6.38.7-desktop-1mnb2'

CC [M] /home/pony/rtl/HAL/rtl8192u/r8192U_core.o

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c: В функции «proc_get_registers_0»:

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c:708:22: предупреждение: variable «page2» set but not used [-Wunused-but-set-variable]

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c:708:16: предупреждение: variable «page1» set but not used [-Wunused-but-set-variable]

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c: В функции «rtl8192_hard_data_xmit»:

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c:2151:6: предупреждение: variable «ret» set but not used [-Wunused-but-set-variable]

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c: В функции «rtl8192SU_tx»:

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c:3330:27: предупреждение: variable «broad_addr» set but not used [-Wunused-but-set-variable]

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c:3326:7: предупреждение: variable «MPDUOverhead» set but not used [-Wunused-but-set-variable]

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c: В функции «rtl8192SU_MacConfigAfterFwDownload»:

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c:7839:24: предупреждение: comparison between «rtl819xUsb_loopback_e» and «enum _RTL8192SUSB_LOOPBACK» [-Wenum-compare]

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c:7841:30: предупреждение: comparison between «rtl819xUsb_loopback_e» and «enum _RTL8192SUSB_LOOPBACK» [-Wenum-compare]

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c: В функции «rtl8192SU_HwConfigureRTL8192SUsb»:

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c:7905:8: предупреждение: variable «regRATR» set but not used [-Wunused-but-set-variable]

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c: В функции «rtl8192_commit»:

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c:9866:6: предупреждение: variable «reset_status» set but not used [-Wunused-but-set-variable]

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c: В функции «rtl8192_process_phyinfo»:

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c:10286:15: предупреждение: variable «frag» set but not used [-Wunused-but-set-variable]

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c: В функции «rtl8192SU_query_rxphystatus»:

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c:10577:44: предупреждение: variable «prxsc» set but not used [-Wunused-but-set-variable]

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c: В функции «rtl819xusb_process_received_packet»:

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c:11994:10: предупреждение: variable «frame_len» set but not used [-Wunused-but-set-variable]

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c:11993:7: предупреждение: variable «frame» set but not used [-Wunused-but-set-variable] /home/pony/rtl/HAL/rtl8192u/r8192U_core.c: В функции «rtl8192_usb_probe»:

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c:12317:5: ошибка: «struct net_device» не содержит элемента с именем «open»

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c:12318:5: ошибка: «struct net_device» не содержит элемента с именем «stop»

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c:12319:5: ошибка: «struct net_device» не содержит элемента с именем «tx_timeout»

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c:12320:5: ошибка: «struct net_device» не содержит элемента с именем «do_ioctl»

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c:12321:5: ошибка: «struct net_device» не содержит элемента с именем «set_multicast_list»

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c:12322:5: ошибка: «struct net_device» не содержит элемента с именем «set_mac_address»

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c:12323:5: ошибка: «struct net_device» не содержит элемента с именем «get_stats»

/home/pony/rtl/HAL/rtl8192u/r8192U_core.c:12324:6: ошибка: «struct net_device» не содержит элемента с именем «hard_start_xmit»

make[2]: *** [/home/pony/rtl/HAL/rtl8192u/r8192U_core.o] Ошибка 1

make[1]: *** [_module_/home/pony/rtl/HAL/rtl8192u] Ошибка 2

make[1]: Выход из каталога `/usr/src/linux-2.6.38.7-desktop-1mnb2'

make: *** [all] Ошибка 2

revers ()

Вот сейчас поставил видеокарту ATI HD 2600XT. С этой видеокартой при установке компьютер вис. Но я проинсталировал дистрибутив с видеокартой NVIDIA, потом поставил видеокарту ATI и запустил XFdrake. Потом скачал драйвер ati-drivеr*.run с сайта ati.amd. Этот драйвер поставился хорошо. Игра Doom 3 пошла но все такое же черное. Тоже самое что и на видеокарте NVIDIA.

Значит драйвер не причем. Дело в самом дистрибутиве. Вот что пишет в консоли Doom 3, может это что-то говорит:

WARNING: idAFTree::Factor: couldn't invert 5x5 matrix for constraint 'lankle'

WARNING: idAFTree::Factor: couldn't invert 5x5 matrix for constraint 'lloleg'

WARNING: idAFTree::Factor: couldn't invert 5x5 matrix for constraint 'lankle'

WARNING: idAFTree::Factor: couldn't invert 5x5 matrix for constraint 'lloleg'

WARNING: idAFTree::Factor: couldn't invert 5x5 matrix for constraint 'lankle'

WARNING: idAFTree::Factor: couldn't invert 5x5 matrix for constraint 'lloleg'

WARNING: idAFTree::Factor: couldn't invert 5x5 matrix for constraint 'lankle'

WARNING: idAFTree::Factor: couldn't invert 5x5 matrix for constraint 'lloleg'

revers ()

>Вобщем у меня этот драйвер плохо работает в играх. Например в игре Doom 3 все слишком темное. То есть ничего почти не видно. Игра для Linux. Я хотел спросить — все ли я правильно поставил? Может еще что нужно поставить?

nvidia-settings запусти и там гамму настрой или

xgamma -gamma 2.0 попробуй

к качеству работы драйвера это никак не относится.

dikiy ★★☆☆☆ ()

Я бы, на вашем месте, проверил настройки игры. В первую очередь.

Axon ★★★★★ ()

В других играх (первом думе с каким-нибудь opengl-ным портом, например) так же?

anonymousss ★★ ()

Вобщем поставил я еще Quake 4. Вобщем то тоже самое. Все темное и вместо дверей артефакты. Если фонарик включить то еще что то видно. В меню игры пропадают слова. Иногда видны пункты меню - «новая игра» или «загрузка», а иногда их не видно. Мне новая мандрива понравилась, но наверное вряд ли получится что то сделать. Я вот скачал предыдущую Мандриву 2010.2 Надо ее поставить.

revers ()
Ответ на: комментарий от RussianNeuroMancer

На атишной видеокарте тоже самое...

алсо: Ну вобщем я поставил Мандриву 2010.2 там игры заработали нормально.

revers ()
Ответ на: комментарий от revers

На атишной видеокарте тоже самое...
Хм, любопытно. В таком случае с ходу угадать причину не берусь. Возможно какая-то особенность 2011-й Мандривы.

RussianNeuroMancer ★★★★★ ()
Вы не можете добавлять комментарии в эту тему. Тема перемещена в архив.